Update to 3.6.0
- Drop the -Werror patch; applied upstream - Add glib-compile-schemas scriptlets - Relicensed from LGPLv2+ to GPLv2+
This commit is contained in:
parent
a70443027d
commit
fc97b8ffb9
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@ gnome-disk-utility-2.30.1.tar.bz2
|
|||||||
/gnome-disk-utility-3.5.1.tar.xz
|
/gnome-disk-utility-3.5.1.tar.xz
|
||||||
/gnome-disk-utility-3.5.2.tar.xz
|
/gnome-disk-utility-3.5.2.tar.xz
|
||||||
/gnome-disk-utility-3.5.3.tar.xz
|
/gnome-disk-utility-3.5.3.tar.xz
|
||||||
|
/gnome-disk-utility-3.6.0.tar.xz
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
From 196c25d2a01e905b4f03baf6414155a755fd16eb Mon Sep 17 00:00:00 2001
|
|
||||||
From: David Zeuthen <zeuthen@gmail.com>
|
|
||||||
Date: Fri, 27 Jul 2012 14:33:01 -0400
|
|
||||||
Subject: [PATCH] Replace -Werror=foo with -Wfoo
|
|
||||||
|
|
||||||
Signed-off-by: David Zeuthen <zeuthen@gmail.com>
|
|
||||||
---
|
|
||||||
configure.ac | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index ae56f84..c161cbc 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -35,9 +35,9 @@ CC_CHECK_CFLAGS_APPEND([ \
|
|
||||||
-Wcast-align \
|
|
||||||
-Wdeclaration-after-statement \
|
|
||||||
-Wendif-labels \
|
|
||||||
- -Werror=format-security \
|
|
||||||
- -Werror=implicit-function-declaration \
|
|
||||||
- -Werror=overflow \
|
|
||||||
+ -Wformat-security \
|
|
||||||
+ -Wimplicit-function-declaration \
|
|
||||||
+ -Woverflow \
|
|
||||||
-Wformat-nonliteral \
|
|
||||||
-Wformat=2 \
|
|
||||||
-Wimplicit \
|
|
||||||
--
|
|
||||||
1.7.11.2
|
|
||||||
|
|
@ -1,22 +1,20 @@
|
|||||||
%define glib2_version 2.31.0
|
%define glib2_version 2.31.0
|
||||||
%define gtk3_version 3.3.11
|
%define gtk3_version 3.5.8
|
||||||
%define udisks_version 1.99.0
|
%define udisks_version 1.99.0
|
||||||
|
|
||||||
# Only enable if using patches that touches configure.ac,
|
# Only enable if using patches that touches configure.ac,
|
||||||
# Makefile.am or other build system related files
|
# Makefile.am or other build system related files
|
||||||
#
|
#
|
||||||
%define enable_autoreconf 1
|
%define enable_autoreconf 0
|
||||||
|
|
||||||
Summary: Disks
|
Summary: Disks
|
||||||
Name: gnome-disk-utility
|
Name: gnome-disk-utility
|
||||||
Version: 3.5.3
|
Version: 3.6.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://git.gnome.org/browse/gnome-disk-utility
|
URL: http://git.gnome.org/browse/gnome-disk-utility
|
||||||
Source0: http://download.gnome.org/sources/gnome-disk-utility/3.5/%{name}-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/gnome-disk-utility/3.6/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
Patch0: gnome-disk-utility-3.5.3-Replace-Werror-foo-with-Wfoo.patch
|
|
||||||
|
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
BuildRequires: gtk3-devel >= %{gtk3_version}
|
BuildRequires: gtk3-devel >= %{gtk3_version}
|
||||||
@ -55,7 +53,6 @@ fstab/crypttab editing, ATA SMART and other features
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if 0%{?enable_autoreconf}
|
%if 0%{?enable_autoreconf}
|
||||||
@ -81,21 +78,22 @@ update-desktop-database %{_datadir}/applications &> /dev/null
|
|||||||
%postun
|
%postun
|
||||||
update-desktop-database %{_datadir}/applications &> /dev/null
|
update-desktop-database %{_datadir}/applications &> /dev/null
|
||||||
if [ $1 -eq 0 ] ; then
|
if [ $1 -eq 0 ] ; then
|
||||||
|
glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
|
||||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
||||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
fi
|
fi
|
||||||
|
|
||||||
%posttrans
|
%posttrans
|
||||||
|
glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
|
||||||
gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
|
gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
|
||||||
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root,-)
|
|
||||||
|
|
||||||
%{_bindir}/gnome-disks
|
%{_bindir}/gnome-disks
|
||||||
%{_bindir}/gnome-disk-image-mounter
|
%{_bindir}/gnome-disk-image-mounter
|
||||||
%{_datadir}/applications/gnome-disks.desktop
|
%{_datadir}/applications/gnome-disks.desktop
|
||||||
%{_datadir}/applications/gnome-disk-image-mounter.desktop
|
%{_datadir}/applications/gnome-disk-image-mounter.desktop
|
||||||
|
%{_datadir}/glib-2.0/schemas/org.gnome.Disks.gschema.xml
|
||||||
|
|
||||||
%dir %{_datadir}/gnome-disk-utility
|
%dir %{_datadir}/gnome-disk-utility
|
||||||
%{_datadir}/gnome-disk-utility/*.ui
|
%{_datadir}/gnome-disk-utility/*.ui
|
||||||
@ -106,6 +104,12 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
|
|||||||
%doc README AUTHORS NEWS COPYING
|
%doc README AUTHORS NEWS COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Sep 22 2012 Kalev Lember <kalevlember@gmail.com> - 3.6.0-1
|
||||||
|
- Update to 3.6.0
|
||||||
|
- Drop the -Werror patch; applied upstream
|
||||||
|
- Add glib-compile-schemas scriptlets
|
||||||
|
- Relicensed from LGPLv2+ to GPLv2+
|
||||||
|
|
||||||
* Fri Jul 27 2012 David Zeuthen <davidz@redhat.com> - 3.5.3-2%{?dist}
|
* Fri Jul 27 2012 David Zeuthen <davidz@redhat.com> - 3.5.3-2%{?dist}
|
||||||
- Avoid treating warnings as errors
|
- Avoid treating warnings as errors
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user