Update to 3.14.0
This commit is contained in:
parent
b4c88f34b9
commit
7b83698001
1
.gitignore
vendored
1
.gitignore
vendored
@ -26,3 +26,4 @@ gnome-disk-utility-2.30.1.tar.bz2
|
||||
/gnome-disk-utility-3.11.0.tar.xz
|
||||
/gnome-disk-utility-3.12.0.tar.xz
|
||||
/gnome-disk-utility-3.12.1.tar.xz
|
||||
/gnome-disk-utility-3.14.0.tar.xz
|
||||
|
@ -1,66 +0,0 @@
|
||||
From cdbb0497d9536d81b24abe166ab7c7834fd18e8f Mon Sep 17 00:00:00 2001
|
||||
From: Yosef Or Boczko <yoseforb@src.gnome.org>
|
||||
Date: Thu, 1 May 2014 19:46:20 +0200
|
||||
Subject: Fix headerbar item positions
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=729349
|
||||
|
||||
Signed-off-by: David Zeuthen <zeuthen@gmail.com>
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ebdd5b0..6ecfbe3 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -104,7 +104,7 @@ AC_MSG_RESULT([no])])
|
||||
|
||||
GLIB2_REQUIRED=2.31.0
|
||||
UDISKS2_REQUIRED=2.1.1
|
||||
-GTK3_REQUIRED=3.10.0
|
||||
+GTK3_REQUIRED=3.12.0
|
||||
LIBSECRET1_REQUIRED=0.7
|
||||
PWQUALITY_REQUIRED=1.0.0
|
||||
CANBERRA_REQUIRED=0.1
|
||||
diff --git a/src/disks/gduwindow.c b/src/disks/gduwindow.c
|
||||
index 24834ce..f8710d6 100644
|
||||
--- a/src/disks/gduwindow.c
|
||||
+++ b/src/disks/gduwindow.c
|
||||
@@ -978,26 +978,27 @@ create_header (GduWindow *window)
|
||||
header = gtk_header_bar_new ();
|
||||
gtk_header_bar_set_show_close_button (GTK_HEADER_BAR (header), TRUE);
|
||||
|
||||
- button = window->devtab_drive_loop_detach_button = gtk_button_new ();
|
||||
- image = gtk_image_new_from_icon_name ("list-remove-symbolic", GTK_ICON_SIZE_MENU);
|
||||
+ button = window->devtab_drive_generic_button = gtk_menu_button_new ();
|
||||
+ gtk_menu_button_set_popup (GTK_MENU_BUTTON (button), window->generic_drive_menu);
|
||||
+ image = gtk_image_new_from_icon_name ("emblem-system-symbolic", GTK_ICON_SIZE_MENU);
|
||||
gtk_button_set_image (GTK_BUTTON (button), image);
|
||||
gtk_header_bar_pack_end (GTK_HEADER_BAR (header), button);
|
||||
|
||||
- button = window->devtab_drive_eject_button = gtk_button_new ();
|
||||
- image = gtk_image_new_from_icon_name ("media-eject-symbolic", GTK_ICON_SIZE_MENU);
|
||||
+ button = window->devtab_drive_power_off_button = gtk_button_new ();
|
||||
+ image = gtk_image_new_from_icon_name ("system-shutdown-symbolic", GTK_ICON_SIZE_MENU);
|
||||
gtk_button_set_image (GTK_BUTTON (button), image);
|
||||
gtk_header_bar_pack_end (GTK_HEADER_BAR (header), button);
|
||||
|
||||
- button = window->devtab_drive_power_off_button = gtk_button_new ();
|
||||
- image = gtk_image_new_from_icon_name ("system-shutdown-symbolic", GTK_ICON_SIZE_MENU);
|
||||
+ button = window->devtab_drive_eject_button = gtk_button_new ();
|
||||
+ image = gtk_image_new_from_icon_name ("media-eject-symbolic", GTK_ICON_SIZE_MENU);
|
||||
gtk_button_set_image (GTK_BUTTON (button), image);
|
||||
gtk_header_bar_pack_end (GTK_HEADER_BAR (header), button);
|
||||
|
||||
- button = window->devtab_drive_generic_button = gtk_menu_button_new ();
|
||||
- gtk_menu_button_set_popup (GTK_MENU_BUTTON (button), window->generic_drive_menu);
|
||||
- image = gtk_image_new_from_icon_name ("emblem-system-symbolic", GTK_ICON_SIZE_MENU);
|
||||
+ button = window->devtab_drive_loop_detach_button = gtk_button_new ();
|
||||
+ image = gtk_image_new_from_icon_name ("list-remove-symbolic", GTK_ICON_SIZE_MENU);
|
||||
gtk_button_set_image (GTK_BUTTON (button), image);
|
||||
gtk_header_bar_pack_end (GTK_HEADER_BAR (header), button);
|
||||
+
|
||||
return header;
|
||||
}
|
||||
|
||||
--
|
||||
cgit v0.10.1
|
||||
|
@ -1,19 +1,17 @@
|
||||
# Only enable if using patches that touches configure.ac,
|
||||
# Makefile.am or other build system related files
|
||||
#
|
||||
%define enable_autoreconf 1
|
||||
%define enable_autoreconf 0
|
||||
|
||||
Name: gnome-disk-utility
|
||||
Version: 3.12.1
|
||||
Release: 7%{?dist}
|
||||
Version: 3.14.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Disks
|
||||
|
||||
Group: Applications/System
|
||||
License: GPLv2+
|
||||
URL: https://git.gnome.org/browse/gnome-disk-utility
|
||||
Source0: https://download.gnome.org/sources/%{name}/3.12/%{name}-%{version}.tar.xz
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=729349
|
||||
Patch0: gnome-disk-utility-3.12.1-fix-header-bar-item-positions.patch
|
||||
Source0: https://download.gnome.org/sources/%{name}/3.14/%{name}-%{version}.tar.xz
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: docbook-style-xsl
|
||||
@ -49,7 +47,6 @@ fstab/crypttab editing, ATA SMART and other features
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -114,6 +111,9 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Nov 12 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-1
|
||||
- Update to 3.14.0
|
||||
|
||||
* Tue Oct 07 2014 David King <amigadave@amigadave.com> - 3.12.1-7
|
||||
- Remove obsolete Obsoletes (#1002112)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user