Update to 42.rc
This commit is contained in:
parent
dcef09d205
commit
bee2009027
1
.gitignore
vendored
1
.gitignore
vendored
@ -43,3 +43,4 @@
|
||||
/gnome-control-center-41.2.tar.xz
|
||||
/gnome-control-center-41.4.tar.xz
|
||||
/gnome-control-center-42.beta.tar.xz
|
||||
/gnome-control-center-42.rc.tar.xz
|
||||
|
@ -1,69 +0,0 @@
|
||||
From 9401881a38dbfd46559c75c72a9b8161e528a915 Mon Sep 17 00:00:00 2001
|
||||
From: Dor Askayo <dor.askayo@gmail.com>
|
||||
Date: Sun, 20 Feb 2022 01:26:12 +0200
|
||||
Subject: [PATCH] common: Add a missing dependency on cc-common-resources.h
|
||||
|
||||
cc-common-resources.h is used by both libwidgets and liblanguage, and
|
||||
so must be generated before they build. However, Meson wasn't aware
|
||||
of this dependency which resulted in a race condition during build.
|
||||
|
||||
Conveniently, "generates_sources_dep" already contains other generated
|
||||
sources used by these two libraries, so adding cc-common-resources.h
|
||||
to this list is enough to declare the dependency.
|
||||
---
|
||||
panels/common/meson.build | 32 ++++++++++++++++----------------
|
||||
1 file changed, 16 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/panels/common/meson.build b/panels/common/meson.build
|
||||
index 20b9dcf16..13557c1ff 100644
|
||||
--- a/panels/common/meson.build
|
||||
+++ b/panels/common/meson.build
|
||||
@@ -24,6 +24,22 @@ common_sources += gnome.mkenums(
|
||||
vtail: ' { 0, NULL, NULL }\n };\n etype = g_@type@_register_static ("@EnumName@", values);\n }\n return etype;\n}\n'
|
||||
)
|
||||
|
||||
+resource_data = files(
|
||||
+ 'cc-language-chooser.ui',
|
||||
+ 'cc-language-row.ui',
|
||||
+ 'cc-list-row.ui',
|
||||
+ 'cc-time-editor.ui',
|
||||
+ 'cc-permission-infobar.ui',
|
||||
+)
|
||||
+
|
||||
+common_sources += gnome.compile_resources(
|
||||
+ 'cc-common-resources',
|
||||
+ 'common.gresource.xml',
|
||||
+ c_name: 'cc_common',
|
||||
+ dependencies: resource_data,
|
||||
+ export: true
|
||||
+)
|
||||
+
|
||||
generates_sources_dep = declare_dependency(
|
||||
sources: common_sources,
|
||||
)
|
||||
@@ -55,22 +71,6 @@ sources = common_sources + files(
|
||||
'cc-util.c'
|
||||
)
|
||||
|
||||
-resource_data = files(
|
||||
- 'cc-language-chooser.ui',
|
||||
- 'cc-language-row.ui',
|
||||
- 'cc-list-row.ui',
|
||||
- 'cc-time-editor.ui',
|
||||
- 'cc-permission-infobar.ui',
|
||||
-)
|
||||
-
|
||||
-sources += gnome.compile_resources(
|
||||
- 'cc-common-resources',
|
||||
- 'common.gresource.xml',
|
||||
- c_name: 'cc_common',
|
||||
- dependencies: resource_data,
|
||||
- export: true
|
||||
-)
|
||||
-
|
||||
deps = common_deps + [
|
||||
generates_sources_dep,
|
||||
gnome_desktop_dep,
|
||||
--
|
||||
GitLab
|
||||
|
@ -12,7 +12,7 @@
|
||||
%global tarball_version %%(echo %{version} | tr '~' '.')
|
||||
|
||||
Name: gnome-control-center
|
||||
Version: 42~beta
|
||||
Version: 42~rc
|
||||
Release: %autorelease
|
||||
Summary: Utilities to configure the GNOME desktop
|
||||
|
||||
@ -22,8 +22,6 @@ Source0: https://download.gnome.org/sources/gnome-control-center/42/gnome
|
||||
|
||||
# https://gitlab.gnome.org/GNOME/gnome-control-center/-/merge_requests/965
|
||||
Patch0: distro-logo.patch
|
||||
# https://gitlab.gnome.org/GNOME/gnome-control-center/-/merge_requests/1229
|
||||
Patch1: gnome-control-center-42.beta-s390-resources.patch
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: cups-devel
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnome-control-center-42.beta.tar.xz) = 6ede2f8856dd76a14c172d1ccdcaf46d5167a648ab0676ceb588637cb6d4c1b417c6e62c41b2a3c5cfd51657c45cf59b59d0d2864d5ba054a209e3f2c3598125
|
||||
SHA512 (gnome-control-center-42.rc.tar.xz) = 910f24475992d86a735dd592182c8659ef2c4656dc5f4ed5d8f7f1ae1851274059dfb3be0392191dc0aa92ed06fd96b722f655ac118b239f4bf749740fa3a5b5
|
||||
|
Loading…
Reference in New Issue
Block a user