Update to 41.beta

This commit is contained in:
Michael Catanzaro 2021-08-23 09:15:54 -05:00
parent aaf18e4370
commit a84d66ccd2
4 changed files with 37 additions and 59 deletions

1
.gitignore vendored
View File

@ -36,3 +36,4 @@
/gnome-control-center-40.beta.tar.xz /gnome-control-center-40.beta.tar.xz
/gnome-control-center-40.rc.tar.xz /gnome-control-center-40.rc.tar.xz
/gnome-control-center-40.0.tar.xz /gnome-control-center-40.0.tar.xz
/gnome-control-center-41.beta.tar.xz

View File

@ -1,7 +1,7 @@
From 4369e31ec541172e1c0d7c64645c7990e413bbca Mon Sep 17 00:00:00 2001 From abde4f40c257db149be708fb66c805cc58f80a13 Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@gnome.org> From: Michael Catanzaro <mcatanzaro@gnome.org>
Date: Tue, 9 Mar 2021 14:51:54 -0600 Date: Tue, 9 Mar 2021 14:51:54 -0600
Subject: [PATCH 1/3] info-overview: add build option to control distributor Subject: [PATCH 1/2] info-overview: add build option to control distributor
logo logo
Currently, we display a 256x256 version of the OS icon from Currently, we display a 256x256 version of the OS icon from
@ -22,7 +22,7 @@ this.
3 files changed, 11 insertions(+) 3 files changed, 11 insertions(+)
diff --git a/meson.build b/meson.build diff --git a/meson.build b/meson.build
index e8333c0da..1661caa4b 100644 index 42a9536b4..94c8abfbb 100644
--- a/meson.build --- a/meson.build
+++ b/meson.build +++ b/meson.build
@@ -50,6 +50,12 @@ foreach define: set_defines @@ -50,6 +50,12 @@ foreach define: set_defines
@ -48,10 +48,10 @@ index 1b7b54810..93e551373 100644
option('malcontent', type: 'boolean', value: false, description: 'build with malcontent support') option('malcontent', type: 'boolean', value: false, description: 'build with malcontent support')
+option('distributor_logo', type: 'string', description: 'absolute path to distributor logo for the About panel') +option('distributor_logo', type: 'string', description: 'absolute path to distributor logo for the About panel')
diff --git a/panels/info-overview/cc-info-overview-panel.c b/panels/info-overview/cc-info-overview-panel.c diff --git a/panels/info-overview/cc-info-overview-panel.c b/panels/info-overview/cc-info-overview-panel.c
index bd0e07762..95a5904df 100644 index 9ee9d2910..ce1493f7c 100644
--- a/panels/info-overview/cc-info-overview-panel.c --- a/panels/info-overview/cc-info-overview-panel.c
+++ b/panels/info-overview/cc-info-overview-panel.c +++ b/panels/info-overview/cc-info-overview-panel.c
@@ -869,6 +869,9 @@ cc_info_panel_row_activated_cb (CcInfoOverviewPanel *self, @@ -901,6 +901,9 @@ get_asset_suffix (CcInfoOverviewPanel *panel)
static void static void
setup_os_logo (CcInfoOverviewPanel *panel) setup_os_logo (CcInfoOverviewPanel *panel)
{ {
@ -59,24 +59,23 @@ index bd0e07762..95a5904df 100644
+ gtk_image_set_from_file (panel->os_logo, DISTRIBUTOR_LOGO); + gtk_image_set_from_file (panel->os_logo, DISTRIBUTOR_LOGO);
+#else +#else
g_autofree char *logo_name = g_get_os_info ("LOGO"); g_autofree char *logo_name = g_get_os_info ("LOGO");
if (logo_name != NULL) g_autofree char *logo_name_with_variant = NULL;
{
@@ -879,6 +882,7 @@ setup_os_logo (CcInfoOverviewPanel *panel) @@ -910,6 +913,7 @@ setup_os_logo (CcInfoOverviewPanel *panel)
{ logo_name_with_variant = g_strdup_printf ("%s-text%s", logo_name, get_asset_suffix (panel));
gtk_image_set_from_resource (panel->os_logo, "/org/gnome/control-center/info-overview/GnomeLogoVerticalMedium.svg"); gtk_image_set_from_icon_name (panel->os_logo, logo_name_with_variant, GTK_ICON_SIZE_INVALID);
} gtk_image_set_pixel_size (panel->os_logo, -1);
+#endif +#endif
} }
static void static void
-- --
GitLab 2.31.1
From 2fa7e314ded37254f85910f7b5da74aeae67c841 Mon Sep 17 00:00:00 2001
From f08669767ca87ff99fc08e1a7334c8f2e7f18f0b Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@gnome.org> From: Michael Catanzaro <mcatanzaro@gnome.org>
Date: Tue, 9 Mar 2021 16:02:46 -0600 Date: Tue, 9 Mar 2021 16:02:46 -0600
Subject: [PATCH 2/3] info-overview: add build option to specify a dark mode Subject: [PATCH 2/2] info-overview: add build option to specify a dark mode
logo variant logo variant
Let's allow distributions to specify a different logo to use when using Let's allow distributions to specify a different logo to use when using
@ -90,7 +89,7 @@ for a theme named "midnight" or anything that doesn't match convention.
3 files changed, 33 insertions(+) 3 files changed, 33 insertions(+)
diff --git a/meson.build b/meson.build diff --git a/meson.build b/meson.build
index 1661caa4b..124171626 100644 index 94c8abfbb..f5ce81f07 100644
--- a/meson.build --- a/meson.build
+++ b/meson.build +++ b/meson.build
@@ -54,6 +54,11 @@ distributor_logo = get_option('distributor_logo') @@ -54,6 +54,11 @@ distributor_logo = get_option('distributor_logo')
@ -115,10 +114,10 @@ index 93e551373..5305c8606 100644
option('distributor_logo', type: 'string', description: 'absolute path to distributor logo for the About panel') option('distributor_logo', type: 'string', description: 'absolute path to distributor logo for the About panel')
+option('dark_mode_distributor_logo', type: 'string', description: 'absolute path to distributor logo dark mode variant') +option('dark_mode_distributor_logo', type: 'string', description: 'absolute path to distributor logo dark mode variant')
diff --git a/panels/info-overview/cc-info-overview-panel.c b/panels/info-overview/cc-info-overview-panel.c diff --git a/panels/info-overview/cc-info-overview-panel.c b/panels/info-overview/cc-info-overview-panel.c
index 95a5904df..cb20e16b1 100644 index ce1493f7c..7454bb1ea 100644
--- a/panels/info-overview/cc-info-overview-panel.c --- a/panels/info-overview/cc-info-overview-panel.c
+++ b/panels/info-overview/cc-info-overview-panel.c +++ b/panels/info-overview/cc-info-overview-panel.c
@@ -866,10 +866,37 @@ cc_info_panel_row_activated_cb (CcInfoOverviewPanel *self, @@ -880,6 +880,25 @@ cc_info_panel_row_activated_cb (CcInfoOverviewPanel *self,
open_software_update (self); open_software_update (self);
} }
@ -140,8 +139,16 @@ index 95a5904df..cb20e16b1 100644
+ g_object_get (settings, "gtk-theme-name", &theme_name, NULL); + g_object_get (settings, "gtk-theme-name", &theme_name, NULL);
+ return theme_name != NULL && g_str_has_suffix (theme_name, "dark"); + return theme_name != NULL && g_str_has_suffix (theme_name, "dark");
+} +}
+#else
static const char *
get_asset_suffix (CcInfoOverviewPanel *panel)
{
@@ -897,11 +916,19 @@ get_asset_suffix (CcInfoOverviewPanel *panel)
g_object_get (settings, "gtk-theme-name", &theme_name, NULL);
return (theme_name != NULL && g_str_has_suffix (theme_name, "dark")) ? "-dark" : "";
}
+#endif +#endif
+
static void static void
setup_os_logo (CcInfoOverviewPanel *panel) setup_os_logo (CcInfoOverviewPanel *panel)
{ {
@ -157,39 +164,4 @@ index 95a5904df..cb20e16b1 100644
#else #else
g_autofree char *logo_name = g_get_os_info ("LOGO"); g_autofree char *logo_name = g_get_os_info ("LOGO");
-- --
GitLab 2.31.1
From c379ccc4e8f0bcdee78361f134ba29d3a25f7528 Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@gnome.org>
Date: Wed, 10 Mar 2021 11:30:57 -0600
Subject: [PATCH 3/3] info-overview: reduce size of logo when using icon from
/etc/os-release
When using the icon from /etc/os-release, display it as 128x128 rather
than 256x256. In distributions that don't ship a 128x128, such as
Fedora, this results in the 256x256 icon being scaled down to a
reasonable size. 256x256 is so large here as to be clearly undesirable.
128x128 is also the size that Ubuntu uses in its downstream patch. Might
as well reduce the need for patching as far as possible, even though
Fedora doesn't plan to use this codepath.
---
panels/info-overview/cc-info-overview-panel.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/panels/info-overview/cc-info-overview-panel.c b/panels/info-overview/cc-info-overview-panel.c
index cb20e16b1..3575b90c5 100644
--- a/panels/info-overview/cc-info-overview-panel.c
+++ b/panels/info-overview/cc-info-overview-panel.c
@@ -903,7 +903,7 @@ setup_os_logo (CcInfoOverviewPanel *panel)
if (logo_name != NULL)
{
gtk_image_set_from_icon_name (panel->os_logo, logo_name, GTK_ICON_SIZE_INVALID);
- gtk_image_set_pixel_size (panel->os_logo, 256);
+ gtk_image_set_pixel_size (panel->os_logo, 128);
}
else
{
--
GitLab

View File

@ -12,13 +12,13 @@
%global tarball_version %%(echo %{version} | tr '~' '.') %global tarball_version %%(echo %{version} | tr '~' '.')
Name: gnome-control-center Name: gnome-control-center
Version: 40.0 Version: 41~beta
Release: 11%{?dist} Release: 1%{?dist}
Summary: Utilities to configure the GNOME desktop Summary: Utilities to configure the GNOME desktop
License: GPLv2+ and CC-BY-SA License: GPLv2+ and CC-BY-SA
URL: http://www.gnome.org URL: http://www.gnome.org
Source0: https://download.gnome.org/sources/gnome-control-center/40/gnome-control-center-%{tarball_version}.tar.xz Source0: https://download.gnome.org/sources/gnome-control-center/41/gnome-control-center-%{tarball_version}.tar.xz
# https://gitlab.gnome.org/GNOME/gnome-control-center/-/merge_requests/965 # https://gitlab.gnome.org/GNOME/gnome-control-center/-/merge_requests/965
Patch0: distro-logo.patch Patch0: distro-logo.patch
@ -36,6 +36,7 @@ BuildRequires: pkgconfig(cheese-gtk)
BuildRequires: pkgconfig(clutter-gtk-1.0) BuildRequires: pkgconfig(clutter-gtk-1.0)
BuildRequires: pkgconfig(colord) BuildRequires: pkgconfig(colord)
BuildRequires: pkgconfig(colord-gtk) BuildRequires: pkgconfig(colord-gtk)
BuildRequires: pkgconfig(gcr-3)
BuildRequires: pkgconfig(gdk-pixbuf-2.0) BuildRequires: pkgconfig(gdk-pixbuf-2.0)
BuildRequires: pkgconfig(gdk-wayland-3.0) BuildRequires: pkgconfig(gdk-wayland-3.0)
BuildRequires: pkgconfig(gio-2.0) >= %{glib2_version} BuildRequires: pkgconfig(gio-2.0) >= %{glib2_version}
@ -192,6 +193,7 @@ chrpath --delete $RPM_BUILD_ROOT%{_bindir}/gnome-control-center
%{_datadir}/gnome-control-center/keybindings/*.xml %{_datadir}/gnome-control-center/keybindings/*.xml
%{_datadir}/gnome-control-center/pixmaps %{_datadir}/gnome-control-center/pixmaps
%{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini %{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini
%{_datadir}/icons/*
%{_datadir}/icons/hicolor/*/*/* %{_datadir}/icons/hicolor/*/*/*
%{_datadir}/man/man1/gnome-control-center.1* %{_datadir}/man/man1/gnome-control-center.1*
%{_datadir}/metainfo/gnome-control-center.appdata.xml %{_datadir}/metainfo/gnome-control-center.appdata.xml
@ -210,6 +212,9 @@ chrpath --delete $RPM_BUILD_ROOT%{_bindir}/gnome-control-center
%dir %{_datadir}/gnome/wm-properties %dir %{_datadir}/gnome/wm-properties
%changelog %changelog
* Mon Aug 23 2021 Michael Catanzaro <mcatanzaro@redhat.com> - 41~beta-1
- Update to 41.beta
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 40.0-11 * Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 40.0-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (gnome-control-center-40.0.tar.xz) = 26980cd18c414b12d2bf7e61be200e02302e170d53aba4f064154eda4c006648160919b6d4c9d168d8c5a461c05dc6593a52066b144af577c6aac420b9723cb9 SHA512 (gnome-control-center-41.beta.tar.xz) = dbd9a5fd99ba1aa07e2fd66eb0ab8dfcc7ea7e9012f590d4a35801cd29369a9b99f702162d0f67d3d1575fa13b842f0a59eb7b4b7e4bfb37174c20b9bbd6c214