Fix s390 gresource patch

This commit is contained in:
David King 2022-02-16 12:18:45 +00:00
parent dd0d228d2c
commit a5747e3d37

View File

@ -1,20 +1,26 @@
From 741aeffed7751a0ae1514d708022284906fd6845 Mon Sep 17 00:00:00 2001
From 21226b9973fa222104f9c178269be42323a0b1fe Mon Sep 17 00:00:00 2001
From: David King <amigadave@amigadave.com>
Date: Wed, 16 Feb 2022 11:14:12 +0000
Subject: [PATCH] common: Add missing source_dir
Subject: [PATCH] common: Add gresource sources to common_sources
This seems to match other uses of compile_resources(). Without this, the
build fails on s390 as the resources header is not generated.
As the gresource source and header are generated, add them to
common_sources. Follow-up to 234d1aadb78dfea16d001569bcb71a6807598c03.
Without this, the build fails on s390 as the resources header is not
generated.
---
panels/common/meson.build | 1 +
1 file changed, 1 insertion(+)
panels/common/meson.build | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/panels/common/meson.build b/panels/common/meson.build
index 20b9dcf16..bc4cc339a 100644
index 20b9dcf16..b956f7c18 100644
--- a/panels/common/meson.build
+++ b/panels/common/meson.build
@@ -66,6 +66,7 @@ resource_data = files(
sources += gnome.compile_resources(
@@ -63,9 +63,10 @@ resource_data = files(
'cc-permission-infobar.ui',
)
-sources += gnome.compile_resources(
+common_sources += gnome.compile_resources(
'cc-common-resources',
'common.gresource.xml',
+ source_dir: '.',