Update to 41.rc1
This commit is contained in:
parent
6386df01b9
commit
3116f08825
1
.gitignore
vendored
1
.gitignore
vendored
@ -37,3 +37,4 @@
|
||||
/gnome-control-center-40.rc.tar.xz
|
||||
/gnome-control-center-40.0.tar.xz
|
||||
/gnome-control-center-41.beta.tar.xz
|
||||
/gnome-control-center-41.rc1.tar.xz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From abde4f40c257db149be708fb66c805cc58f80a13 Mon Sep 17 00:00:00 2001
|
||||
From 763cde56be06ce352f41adcdc1c6756f17043f5d Mon Sep 17 00:00:00 2001
|
||||
From: Michael Catanzaro <mcatanzaro@gnome.org>
|
||||
Date: Tue, 9 Mar 2021 14:51:54 -0600
|
||||
Subject: [PATCH 1/2] info-overview: add build option to control distributor
|
||||
@ -22,7 +22,7 @@ this.
|
||||
3 files changed, 11 insertions(+)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 42a9536b4..94c8abfbb 100644
|
||||
index 6f08febd9..edaebeea3 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -50,6 +50,12 @@ foreach define: set_defines
|
||||
@ -48,10 +48,10 @@ index 1b7b54810..93e551373 100644
|
||||
option('malcontent', type: 'boolean', value: false, description: 'build with malcontent support')
|
||||
+option('distributor_logo', type: 'string', description: 'absolute path to distributor logo for the About panel')
|
||||
diff --git a/panels/info-overview/cc-info-overview-panel.c b/panels/info-overview/cc-info-overview-panel.c
|
||||
index 9ee9d2910..ce1493f7c 100644
|
||||
index 6e832eb35..3db143d80 100644
|
||||
--- a/panels/info-overview/cc-info-overview-panel.c
|
||||
+++ b/panels/info-overview/cc-info-overview-panel.c
|
||||
@@ -901,6 +901,9 @@ get_asset_suffix (CcInfoOverviewPanel *panel)
|
||||
@@ -901,6 +901,9 @@ use_dark_theme (CcInfoOverviewPanel *panel)
|
||||
static void
|
||||
setup_os_logo (CcInfoOverviewPanel *panel)
|
||||
{
|
||||
@ -59,12 +59,12 @@ index 9ee9d2910..ce1493f7c 100644
|
||||
+ gtk_image_set_from_file (panel->os_logo, DISTRIBUTOR_LOGO);
|
||||
+#else
|
||||
g_autofree char *logo_name = g_get_os_info ("LOGO");
|
||||
g_autofree char *logo_name_with_variant = NULL;
|
||||
g_autoptr(GPtrArray) array = NULL;
|
||||
g_autoptr(GIcon) icon = NULL;
|
||||
@@ -920,6 +923,7 @@ setup_os_logo (CcInfoOverviewPanel *panel)
|
||||
|
||||
@@ -910,6 +913,7 @@ setup_os_logo (CcInfoOverviewPanel *panel)
|
||||
logo_name_with_variant = g_strdup_printf ("%s-text%s", logo_name, get_asset_suffix (panel));
|
||||
gtk_image_set_from_icon_name (panel->os_logo, logo_name_with_variant, GTK_ICON_SIZE_INVALID);
|
||||
gtk_image_set_pixel_size (panel->os_logo, -1);
|
||||
icon = g_themed_icon_new_from_names ((char **) array->pdata, array->len);
|
||||
gtk_image_set_from_gicon (panel->os_logo, icon, GTK_ICON_SIZE_INVALID);
|
||||
+#endif
|
||||
}
|
||||
|
||||
@ -72,7 +72,7 @@ index 9ee9d2910..ce1493f7c 100644
|
||||
--
|
||||
2.31.1
|
||||
|
||||
From 2fa7e314ded37254f85910f7b5da74aeae67c841 Mon Sep 17 00:00:00 2001
|
||||
From 314ef01084276cd0ca23c404a94087ff268700ba Mon Sep 17 00:00:00 2001
|
||||
From: Michael Catanzaro <mcatanzaro@gnome.org>
|
||||
Date: Tue, 9 Mar 2021 16:02:46 -0600
|
||||
Subject: [PATCH 2/2] info-overview: add build option to specify a dark mode
|
||||
@ -83,13 +83,13 @@ a dark GTK theme. This is best-effort only since it relies on the
|
||||
convention that dark themes must end with "dark" and therefore will fail
|
||||
for a theme named "midnight" or anything that doesn't match convention.
|
||||
---
|
||||
meson.build | 5 ++++
|
||||
meson_options.txt | 1 +
|
||||
panels/info-overview/cc-info-overview-panel.c | 27 +++++++++++++++++++
|
||||
3 files changed, 33 insertions(+)
|
||||
meson.build | 5 +++++
|
||||
meson_options.txt | 1 +
|
||||
panels/info-overview/cc-info-overview-panel.c | 9 +++++++++
|
||||
3 files changed, 15 insertions(+)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 94c8abfbb..f5ce81f07 100644
|
||||
index edaebeea3..bb0e06d9e 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -54,6 +54,11 @@ distributor_logo = get_option('distributor_logo')
|
||||
@ -114,38 +114,20 @@ index 93e551373..5305c8606 100644
|
||||
option('distributor_logo', type: 'string', description: 'absolute path to distributor logo for the About panel')
|
||||
+option('dark_mode_distributor_logo', type: 'string', description: 'absolute path to distributor logo dark mode variant')
|
||||
diff --git a/panels/info-overview/cc-info-overview-panel.c b/panels/info-overview/cc-info-overview-panel.c
|
||||
index ce1493f7c..7454bb1ea 100644
|
||||
index 3db143d80..434850e7a 100644
|
||||
--- a/panels/info-overview/cc-info-overview-panel.c
|
||||
+++ b/panels/info-overview/cc-info-overview-panel.c
|
||||
@@ -880,6 +880,25 @@ cc_info_panel_row_activated_cb (CcInfoOverviewPanel *self,
|
||||
@@ -880,6 +880,7 @@ cc_info_panel_row_activated_cb (CcInfoOverviewPanel *self,
|
||||
open_software_update (self);
|
||||
}
|
||||
|
||||
+#ifdef DARK_MODE_DISTRIBUTOR_LOGO
|
||||
+static gboolean
|
||||
+is_dark_mode (CcInfoOverviewPanel *panel)
|
||||
+{
|
||||
+ GdkScreen *screen;
|
||||
+ GtkSettings *settings;
|
||||
+ g_autofree char *theme_name = NULL;
|
||||
+
|
||||
+ theme_name = g_strdup (g_getenv ("GTK_THEME"));
|
||||
+ if (theme_name != NULL)
|
||||
+ return g_str_has_suffix (theme_name, "dark");
|
||||
+
|
||||
+ screen = gtk_widget_get_screen (GTK_WIDGET (panel));
|
||||
+ settings = gtk_settings_get_for_screen (screen);
|
||||
+
|
||||
+ g_object_get (settings, "gtk-theme-name", &theme_name, NULL);
|
||||
+ return theme_name != NULL && g_str_has_suffix (theme_name, "dark");
|
||||
+}
|
||||
+#else
|
||||
static const char *
|
||||
get_asset_suffix (CcInfoOverviewPanel *panel)
|
||||
+#if !defined(DISTRIBUTOR_LOGO) || defined(DARK_MODE_DISTRIBUTOR_LOGO)
|
||||
static gboolean
|
||||
use_dark_theme (CcInfoOverviewPanel *panel)
|
||||
{
|
||||
@@ -897,11 +916,19 @@ get_asset_suffix (CcInfoOverviewPanel *panel)
|
||||
@@ -897,11 +898,19 @@ use_dark_theme (CcInfoOverviewPanel *panel)
|
||||
g_object_get (settings, "gtk-theme-name", &theme_name, NULL);
|
||||
return (theme_name != NULL && g_str_has_suffix (theme_name, "dark")) ? "-dark" : "";
|
||||
return (theme_name != NULL && g_str_has_suffix (theme_name, "dark")) ? TRUE : FALSE;
|
||||
}
|
||||
+#endif
|
||||
|
||||
@ -154,7 +136,7 @@ index ce1493f7c..7454bb1ea 100644
|
||||
{
|
||||
#ifdef DISTRIBUTOR_LOGO
|
||||
+#ifdef DARK_MODE_DISTRIBUTOR_LOGO
|
||||
+ if (is_dark_mode (panel))
|
||||
+ if (use_dark_theme (panel))
|
||||
+ {
|
||||
+ gtk_image_set_from_file (panel->os_logo, DARK_MODE_DISTRIBUTOR_LOGO);
|
||||
+ return;
|
||||
@ -165,3 +147,4 @@ index ce1493f7c..7454bb1ea 100644
|
||||
g_autofree char *logo_name = g_get_os_info ("LOGO");
|
||||
--
|
||||
2.31.1
|
||||
|
||||
|
@ -12,8 +12,8 @@
|
||||
%global tarball_version %%(echo %{version} | tr '~' '.')
|
||||
|
||||
Name: gnome-control-center
|
||||
Version: 41~beta
|
||||
Release: 3%{?dist}
|
||||
Version: 41~rc1
|
||||
Release: 1%{?dist}
|
||||
Summary: Utilities to configure the GNOME desktop
|
||||
|
||||
License: GPLv2+ and CC-BY-SA
|
||||
@ -23,9 +23,6 @@ Source0: https://download.gnome.org/sources/gnome-control-center/41/gnome
|
||||
# https://gitlab.gnome.org/GNOME/gnome-control-center/-/merge_requests/965
|
||||
Patch0: distro-logo.patch
|
||||
|
||||
# https://gitlab.gnome.org/GNOME/gnome-control-center/-/merge_requests/1049
|
||||
Patch1: parental-controls.patch
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: cups-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
@ -218,6 +215,9 @@ chrpath --delete $RPM_BUILD_ROOT%{_bindir}/gnome-control-center
|
||||
%dir %{_datadir}/gnome/wm-properties
|
||||
|
||||
%changelog
|
||||
* Wed Sep 08 2021 Michael Catanzaro <mcatanzaro@redhat.com> - 41~rc1-1
|
||||
- Update to 41.rc1
|
||||
|
||||
* Thu Aug 26 2021 Bastien Nocera <bnocera@redhat.com> - 41~beta-3
|
||||
+ gnome-control-center-41~beta-3
|
||||
- Parental controls fixes
|
||||
|
@ -1,164 +0,0 @@
|
||||
From e65a4ba77ba741fb372734c5a862d892c9ba102b Mon Sep 17 00:00:00 2001
|
||||
From: Kalev Lember <klember@redhat.com>
|
||||
Date: Thu, 26 Aug 2021 16:33:20 +0200
|
||||
Subject: [PATCH 1/4] user-accounts: Fix spurious underscore in front of
|
||||
"Parental Controls" label
|
||||
|
||||
---
|
||||
panels/user-accounts/cc-user-panel.ui | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/panels/user-accounts/cc-user-panel.ui b/panels/user-accounts/cc-user-panel.ui
|
||||
index a1092eed7..6a3f92247 100644
|
||||
--- a/panels/user-accounts/cc-user-panel.ui
|
||||
+++ b/panels/user-accounts/cc-user-panel.ui
|
||||
@@ -284,6 +284,7 @@
|
||||
<property name="title" translatable="yes">_Parental Controls</property>
|
||||
<property name="subtitle" translatable="yes">Open the Parental Controls application.</property>
|
||||
<property name="subtitle-lines">0</property>
|
||||
+ <property name="use_underline">True</property>
|
||||
<property name="activatable">True</property>
|
||||
<child>
|
||||
<object class="GtkLabel" id="parental_controls_button_label">
|
||||
--
|
||||
2.31.1
|
||||
|
||||
|
||||
From 820aea267d8db1b84d53651ffd63ac36028e0390 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Thu, 26 Aug 2021 16:49:40 +0200
|
||||
Subject: [PATCH 2/4] user-accounts: Hide parental controls row if unavailable
|
||||
|
||||
Don't show the parental controls line for administrator accounts.
|
||||
---
|
||||
panels/user-accounts/cc-user-panel.c | 15 ++++++++-------
|
||||
panels/user-accounts/cc-user-panel.ui | 1 +
|
||||
2 files changed, 9 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/panels/user-accounts/cc-user-panel.c b/panels/user-accounts/cc-user-panel.c
|
||||
index 57cd019db..73af3a98a 100644
|
||||
--- a/panels/user-accounts/cc-user-panel.c
|
||||
+++ b/panels/user-accounts/cc-user-panel.c
|
||||
@@ -331,7 +331,12 @@ reload_users (CcUserPanel *self, ActUser *selected_user)
|
||||
g_object_set (settings, "gtk-enable-animations", animations, NULL);
|
||||
#ifdef HAVE_MALCONTENT
|
||||
/* Parental Controls row not to be shown for single user setups. */
|
||||
- gtk_widget_set_visible (GTK_WIDGET (self->parental_controls_row), users_count > 1);
|
||||
+ if (selected_user != NULL) {
|
||||
+ gtk_widget_set_visible (GTK_WIDGET (self->parental_controls_row),
|
||||
+ act_user_get_account_type (selected_user) != ACT_USER_ACCOUNT_TYPE_ADMINISTRATOR);
|
||||
+ } else {
|
||||
+ gtk_widget_set_visible (GTK_WIDGET (self->parental_controls_row), users_count > 1);
|
||||
+ }
|
||||
#endif
|
||||
}
|
||||
|
||||
@@ -921,12 +926,7 @@ show_user (ActUser *user, CcUserPanel *self)
|
||||
#ifdef HAVE_MALCONTENT
|
||||
/* Parental Controls: Unavailable if user is admin */
|
||||
if (act_user_get_account_type (user) == ACT_USER_ACCOUNT_TYPE_ADMINISTRATOR) {
|
||||
- GtkStyleContext *context = gtk_widget_get_style_context (GTK_WIDGET (self->parental_controls_button_label));
|
||||
-
|
||||
- gtk_widget_hide (GTK_WIDGET (self->parental_control_go_next));
|
||||
- /* TRANSLATORS: Status of Parental Controls setup */
|
||||
- gtk_label_set_text (self->parental_controls_button_label, _("Unavailable"));
|
||||
- gtk_style_context_add_class (context, "dim-label");
|
||||
+ gtk_widget_hide (GTK_WIDGET (self->parental_controls_row));
|
||||
} else {
|
||||
GtkStyleContext *context = gtk_widget_get_style_context (GTK_WIDGET (self->parental_controls_button_label));
|
||||
|
||||
@@ -939,6 +939,7 @@ show_user (ActUser *user, CcUserPanel *self)
|
||||
|
||||
gtk_style_context_remove_class (context, "dim-label");
|
||||
gtk_widget_show (GTK_WIDGET (self->parental_control_go_next));
|
||||
+ gtk_widget_show (GTK_WIDGET (self->parental_controls_row));
|
||||
}
|
||||
#endif
|
||||
|
||||
diff --git a/panels/user-accounts/cc-user-panel.ui b/panels/user-accounts/cc-user-panel.ui
|
||||
index 6a3f92247..134a9a39a 100644
|
||||
--- a/panels/user-accounts/cc-user-panel.ui
|
||||
+++ b/panels/user-accounts/cc-user-panel.ui
|
||||
@@ -286,6 +286,7 @@
|
||||
<property name="subtitle-lines">0</property>
|
||||
<property name="use_underline">True</property>
|
||||
<property name="activatable">True</property>
|
||||
+ <property name="visible">False</property>
|
||||
<child>
|
||||
<object class="GtkLabel" id="parental_controls_button_label">
|
||||
<property name="visible">True</property>
|
||||
--
|
||||
2.31.1
|
||||
|
||||
|
||||
From b59aec45372cfe6ea790793ae8fc5a3a32b5555d Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Thu, 26 Aug 2021 16:49:55 +0200
|
||||
Subject: [PATCH 3/4] user-accounts: Avoid double password prompt
|
||||
|
||||
Don't require a password to be typed just to be able to launch the
|
||||
parental controls app which itself will ask for a password to be typed.
|
||||
---
|
||||
panels/user-accounts/cc-user-panel.c | 8 --------
|
||||
1 file changed, 8 deletions(-)
|
||||
|
||||
diff --git a/panels/user-accounts/cc-user-panel.c b/panels/user-accounts/cc-user-panel.c
|
||||
index 73af3a98a..249daa578 100644
|
||||
--- a/panels/user-accounts/cc-user-panel.c
|
||||
+++ b/panels/user-accounts/cc-user-panel.c
|
||||
@@ -1438,10 +1438,6 @@ on_permission_changed (CcUserPanel *self)
|
||||
|
||||
gtk_widget_set_sensitive (GTK_WIDGET (self->last_login_row), TRUE);
|
||||
remove_unlock_tooltip (GTK_WIDGET (self->last_login_row));
|
||||
-#ifdef HAVE_MALCONTENT
|
||||
- gtk_widget_set_sensitive (GTK_WIDGET (self->parental_controls_row), TRUE);
|
||||
- remove_unlock_tooltip (GTK_WIDGET (self->parental_controls_row));
|
||||
-#endif
|
||||
}
|
||||
else {
|
||||
gtk_stack_set_visible_child (self->user_icon_stack, GTK_WIDGET (self->user_icon_image));
|
||||
@@ -1457,10 +1453,6 @@ on_permission_changed (CcUserPanel *self)
|
||||
|
||||
gtk_widget_set_sensitive (GTK_WIDGET (self->last_login_row), FALSE);
|
||||
add_unlock_tooltip (GTK_WIDGET (self->last_login_row));
|
||||
-#ifdef HAVE_MALCONTENT
|
||||
- gtk_widget_set_sensitive (GTK_WIDGET (self->parental_controls_row), FALSE);
|
||||
- add_unlock_tooltip (GTK_WIDGET (self->parental_controls_row));
|
||||
-#endif
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
||||
|
||||
From 14d29b8e45504b475ffb07a6a5617ba064892802 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Thu, 26 Aug 2021 17:20:56 +0200
|
||||
Subject: [PATCH 4/4] user-accounts: Add debug when launching
|
||||
malcontent-control
|
||||
|
||||
---
|
||||
panels/user-accounts/cc-user-panel.c | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/panels/user-accounts/cc-user-panel.c b/panels/user-accounts/cc-user-panel.c
|
||||
index 249daa578..aa273fca2 100644
|
||||
--- a/panels/user-accounts/cc-user-panel.c
|
||||
+++ b/panels/user-accounts/cc-user-panel.c
|
||||
@@ -1214,7 +1214,11 @@ spawn_malcontent_control (CcUserPanel *self)
|
||||
#endif /* HAVE_MALCONTENT_0_10 */
|
||||
NULL
|
||||
};
|
||||
- g_spawn_async (NULL, (char **)argv, NULL, G_SPAWN_SEARCH_PATH, NULL, NULL, NULL, NULL);
|
||||
+ g_autoptr(GError) error = NULL;
|
||||
+ if (!g_spawn_async (NULL, (char **)argv, NULL, G_SPAWN_SEARCH_PATH, NULL, NULL, NULL, &error))
|
||||
+ g_debug ("Couldn't launch malcontent-control: %s", error->message);
|
||||
+ } else {
|
||||
+ g_debug ("Not launching malcontent because selected user is an admin");
|
||||
}
|
||||
}
|
||||
#endif
|
||||
--
|
||||
2.31.1
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gnome-control-center-41.beta.tar.xz) = dbd9a5fd99ba1aa07e2fd66eb0ab8dfcc7ea7e9012f590d4a35801cd29369a9b99f702162d0f67d3d1575fa13b842f0a59eb7b4b7e4bfb37174c20b9bbd6c214
|
||||
SHA512 (gnome-control-center-41.rc1.tar.xz) = 0d58cc2535c0a2925f4a02e791b1d3a0f26b12df6647350059cf94c4b1cc7acb818fe2766d299070e2eaac7f27128afec0aa93d10297457f58e8d4fb05a50fe8
|
||||
|
Loading…
Reference in New Issue
Block a user