Update to 3.25.2
- Drop appdata modification, fixed upstream - Update meson patch
This commit is contained in:
parent
31ccb82c77
commit
a042889e70
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@
|
|||||||
/gnome-clocks-3.23.90.tar.xz
|
/gnome-clocks-3.23.90.tar.xz
|
||||||
/gnome-clocks-3.24.0.tar.xz
|
/gnome-clocks-3.24.0.tar.xz
|
||||||
/gnome-clocks-3.25.1.tar.xz
|
/gnome-clocks-3.25.1.tar.xz
|
||||||
|
/gnome-clocks-3.25.2.tar.xz
|
||||||
|
@ -1,21 +1,8 @@
|
|||||||
diff --git a/data/meson.build b/data/meson.build
|
|
||||||
index 90dafc2..a7dacb0 100644
|
|
||||||
--- a/data/meson.build
|
|
||||||
+++ b/data/meson.build
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
iconsdir = join_paths(get_option('datadir'), 'icons/hicolor')
|
|
||||||
-foreach size: ['16x16', '22x22', '32x32', '48x48', '256x256', 'scalable']
|
|
||||||
- install_subdir('icons/' + size, install_dir: iconsdir)
|
|
||||||
+foreach size: ['16x16', '22x22', '32x32', '48x48', '256x256', 'symbolic']
|
|
||||||
+ install_subdir('icons/hicolor/' + size, install_dir: iconsdir)
|
|
||||||
endforeach
|
|
||||||
|
|
||||||
install_subdir('images/', install_dir: join_paths(get_option('datadir'), meson.project_name()))
|
|
||||||
diff --git a/help/meson.build b/help/meson.build
|
diff --git a/help/meson.build b/help/meson.build
|
||||||
index f89afbd..31d389f 100644
|
index 654b994..57eef1b 100644
|
||||||
--- a/help/meson.build
|
--- a/help/meson.build
|
||||||
+++ b/help/meson.build
|
+++ b/help/meson.build
|
||||||
@@ -39,4 +39,5 @@ gnome.yelp(meson.project_name(),
|
@@ -41,4 +41,5 @@ gnome.yelp(
|
||||||
sources: help_files,
|
sources: help_files,
|
||||||
media: help_media,
|
media: help_media,
|
||||||
languages: help_linguas,
|
languages: help_linguas,
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
Name: gnome-clocks
|
Name: gnome-clocks
|
||||||
Version: 3.25.1
|
Version: 3.25.2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Clock application designed for GNOME 3
|
Summary: Clock application designed for GNOME 3
|
||||||
|
|
||||||
@ -7,7 +7,7 @@ License: GPLv2+
|
|||||||
URL: https://wiki.gnome.org/Apps/Clocks
|
URL: https://wiki.gnome.org/Apps/Clocks
|
||||||
Source0: https://download.gnome.org/sources/gnome-clocks/3.25/%{name}-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/gnome-clocks/3.25/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# these are already upstream
|
# This one got lost in the release
|
||||||
Patch0: gnome-clocks-meson1.patch
|
Patch0: gnome-clocks-meson1.patch
|
||||||
|
|
||||||
BuildRequires: meson
|
BuildRequires: meson
|
||||||
@ -41,18 +41,6 @@ Clock application designed for GNOME 3
|
|||||||
%meson_install
|
%meson_install
|
||||||
%find_lang gnome-clocks --with-gnome
|
%find_lang gnome-clocks --with-gnome
|
||||||
|
|
||||||
# Update the screenshot shown in the software center
|
|
||||||
#
|
|
||||||
# NOTE: It would be *awesome* if this file was pushed upstream.
|
|
||||||
#
|
|
||||||
# See http://people.freedesktop.org/~hughsient/appdata/#screenshots for more details.
|
|
||||||
#
|
|
||||||
appstream-util replace-screenshots $RPM_BUILD_ROOT%{_datadir}/appdata/org.gnome.clocks.appdata.xml \
|
|
||||||
https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/org.gnome.clocks/a.png \
|
|
||||||
https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/org.gnome.clocks/b.png \
|
|
||||||
https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/org.gnome.clocks/c.png \
|
|
||||||
https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/org.gnome.clocks/d.png \
|
|
||||||
https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/org.gnome.clocks/e.png
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/org.gnome.clocks.desktop
|
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/org.gnome.clocks.desktop
|
||||||
@ -88,6 +76,11 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jul 1 2017 Yanko Kaneti <yaneti@declera.com> - 3.25.2-1
|
||||||
|
- Update to 3.25.2
|
||||||
|
- Drop appdata modification, fixed upstream
|
||||||
|
- Update meson patch
|
||||||
|
|
||||||
* Tue May 23 2017 Yanko Kaneti <yaneti@declera.com> - 3.25.1-1
|
* Tue May 23 2017 Yanko Kaneti <yaneti@declera.com> - 3.25.1-1
|
||||||
- Update to 3.25.1. Meson. BR reshuffle
|
- Update to 3.25.1. Meson. BR reshuffle
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gnome-clocks-3.25.1.tar.xz) = 93207d91bbec3cfd163e31a62e237ba3c9e92aaf794f1783ec6118fa02d63ab9625bb943245ab6dc5c992f74c11f26a31287e5b1f0b9c8486dac2a0bfdbd606e
|
SHA512 (gnome-clocks-3.25.2.tar.xz) = 53dd531a535434af007432f0846dc68a9e45dda958f0d820c583b723229d2243c147f99dbdb05cade6b0032af6eed9f4cb82e20bbcbda2372c25f5a6584aa0e3
|
||||||
|
Loading…
Reference in New Issue
Block a user