New upstream release - 3.7.90. Moving to vala.
This commit is contained in:
parent
76c3e5789e
commit
5b3d69db17
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/gnome-clocks-0.1.4.tar.xz
|
||||
/gnome-clocks-0.1.5.tar.xz
|
||||
/gnome-clocks-0.1.6.tar.xz
|
||||
/gnome-clocks-3.7.90.tar.xz
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 3bb5d7ca10dd441cec9f1b0a7f558c041962800c Mon Sep 17 00:00:00 2001
|
||||
From: Mathieu Bridon <bochecha@fedoraproject.org>
|
||||
Date: Wed, 6 Feb 2013 16:43:25 +0800
|
||||
Subject: [PATCH] Use the system pycanberra
|
||||
|
||||
As pycanberra has not yet been ported to Python 3, keep the fallback on
|
||||
the bundled version.
|
||||
---
|
||||
gnomeclocks/utils.py | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gnomeclocks/utils.py b/gnomeclocks/utils.py
|
||||
index 637983d..159fe67 100644
|
||||
--- a/gnomeclocks/utils.py
|
||||
+++ b/gnomeclocks/utils.py
|
||||
@@ -20,7 +20,13 @@ import os
|
||||
import time
|
||||
import datetime
|
||||
from gi.repository import GObject, Gio, GnomeDesktop, Notify
|
||||
-from . import pycanberra
|
||||
+
|
||||
+try:
|
||||
+ import pycanberra
|
||||
+except ImportError:
|
||||
+ # Fallback on the bundled version
|
||||
+ from . import pycanberra
|
||||
+
|
||||
from gnomeclocks import GNOMECLOCKS_DATADIR
|
||||
|
||||
|
||||
--
|
||||
1.8.1.2
|
||||
|
@ -1,39 +0,0 @@
|
||||
diff --git a/po/ca.po b/po/ca.po
|
||||
index 10c2b58..770838e 100644
|
||||
--- a/po/ca.po
|
||||
+++ b/po/ca.po
|
||||
@@ -34,7 +34,7 @@ msgstr ""
|
||||
|
||||
#: ../data/gnome-clocks.desktop.in.h:4
|
||||
msgid "time;timer;alarm;world clock;stopwatch;time zone;"
|
||||
-msgstr "temps;temporitzador;alarma;rellotge global;cronòmetre;zona horària"
|
||||
+msgstr "temps;temporitzador;alarma;rellotge global;cronòmetre;zona horària;"
|
||||
|
||||
#: ../gnomeclocks/alarm.py:93 ../gnomeclocks/alarm.py:451
|
||||
msgid "Alarm"
|
||||
diff --git a/po/el.po b/po/el.po
|
||||
index 454a1bc..6bf26da 100644
|
||||
--- a/po/el.po
|
||||
+++ b/po/el.po
|
||||
@@ -37,7 +37,7 @@ msgstr ""
|
||||
|
||||
#: ../data/gnome-clocks.desktop.in.h:4
|
||||
msgid "time;timer;alarm;world clock;stopwatch;time zone;"
|
||||
-msgstr "χρόνος·χρονόμετρο·συναγερμός·παγκόσμιο ρολόι·χρονόμετρο·ώρα ζώνης·"
|
||||
+msgstr "χρόνος;χρονόμετρο;συναγερμός;παγκόσμιο ρολόι;χρονόμετρο;ώρα ζώνης;"
|
||||
|
||||
#. Translators: "New" refers to an alarm
|
||||
#: ../gnomeclocks/alarm.py:91 ../gnomeclocks/alarm.py:443
|
||||
diff --git a/po/ug.po b/po/ug.po
|
||||
index 53be856..05b0f51 100644
|
||||
--- a/po/ug.po
|
||||
+++ b/po/ug.po
|
||||
@@ -32,7 +32,7 @@ msgstr "دۇنيا ۋاقىتلىرى، قوڭغۇراقلىق سائەت، ۋا
|
||||
|
||||
#: ../data/gnome-clocks.desktop.in.h:4
|
||||
msgid "time;timer;alarm;world clock;stopwatch;time zone;"
|
||||
-msgstr "time;timer;alarm;world clock;stopwatch;time zone;ۋاقىت؛ئۆلچىگۈچ؛قوڭغۇراق؛دۇنيا سائىتى؛ۋاقىت رايونى؛"
|
||||
+msgstr "time;timer;alarm;world clock;stopwatch;time zone;ۋاقىت؛ئۆلچىگۈچ؛قوڭغۇراق؛دۇنيا سائىتى؛ۋاقىت رايونى;"
|
||||
|
||||
#: ../gnomeclocks/alarm.py:93 ../gnomeclocks/alarm.py:455
|
||||
msgid "Alarm"
|
@ -1,25 +0,0 @@
|
||||
From 3199dc80dba8e56a7185f5d17b218f8f84041298 Mon Sep 17 00:00:00 2001
|
||||
From: Yanko Kaneti <yaneti@declera.com>
|
||||
Date: Wed, 6 Feb 2013 04:32:39 +0200
|
||||
Subject: [PATCH] With python3 the pkg-config name of pycairo is py3cairo
|
||||
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 9c49c96..03f83e5 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -24,7 +24,7 @@ GLIB_GSETTINGS
|
||||
PKG_PROG_PKG_CONFIG([0.22])
|
||||
|
||||
PKG_CHECK_MODULES(CLOCKS, [
|
||||
- pycairo
|
||||
+ py3cairo
|
||||
pygobject-3.0 >= 3.4.2
|
||||
])
|
||||
|
||||
--
|
||||
1.8.1.2
|
||||
|
@ -1,41 +1,32 @@
|
||||
Name: gnome-clocks
|
||||
Version: 0.1.6
|
||||
Release: 3%{?dist}
|
||||
Version: 3.7.90
|
||||
Release: 1%{?dist}
|
||||
Summary: Clock application designed for GNOME 3
|
||||
|
||||
License: GPLv2+
|
||||
URL: https://live.gnome.org/GnomeClocks
|
||||
Source0: http://download.gnome.org/sources/gnome-clocks/0.1/%{name}-%{version}.tar.xz
|
||||
Source0: http://download.gnome.org/sources/gnome-clocks/3.7/%{name}-%{version}.tar.xz
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=693234
|
||||
Patch1: gnome-clocks-0.1.6-desktop-keywords.patch
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=693235
|
||||
Patch2: gnome-clocks-0.1.6-py3cairo.patch
|
||||
# for patch2
|
||||
BuildRequires: automake autoconf
|
||||
|
||||
# Upstream commit 3bb5d7ca10dd441cec9f1b0a7f558c041962800c
|
||||
Patch3: 0001-Use-the-system-pycanberra.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: gtk3-devel
|
||||
Buildrequires: gobject-introspection-devel
|
||||
BuildRequires: libcanberra-devel
|
||||
BuildRequires: libgweather-devel
|
||||
BuildRequires: gnome-desktop3-devel
|
||||
BuildRequires: libnotify-devel
|
||||
BuildRequires: vala-tools
|
||||
BuildRequires: intltool desktop-file-utils glib2-devel
|
||||
BuildRequires: pygobject3-devel python3-cairo-devel
|
||||
Requires: pygobject3 clutter-gtk libgweather gnome-desktop3 libnotify python3-cairo
|
||||
Requires: python3-canberra
|
||||
|
||||
# fixed in master
|
||||
Patch1: no-rpath.patch
|
||||
BuildRequires: automake autoconf
|
||||
|
||||
%description
|
||||
Clock application designed for GNOME 3
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
rm -fv gnomeclocks/pycanberra.py
|
||||
%patch1 -p1 -b .desktop-keywords
|
||||
%patch2 -p1 -b .py3cairo
|
||||
%patch3 -p1 -b .use-system-pycanberra
|
||||
autoreconf -fi
|
||||
intltoolize --force
|
||||
%patch1 -p1 -b .no-rpath
|
||||
autoreconf -f
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -65,7 +56,6 @@ fi
|
||||
%files -f gnome-clocks.lang
|
||||
%doc COPYING README NEWS
|
||||
%{_bindir}/gnome-clocks
|
||||
%{python3_sitelib}/gnomeclocks
|
||||
%{_datadir}/gnome-clocks
|
||||
%{_datadir}/icons/*/*/apps/gnome-clocks.png
|
||||
%{_datadir}/applications/gnome-clocks.desktop
|
||||
@ -73,6 +63,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Feb 20 2013 Yanko Kaneti <yaneti@declera.com> - 3.7.90-1
|
||||
- New upstream release - 3.7.90. Moving to vala.
|
||||
|
||||
* Wed Feb 6 2013 Yanko Kaneti <yaneti@declera.com> - 0.1.6-3
|
||||
- Use python3-canberra
|
||||
|
||||
|
21
no-rpath.patch
Normal file
21
no-rpath.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 270ee4c..035f706 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -134,7 +134,7 @@ AM_CFLAGS = \
|
||||
-Wno-unused-but-set-variable \
|
||||
-Wno-unused-variable
|
||||
|
||||
-gnome_clocks_LDFLAGS = -export-dynamic -rpath $(libdir)
|
||||
+gnome_clocks_LDFLAGS = -export-dynamic
|
||||
gnome_clocks_LDADD = \
|
||||
$(top_builddir)/libgd/libgd.la \
|
||||
$(CLOCKS_LIBS) \
|
||||
@@ -163,7 +163,6 @@ MAINTAINERCLEANFILES = \
|
||||
ABOUT-NLS \
|
||||
aclocal.m4 \
|
||||
config.guess \
|
||||
- config.rpath \
|
||||
config.sub \
|
||||
install-sh \
|
||||
missing \
|
Loading…
Reference in New Issue
Block a user