import gnome-boxes-3.28.5-7.el8

This commit is contained in:
CentOS Sources 2019-11-05 13:48:33 -05:00 committed by Andrew Lukoshko
parent 2d5252c740
commit 4182f9b927
3 changed files with 135 additions and 1 deletions

View File

@ -0,0 +1,43 @@
From 788d5bb418abe88727d33f2b21d56f4ed671b927 Mon Sep 17 00:00:00 2001
From: Felipe Borges <felipeborges@gnome.org>
Date: Thu, 15 Aug 2019 13:11:45 +0200
Subject: [PATCH] offer-only-supported-arches
---
src/installed-media.vala | 2 +-
src/media-manager.vala | 6 +++++-
2 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/src/installed-media.vala b/src/installed-media.vala
index 09ceffdf..e60f3508 100644
--- a/src/installed-media.vala
+++ b/src/installed-media.vala
@@ -12,7 +12,7 @@
".vpc", ".vpc.gz",
".cloop", ".cloop.gz" };
public const string[] supported_architectures = {
- "i686", "i586", "i486", "i386"
+ "i686", "i586", "i486", "i386", "x86_64", "amd64"
};
private static Regex date_regex = /20[0-9]{6,6}/;
diff --git a/src/media-manager.vala b/src/media-manager.vala
index 427ce874..dc7cc997 100644
--- a/src/media-manager.vala
+++ b/src/media-manager.vala
@@ -150,7 +150,11 @@ else if (VMConfigurator.is_libvirt_cloning_config (config))
continue;
}
- list.insert_sorted (media, compare_media_by_vendor);
+ var os = yield os_db.get_os_by_id (os_id);
+ var os_media = os_db.get_media_by_id (os, media_id);
+
+ if (os_media.architecture in InstalledMedia.supported_architectures)
+ list.insert_sorted (media, compare_media_by_vendor);
} catch (GLib.Error error) {
warning ("Failed to use ISO '%s': %s", path, error.message);
}
--
2.21.0

View File

@ -0,0 +1,63 @@
diff --git a/data/osinfo/meson.build b/data/osinfo/meson.build
index 0f4982f..c7c6017 100644
--- a/data/osinfo/meson.build
+++ b/data/osinfo/meson.build
@@ -10,7 +10,8 @@ osinfo_db = [
['rhel-4.0.xml', 'gnome-boxes/osinfo/os/redhat.com'],
['rhel-5.0.xml', 'gnome-boxes/osinfo/os/redhat.com'],
['rhel-6.0.xml', 'gnome-boxes/osinfo/os/redhat.com'],
- ['rhel-7.0.xml', 'gnome-boxes/osinfo/os/redhat.com']
+ ['rhel-7.0.xml', 'gnome-boxes/osinfo/os/redhat.com'],
+ ['rhel-8.0.xml', 'gnome-boxes/osinfo/os/redhat.com']
]
foreach os: osinfo_db
diff --git a/data/osinfo/rhel-4.0.xml b/data/osinfo/rhel-4.0.xml
index 2839687..318544e 100644
--- a/data/osinfo/rhel-4.0.xml
+++ b/data/osinfo/rhel-4.0.xml
@@ -3,7 +3,7 @@
<!-- Please read README.logos for any questions about usage of product logos in Boxes. !-->
<os id="http://redhat.com/rhel/4.0">
- <logo>https://people.gnome.org/~zeeshanak/logos/shadownman-pill.svg</logo>
+ <logo>https://gitlab.gnome.org/GNOME/gnome-boxes-logos/raw/master/logos/shadownman-pill.svg</logo>
</os>
</libosinfo>
diff --git a/data/osinfo/rhel-8.0.xml b/data/osinfo/rhel-8.0.xml
new file mode 100644
index 0000000..ad7a785
--- /dev/null
+++ b/data/osinfo/rhel-8.0.xml
@@ -0,0 +1,9 @@
+<libosinfo version="0.0.1">
+
+ <!-- Please read README.logos for any questions about usage of product logos in Boxes. !-->
+
+ <os id="http://redhat.com/rhel/8.0">
+ <logo>https://gitlab.gnome.org/GNOME/gnome-boxes-logos/raw/master/logos/shadownman-pill.svg</logo>
+ </os>
+
+</libosinfo>
diff --git a/data/recommended-downloads.xml b/data/recommended-downloads.xml
index b389e94..6f2ccce 100644
--- a/data/recommended-downloads.xml
+++ b/data/recommended-downloads.xml
@@ -9,10 +9,11 @@
available.
-->
<list>
- <os_id>http://redhat.com/rhel/7.6</os_id>
- <os_id>http://fedoraproject.org/fedora/29</os_id>
- <os_id>http://fedoraproject.org/silverblue/29</os_id>
- <os_id>http://ubuntu.com/ubuntu/18.10</os_id>
- <os_id>http://opensuse.org/opensuse/15.0</os_id>
+ <os_id>http://redhat.com/rhel/8.1</os_id>
+ <os_id>http://redhat.com/rhel/7.7</os_id>
+ <os_id>http://fedoraproject.org/fedora/30</os_id>
+ <os_id>http://fedoraproject.org/silverblue/30</os_id>
+ <os_id>http://ubuntu.com/ubuntu/19.04</os_id>
+ <os_id>http://opensuse.org/opensuse/15.1</os_id>
<os_id>http://debian.org/debian/9</os_id>
</list>

View File

@ -31,7 +31,7 @@ ExclusiveArch: x86_64
Name: gnome-boxes
Version: 3.28.5
Release: 3%{?dist}
Release: 7%{?dist}
Summary: A simple GNOME 3 application to access remote or virtual systems
License: LGPLv2+
@ -47,6 +47,12 @@ Patch1: gnome-boxes-use-q35-machine-type.patch
# https://bugzilla.redhat.com/1656446
Patch2: gnome-boxes-hardcode-recommended-oses.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1713130
Patch3: gnome-boxes-update-rhel-logo.patch
# https://bugzilla.redhat.com/1739897
Patch4: gnome-boxes-offer-only-supported-arches.patch
BuildRequires: gettext >= 0.19.8
BuildRequires: meson
BuildRequires: vala >= 0.36.0
@ -117,6 +123,8 @@ gnome-boxes lets you easily create, setup, access, and use:
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%build
%meson \
@ -154,6 +162,26 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/org.gnome.Boxes.deskt
%{_datadir}/metainfo/org.gnome.Boxes.appdata.xml
%changelog
* Thu Aug 15 2019 Felipe Borges <feborges@redhat.com> - 3.28.5-7
- Bump the release to 3.28.5-7
- Related: #1739897
* Thu Aug 15 2019 Felipe Borges <feborges@redhat.com> - 3.28.5-7
- Filter off unsupported architectures
- Related: #1739897
* Mon Jun 17 2019 Fabiano Fidêncio <fidencio@redhat.com> - 3.28.5-6
- Revert "Add 3D acceleration option (powered by virgl)"
- Related: #1647004
* Mon Jun 03 2019 Felipe Borges <feborges@redhat.com> - 3.28.5-5
- Add 3D acceleration option (powered by virgl)
- Resolves: #1647004
* Thu May 23 2019 Fabiano Fidêncio <fidencio@redhat.com> - 3.28.5-4
- Add rhel-8.0 logo & update logo for rhel-4.0 & update recommendations
- Resolves: #1713130
* Wed Dec 05 2018 Felipe Borges <feborges@redhat.com> - 3.28.5-3
- Pick our recommended downloads
- Related #1656446