Add necessary patch, remove obsolete ones
This commit is contained in:
parent
55cb2cfcb4
commit
d3f90a473e
@ -1,11 +0,0 @@
|
|||||||
--- gnome-bluetooth-0.7.0/python/manager.py.path 2006-02-16 18:48:02.000000000 +0100
|
|
||||||
+++ gnome-bluetooth-0.7.0/python/manager.py 2006-02-16 18:48:25.000000000 +0100
|
|
||||||
@@ -265,7 +265,7 @@
|
|
||||||
dialog.show ()
|
|
||||||
|
|
||||||
def image_file (self, fname):
|
|
||||||
- for d in [os.path.join (__datadir__, "pixmaps"), "../pixmaps"]:
|
|
||||||
+ for d in [os.path.join (__datadir__, "pixmaps"), "../pixmaps", "/usr/share/pixmaps"]:
|
|
||||||
if os.path.isfile (os.path.join (d, fname)):
|
|
||||||
return os.path.join (d, fname)
|
|
||||||
return None
|
|
@ -1,161 +0,0 @@
|
|||||||
--- gnome-bluetooth-0.7.0/src/Makefile.am.pydir 2006-02-27 14:37:05.000000000 +0100
|
|
||||||
+++ gnome-bluetooth-0.7.0/src/Makefile.am 2006-02-27 14:37:52.000000000 +0100
|
|
||||||
@@ -118,7 +118,7 @@
|
|
||||||
--override $(srcdir)/gnomebt-chooser.override \
|
|
||||||
$(srcdir)/gnomebt-chooser.defs > $@
|
|
||||||
|
|
||||||
-pydir = @pythondir@/gnomebt/
|
|
||||||
+pydir = @pyexecdir@/gnomebt/
|
|
||||||
|
|
||||||
controller_la_SOURCES = gnomebt-controller-py.c gnomebt-controller-pymodule.c
|
|
||||||
controller_la_LIBADD = libgnomebt.la
|
|
||||||
--- gnome-bluetooth-0.7.0/acinclude.m4.pydir 2005-11-21 23:13:25.000000000 +0100
|
|
||||||
+++ gnome-bluetooth-0.7.0/acinclude.m4 2006-02-27 14:31:40.000000000 +0100
|
|
||||||
@@ -27,108 +27,6 @@
|
|
||||||
# doesn't meet the requirement. MINIMUM-VERSION should consist of
|
|
||||||
# numbers and dots only.
|
|
||||||
|
|
||||||
-
|
|
||||||
-AC_DEFUN([AM_PATH_PYTHON],
|
|
||||||
- [
|
|
||||||
- dnl Find a version of Python. I could check for python versions 1.4
|
|
||||||
- dnl or earlier, but the default installation locations changed from
|
|
||||||
- dnl $prefix/lib/site-python in 1.4 to $prefix/lib/python1.5/site-packages
|
|
||||||
- dnl in 1.5, and I don't want to maintain that logic.
|
|
||||||
-
|
|
||||||
- AC_PATH_PROG(PYTHON, python python2.1 python2.0 python1.6 python1.5)
|
|
||||||
-
|
|
||||||
- dnl should we do the version check?
|
|
||||||
- ifelse([$1],[],,[
|
|
||||||
- AC_MSG_CHECKING(if Python version >= $1)
|
|
||||||
- changequote(<<, >>)dnl
|
|
||||||
- prog="
|
|
||||||
-import sys, string
|
|
||||||
-minver = '$1'
|
|
||||||
-pyver = string.split(sys.version)[0] # first word is version string
|
|
||||||
-# split strings by '.' and convert to numeric
|
|
||||||
-minver = map(string.atoi, string.split(minver, '.'))
|
|
||||||
-pyver = map(string.atoi, string.split(pyver, '.'))
|
|
||||||
-# we can now do comparisons on the two lists:
|
|
||||||
-if pyver >= minver:
|
|
||||||
- sys.exit(0)
|
|
||||||
-else:
|
|
||||||
- sys.exit(1)"
|
|
||||||
- changequote([, ])dnl
|
|
||||||
- if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
|
|
||||||
- then
|
|
||||||
- AC_MSG_RESULT(okay)
|
|
||||||
- else
|
|
||||||
- AC_MSG_ERROR(too old)
|
|
||||||
- fi
|
|
||||||
- ])
|
|
||||||
-
|
|
||||||
- AC_MSG_CHECKING([local Python configuration])
|
|
||||||
-
|
|
||||||
- dnl Query Python for its version number. Getting [:3] seems to be
|
|
||||||
- dnl the best way to do this; it's what "site.py" does in the standard
|
|
||||||
- dnl library. Need to change quote character because of [:3]
|
|
||||||
-
|
|
||||||
- AC_SUBST(PYTHON_VERSION)
|
|
||||||
- changequote(<<, >>)dnl
|
|
||||||
- PYTHON_VERSION=`$PYTHON -c "import sys; print sys.version[:3]"`
|
|
||||||
- changequote([, ])dnl
|
|
||||||
-
|
|
||||||
-
|
|
||||||
- dnl Use the values of $prefix and $exec_prefix for the corresponding
|
|
||||||
- dnl values of PYTHON_PREFIX and PYTHON_EXEC_PREFIX. These are made
|
|
||||||
- dnl distinct variables so they can be overridden if need be. However,
|
|
||||||
- dnl general consensus is that you shouldn't need this ability.
|
|
||||||
-
|
|
||||||
- AC_SUBST(PYTHON_PREFIX)
|
|
||||||
- changequote(<<, >>)dnl
|
|
||||||
- PYTHON_PREFIX=`$PYTHON -c "import sys; print sys.prefix"`
|
|
||||||
- changequote([, ])dnl
|
|
||||||
-
|
|
||||||
- AC_SUBST(PYTHON_EXEC_PREFIX)
|
|
||||||
- PYTHON_EXEC_PREFIX='${exec_prefix}'
|
|
||||||
-
|
|
||||||
- dnl At times (like when building shared libraries) you may want
|
|
||||||
- dnl to know which OS platform Python thinks this is.
|
|
||||||
-
|
|
||||||
- AC_SUBST(PYTHON_PLATFORM)
|
|
||||||
- PYTHON_PLATFORM=`$PYTHON -c "import sys; print sys.platform"`
|
|
||||||
-
|
|
||||||
-
|
|
||||||
- dnl Set up 4 directories:
|
|
||||||
-
|
|
||||||
- dnl pythondir -- where to install python scripts. This is the
|
|
||||||
- dnl site-packages directory, not the python standard library
|
|
||||||
- dnl directory like in previous automake betas. This behaviour
|
|
||||||
- dnl is more consistent with lispdir.m4 for example.
|
|
||||||
- dnl
|
|
||||||
- dnl Also, if the package prefix isn't the same as python's prefix,
|
|
||||||
- dnl then the old $(pythondir) was pretty useless.
|
|
||||||
-
|
|
||||||
- AC_SUBST(pythondir)
|
|
||||||
- pythondir=$PYTHON_PREFIX${libdir##$prefix}"/python"$PYTHON_VERSION"/site-packages"
|
|
||||||
-
|
|
||||||
- dnl pkgpythondir -- $PACKAGE directory under pythondir. Was
|
|
||||||
- dnl PYTHON_SITE_PACKAGE in previous betas, but this naming is
|
|
||||||
- dnl more consistent with the rest of automake.
|
|
||||||
- dnl Maybe this should be put in python.am?
|
|
||||||
-
|
|
||||||
- AC_SUBST(pkgpythondir)
|
|
||||||
- pkgpythondir=\${pythondir}/$PACKAGE
|
|
||||||
-
|
|
||||||
- dnl pyexecdir -- directory for installing python extension modules
|
|
||||||
- dnl (shared libraries) Was PYTHON_SITE_EXEC in previous betas.
|
|
||||||
-
|
|
||||||
- AC_SUBST(pyexecdir)
|
|
||||||
- pyexecdir=$PYTHON_EXEC_PREFIX"/lib/python"$PYTHON_VERSION/site-packages
|
|
||||||
-
|
|
||||||
- dnl pkgpyexecdir -- $(pyexecdir)/$(PACKAGE)
|
|
||||||
- dnl Maybe this should be put in python.am?
|
|
||||||
-
|
|
||||||
- AC_SUBST(pkgpyexecdir)
|
|
||||||
- pkgpyexecdir=\${pyexecdir}/$PACKAGE
|
|
||||||
-
|
|
||||||
- AC_MSG_RESULT([looks good])
|
|
||||||
-])
|
|
||||||
dnl -- taken from gnome-python -- thanks james henstridge
|
|
||||||
dnl a macro to check for ability to create python extensions
|
|
||||||
dnl AM_CHECK_PYTHON_HEADERS([ACTION-IF-POSSIBLE], [ACTION-IF-NOT-POSSIBLE])
|
|
||||||
@@ -141,7 +39,8 @@
|
|
||||||
py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
|
|
||||||
PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
|
|
||||||
if test "$py_prefix" != "$py_exec_prefix"; then
|
|
||||||
- PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
|
|
||||||
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_V
|
|
||||||
+ERSION}"
|
|
||||||
fi
|
|
||||||
AC_SUBST(PYTHON_INCLUDES)
|
|
||||||
dnl check if the headers exist:
|
|
||||||
@@ -155,27 +54,6 @@
|
|
||||||
CPPFLAGS="$save_CPPFLAGS"
|
|
||||||
])
|
|
||||||
|
|
||||||
-dnl
|
|
||||||
-dnl JH_ADD_CFLAG(FLAG)
|
|
||||||
-dnl checks whether the C compiler supports the given flag, and if so, adds
|
|
||||||
-dnl it to $CFLAGS. If the flag is already present in the list, then the
|
|
||||||
-dnl check is not performed.
|
|
||||||
-AC_DEFUN([JH_ADD_CFLAG],
|
|
||||||
-[
|
|
||||||
-case " $CFLAGS " in
|
|
||||||
-*@<:@\ \ @:>@$1@<:@\ \ @:>@*)
|
|
||||||
- ;;
|
|
||||||
-*)
|
|
||||||
- save_CFLAGS="$CFLAGS"
|
|
||||||
- CFLAGS="$CFLAGS $1"
|
|
||||||
- AC_MSG_CHECKING([whether [$]CC understands $1])
|
|
||||||
- AC_TRY_COMPILE([], [], [jh_has_option=yes], [jh_has_option=no])
|
|
||||||
- AC_MSG_RESULT($jh_has_option)
|
|
||||||
- if test $jh_has_option = no; then
|
|
||||||
- CFLAGS="$save_CFLAGS"
|
|
||||||
- fi
|
|
||||||
- ;;
|
|
||||||
-esac])
|
|
||||||
dnl Configure paths for libsdp
|
|
||||||
dnl Edd Dumbill <edd@usefulinc.com>
|
|
||||||
dnl Shamelessly stolen from Jack Moffitt, who stole
|
|
||||||
|
|
29
sendto-connect-fix.patch
Normal file
29
sendto-connect-fix.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- trunk/sendto/main.c 2009/03/04 18:42:45 457
|
||||||
|
+++ trunk/sendto/main.c 2009/03/05 00:12:12 458
|
||||||
|
@@ -369,12 +369,12 @@
|
||||||
|
GTK_RESPONSE_CLOSE, TRUE);
|
||||||
|
}
|
||||||
|
|
||||||
|
-static void session_connect_error (DBusGProxy *proxy, DBusGProxy *session_obj, const char *error_name,
|
||||||
|
+static void session_connect_error (DBusGProxy *proxy, const char *session_obj, const char *error_name,
|
||||||
|
const char *error_message, gpointer user_data)
|
||||||
|
{
|
||||||
|
gchar *text;
|
||||||
|
|
||||||
|
- if (session_obj != session_proxy)
|
||||||
|
+ if (strcmp (session_obj, dbus_g_proxy_get_path (session_proxy)) != 0)
|
||||||
|
return;
|
||||||
|
|
||||||
|
gtk_progress_bar_set_text(GTK_PROGRESS_BAR(progress),
|
||||||
|
@@ -388,9 +388,9 @@
|
||||||
|
GTK_RESPONSE_CLOSE, TRUE);
|
||||||
|
}
|
||||||
|
|
||||||
|
-static void session_connected(DBusGProxy *proxy, DBusGProxy *session_obj, gpointer user_data)
|
||||||
|
+static void session_connected(DBusGProxy *proxy, const char *session_obj, gpointer user_data)
|
||||||
|
{
|
||||||
|
- if (session_obj != session_proxy)
|
||||||
|
+ if (strcmp (session_obj, dbus_g_proxy_get_path (session_proxy)) != 0)
|
||||||
|
return;
|
||||||
|
|
||||||
|
gtk_progress_bar_set_text(GTK_PROGRESS_BAR(progress), NULL);
|
Loading…
Reference in New Issue
Block a user