pydir patch
This commit is contained in:
parent
2c25d06631
commit
ce351c5815
@ -158,24 +158,4 @@
|
||||
dnl Configure paths for libsdp
|
||||
dnl Edd Dumbill <edd@usefulinc.com>
|
||||
dnl Shamelessly stolen from Jack Moffitt, who stole
|
||||
--- gnome-bluetooth-0.7.0/python/Makefile.am.pydir 2006-02-27 14:37:13.000000000 +0100
|
||||
+++ gnome-bluetooth-0.7.0/python/Makefile.am 2006-02-27 14:37:30.000000000 +0100
|
||||
@@ -1,5 +1,5 @@
|
||||
|
||||
-pythondir = @pythondir@/gnomebt
|
||||
+pythondir = @pyexecdir@/gnomebt
|
||||
pkgpythondir = $(pythondir)
|
||||
libdir = $(pkgpythondir)
|
||||
|
||||
--- gnome-bluetooth-0.7.0/python/gnome-bluetooth-manager.in.pydir 2005-11-19 20:02:14.000000000 +0100
|
||||
+++ gnome-bluetooth-0.7.0/python/gnome-bluetooth-manager.in 2006-02-27 14:31:40.000000000 +0100
|
||||
@@ -1,4 +1,7 @@
|
||||
#!/bin/sh
|
||||
-PYTHONPATH=@pythondir@:$PYTHONPATH
|
||||
+PYEXECDIR=$(/usr/bin/python -c "from distutils import sysconfig; print sysconfig.get_python_lib(1,0,prefix='/usr')")
|
||||
+
|
||||
+PYTHONPATH="$PYEXECDIR:$PYTHONPATH"
|
||||
export PYTHONPATH
|
||||
-exec @PYTHON@ @pythondir@/gnomebt/manager.py
|
||||
+exec /usr/bin/python $PYEXECDIR/gnomebt/manager.py
|
||||
+
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user