add missing libs
This commit is contained in:
parent
55a365a16f
commit
ccb31137fb
12
gnome-bluetooth-libs.patch
Normal file
12
gnome-bluetooth-libs.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up gnome-bluetooth-2.29.3/lib/Makefile.am.libs gnome-bluetooth-2.29.3/lib/Makefile.am
|
||||||
|
--- gnome-bluetooth-2.29.3/lib/Makefile.am.libs 2010-02-14 14:00:40.224154013 -0500
|
||||||
|
+++ gnome-bluetooth-2.29.3/lib/Makefile.am 2010-02-14 14:01:10.183903796 -0500
|
||||||
|
@@ -39,7 +39,7 @@ libgnome_bluetooth_la_SOURCES = \
|
||||||
|
bluetooth-chooser-combo.c \
|
||||||
|
bluetooth-chooser-combo.h
|
||||||
|
|
||||||
|
-libgnome_bluetooth_la_LIBADD = $(LIBGNOMEBT_LIBS)
|
||||||
|
+libgnome_bluetooth_la_LIBADD = $(LIBGNOMEBT_LIBS) -lm
|
||||||
|
|
||||||
|
libgnome_bluetooth_la_LDFLAGS = \
|
||||||
|
-version-info $(GNOMEBT_LT_VERSION) \
|
@ -1,6 +1,6 @@
|
|||||||
Name: gnome-bluetooth
|
Name: gnome-bluetooth
|
||||||
Version: 2.29.3
|
Version: 2.29.3
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Summary: Bluetooth graphical utilities
|
Summary: Bluetooth graphical utilities
|
||||||
|
|
||||||
Group: Applications/Communications
|
Group: Applications/Communications
|
||||||
@ -8,7 +8,6 @@ License: GPLv2+
|
|||||||
URL: http://live.gnome.org/GnomeBluetooth
|
URL: http://live.gnome.org/GnomeBluetooth
|
||||||
Source0: http://download.gnome.org/sources/gnome-bluetooth/2.28/gnome-bluetooth-%{version}.tar.bz2
|
Source0: http://download.gnome.org/sources/gnome-bluetooth/2.28/gnome-bluetooth-%{version}.tar.bz2
|
||||||
Source1: 61-gnome-bluetooth-rfkill.rules
|
Source1: 61-gnome-bluetooth-rfkill.rules
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
|
||||||
|
|
||||||
BuildRequires: gtk2-devel
|
BuildRequires: gtk2-devel
|
||||||
BuildRequires: GConf2-devel
|
BuildRequires: GConf2-devel
|
||||||
@ -25,6 +24,8 @@ BuildRequires: intltool desktop-file-utils gettext gtk-doc
|
|||||||
|
|
||||||
BuildRequires: gir-repository-devel
|
BuildRequires: gir-repository-devel
|
||||||
BuildRequires: gobject-introspection-devel
|
BuildRequires: gobject-introspection-devel
|
||||||
|
BuildRequires: autoconf automake libtool
|
||||||
|
BuildRequires: gnome-common
|
||||||
|
|
||||||
Obsoletes: bluez-pin
|
Obsoletes: bluez-pin
|
||||||
Provides: dbus-bluez-pin-helper
|
Provides: dbus-bluez-pin-helper
|
||||||
@ -43,6 +44,8 @@ Requires(postun): desktop-file-utils
|
|||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=544881
|
# https://bugzilla.redhat.com/show_bug.cgi?id=544881
|
||||||
Patch0: 0001-Fix-memory-leaks-when-using-dbus_g_method_get_sender.patch
|
Patch0: 0001-Fix-memory-leaks-when-using-dbus_g_method_get_sender.patch
|
||||||
Patch1: 0002-Fix-crash-when-obex-client-isn-t-running-already.patch
|
Patch1: 0002-Fix-crash-when-obex-client-isn-t-running-already.patch
|
||||||
|
#
|
||||||
|
Patch2: gnome-bluetooth-libs.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The gnome-bluetooth package contains graphical utilities to setup,
|
The gnome-bluetooth package contains graphical utilities to setup,
|
||||||
@ -83,6 +86,9 @@ This package contains the Moblin user interface for gnome-bluetooth.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1 -b .libs
|
||||||
|
|
||||||
|
autoreconf -i -f
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-desktop-update --disable-icon-update
|
%configure --disable-desktop-update --disable-icon-update
|
||||||
@ -133,7 +139,6 @@ done
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%post
|
%post
|
||||||
scrollkeeper-update -q
|
|
||||||
update-desktop-database -q
|
update-desktop-database -q
|
||||||
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||||
gconftool-2 --makefile-install-rule \
|
gconftool-2 --makefile-install-rule \
|
||||||
@ -169,7 +174,6 @@ if [ "$1" -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
scrollkeeper-update -q
|
|
||||||
update-desktop-database -q
|
update-desktop-database -q
|
||||||
if [ $1 -eq 0 ] ; then
|
if [ $1 -eq 0 ] ; then
|
||||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
||||||
@ -227,6 +231,9 @@ fi
|
|||||||
%{_bindir}/bluetooth-panel
|
%{_bindir}/bluetooth-panel
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Feb 14 2010 Matthias Clasen <mclasen@redhat.com> 2.29.3-5
|
||||||
|
- Add missing libs
|
||||||
|
|
||||||
* Thu Jan 28 2010 Bastien Nocera <bnocera@redhat.com> 2.29.3-4
|
* Thu Jan 28 2010 Bastien Nocera <bnocera@redhat.com> 2.29.3-4
|
||||||
- Fix a few rpmlint warnings
|
- Fix a few rpmlint warnings
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user