add missing libs

This commit is contained in:
Matthias Clasen 2010-02-14 19:07:47 +00:00
parent 55a365a16f
commit ccb31137fb
2 changed files with 23 additions and 4 deletions

View File

@ -0,0 +1,12 @@
diff -up gnome-bluetooth-2.29.3/lib/Makefile.am.libs gnome-bluetooth-2.29.3/lib/Makefile.am
--- gnome-bluetooth-2.29.3/lib/Makefile.am.libs 2010-02-14 14:00:40.224154013 -0500
+++ gnome-bluetooth-2.29.3/lib/Makefile.am 2010-02-14 14:01:10.183903796 -0500
@@ -39,7 +39,7 @@ libgnome_bluetooth_la_SOURCES = \
bluetooth-chooser-combo.c \
bluetooth-chooser-combo.h
-libgnome_bluetooth_la_LIBADD = $(LIBGNOMEBT_LIBS)
+libgnome_bluetooth_la_LIBADD = $(LIBGNOMEBT_LIBS) -lm
libgnome_bluetooth_la_LDFLAGS = \
-version-info $(GNOMEBT_LT_VERSION) \

View File

@ -1,6 +1,6 @@
Name: gnome-bluetooth
Version: 2.29.3
Release: 4%{?dist}
Release: 5%{?dist}
Summary: Bluetooth graphical utilities
Group: Applications/Communications
@ -8,7 +8,6 @@ License: GPLv2+
URL: http://live.gnome.org/GnomeBluetooth
Source0: http://download.gnome.org/sources/gnome-bluetooth/2.28/gnome-bluetooth-%{version}.tar.bz2
Source1: 61-gnome-bluetooth-rfkill.rules
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires: gtk2-devel
BuildRequires: GConf2-devel
@ -25,6 +24,8 @@ BuildRequires: intltool desktop-file-utils gettext gtk-doc
BuildRequires: gir-repository-devel
BuildRequires: gobject-introspection-devel
BuildRequires: autoconf automake libtool
BuildRequires: gnome-common
Obsoletes: bluez-pin
Provides: dbus-bluez-pin-helper
@ -43,6 +44,8 @@ Requires(postun): desktop-file-utils
# https://bugzilla.redhat.com/show_bug.cgi?id=544881
Patch0: 0001-Fix-memory-leaks-when-using-dbus_g_method_get_sender.patch
Patch1: 0002-Fix-crash-when-obex-client-isn-t-running-already.patch
#
Patch2: gnome-bluetooth-libs.patch
%description
The gnome-bluetooth package contains graphical utilities to setup,
@ -83,6 +86,9 @@ This package contains the Moblin user interface for gnome-bluetooth.
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1 -b .libs
autoreconf -i -f
%build
%configure --disable-desktop-update --disable-icon-update
@ -133,7 +139,6 @@ done
rm -rf $RPM_BUILD_ROOT
%post
scrollkeeper-update -q
update-desktop-database -q
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-install-rule \
@ -169,7 +174,6 @@ if [ "$1" -eq 0 ]; then
fi
%postun
scrollkeeper-update -q
update-desktop-database -q
if [ $1 -eq 0 ] ; then
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
@ -227,6 +231,9 @@ fi
%{_bindir}/bluetooth-panel
%changelog
* Sun Feb 14 2010 Matthias Clasen <mclasen@redhat.com> 2.29.3-5
- Add missing libs
* Thu Jan 28 2010 Bastien Nocera <bnocera@redhat.com> 2.29.3-4
- Fix a few rpmlint warnings