diff --git a/gnome-bluetooth.spec b/gnome-bluetooth.spec
index 24c8135..106e416 100644
--- a/gnome-bluetooth.spec
+++ b/gnome-bluetooth.spec
@@ -1,7 +1,7 @@
Summary: GNOME Bluetooth Subsystem
Name: gnome-bluetooth
Version: 0.5.1
-Release: 12
+Release: 13
License: GPL
Group: System Environment/Libraries
URL: http://usefulinc.com/software/gnome-bluetooth
@@ -10,17 +10,15 @@ Patch1: gnome-bluetooth-0.5.1-pydir.patch
Patch2: gnome-bluetooth-0.5.1-auto.patch
Patch3: gnome-bluetooth-0.5.1-unref.patch
Patch4: gnome-bluetooth-0.5.1-gnomepython.patch
-BuildRoot: %{_tmppath}/%{name}-root
-BuildRequires: autoconf >= 0:2.57 bluez-libs-devel >= 0:2.8 bluez-utils
-BuildRequires: glib2-devel >= 0:2.2.0 libgnomeui-devel >= 0:2.2 libbonobo-devel >= 0:2.0
-BuildRequires: GConf2-devel >= 0:2.0 librsvg2-devel
-BuildRequires: libbtctl-devel >= 0:0.4.1-2
-BuildRequires: gob2 openobex-devel >= 0:1.0.1 perl
-BuildRequires: pygtk2-devel
-Requires: %{name}-libs = 0:%{version}-%{release}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: autoconf >= 2.57 bluez-libs-devel >= 2.8 bluez-utils
+BuildRequires: libgnomeui-devel >= 2.2 libbonobo-devel >= 2.0
+BuildRequires: GConf2-devel >= 2.0 librsvg2-devel
+BuildRequires: libbtctl-devel >= 0.4.1-2
+BuildRequires: gob2 openobex-devel >= 1.0.1
+BuildRequires: pygtk2-devel python-devel
+Requires: %{name}-libs = %{version}-%{release}
ExcludeArch: s390 s390x
-%define pyver %(%{__python} -c "import sys; print sys.version[:3]")
-Requires: python-abi = %{pyver}
%description
This package contains a Bonobo server to control Bluetooth devices,
@@ -39,7 +37,7 @@ This package contains the libraries for applications, which use gnome-bluetooth.
%package devel
Summary: Files for the development of applications, which use gnome-bluetooth
Group: Development/Libraries
-Requires: %{name}-libs = 0:%{version}-%{release}
+Requires: %{name}-libs = %{version}-%{release}
Requires: glib2-devel
Requires: libbtctl-devel
@@ -56,6 +54,8 @@ rm -rf $RPM_BUILD_ROOT
%patch3 -p1 -b .unref
%patch4 -p1 -b .gnome
+perl -pi -e 's|^Icon=.*|Icon=%{_datadir}/pixmaps/blueradio.png|g' \
+ */*.desktop.in
#perl -pi -e 's#-DGTK_DISABLE_DEPRECATED##g' $(find libegg -name Makefile.in)
%build
@@ -66,13 +66,15 @@ make
rm -rf $RPM_BUILD_ROOT
%makeinstall
./libtool --finish $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules
+mkdir -p %{buildroot}%{_datadir}/pixmaps/
+cp -a %{buildroot}%{_datadir}/gnome-bluetooth/pixmaps/blueradio-48.png \
+ %{buildroot}%{_datadir}/pixmaps/blueradio.png
# we do not want .la files
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
-%find_lang %name
-
+%find_lang %{name}
%clean
rm -rf $RPM_BUILD_ROOT
@@ -86,29 +88,34 @@ rm -rf $RPM_BUILD_ROOT
%doc AUTHORS COPYING ChangeLog NEWS README
#%{_bindir}/gnome-bluetooth-admin
%{_bindir}/gnome-bluetooth-manager
-%{_bindir}/gnome-obex-server
%{_bindir}/gnome-obex-send
+%{_bindir}/gnome-obex-server
%{_datadir}/applications/gnome-obex-server.desktop
-%{_datadir}/gnome-bluetooth
%{_datadir}/applications/gnome-bluetooth-manager.desktop
+%{_datadir}/gnome-bluetooth/
+%{_datadir}/pixmaps/blueradio.png
%files libs
%defattr(-, root, root)
%{_libdir}/libgnomebt.so.*
%{_libdir}/bonobo/libgnome-bluetooth-component.so
%{_libdir}/bonobo/servers/GNOME_Bluetooth_Component.server
-%dir %{_libdir}/python*.*/site-packages/gnomebt
-%{_libdir}/python*.*/site-packages/gnomebt/*
-
+%{_libdir}/python*.*/site-packages/gnomebt/
%files devel
%defattr(-, root, root)
%{_libdir}/pkgconfig/gnome-bluetooth.pc
%{_libdir}/libgnomebt.so
-%{_prefix}/include/gnome-bluetooth
-
+%{_includedir}/gnome-bluetooth/
%changelog
+* Thu Jul 7 2005 Matthias Saou 0.5.1-13
+- Minor spec file cleanups.
+- Fix relative path for the icons in desktop files which no longer works
+ with the icon cache.
+- Remove useless zero epochs.
+- Remove explicit python abi requirement, it's automatic for FC4 and up.
+
* Thu Mar 31 2005 Harald Hoyer - 0.5.1-12
- removed base requirement from libs