60 lines
2.2 KiB
Diff
60 lines
2.2 KiB
Diff
diff -up gmp-4.3.1/configure.in.s390 gmp-4.3.1/configure.in
|
|
--- gmp-4.3.1/configure.in.s390 2009-05-12 08:12:12.000000000 +0200
|
|
+++ gmp-4.3.1/configure.in 2009-05-28 14:59:54.000000000 +0200
|
|
@@ -1066,6 +1066,11 @@ case $host in
|
|
;;
|
|
|
|
|
|
+ s390x-*-*)
|
|
+ gcc_cflags="-g -O2 $fomit_frame_pointer"
|
|
+ path="s390x"
|
|
+ #extra_functions="udiv_w_sdiv"
|
|
+ ;;
|
|
# IBM s/370 and similar
|
|
[s3[6-9]0*-*-*])
|
|
gcc_cflags="$gcc_cflags $fomit_frame_pointer"
|
|
diff -up gmp-4.3.1/mpn/s390/gmp-mparam.h.s390 gmp-4.3.1/mpn/s390/gmp-mparam.h
|
|
--- gmp-4.3.1/mpn/s390/gmp-mparam.h.s390 2009-05-12 08:12:12.000000000 +0200
|
|
+++ gmp-4.3.1/mpn/s390/gmp-mparam.h 2009-05-28 14:59:54.000000000 +0200
|
|
@@ -18,7 +18,8 @@ You should have received a copy of the G
|
|
along with the GNU MP Library. If not, see http://www.gnu.org/licenses/. */
|
|
|
|
|
|
-/* BITS_PER_MP_LIMB etc generated by configure */
|
|
+#define BITS_PER_MP_LIMB 32
|
|
+#define BYTES_PER_MP_LIMB 4
|
|
|
|
|
|
/* Generated by tuneup.c, 2001-12-03, gcc 2.95 */
|
|
diff -up /dev/null gmp-4.3.1/mpn/s390x/gmp-mparam.h
|
|
--- /dev/null 2009-05-25 10:38:12.683001420 +0200
|
|
+++ gmp-4.3.1/mpn/s390x/gmp-mparam.h 2009-05-28 14:59:54.000000000 +0200
|
|
@@ -0,0 +1,27 @@
|
|
+/* gmp-mparam.h -- Compiler/machine parameter header file.
|
|
+
|
|
+Copyright (C) 1991, 1993, 1994, 1995 Free Software Foundation, Inc.
|
|
+
|
|
+This file is part of the GNU MP Library.
|
|
+
|
|
+The GNU MP Library is free software; you can redistribute it and/or modify
|
|
+it under the terms of the GNU Library General Public License as published by
|
|
+the Free Software Foundation; either version 2 of the License, or (at your
|
|
+option) any later version.
|
|
+
|
|
+The GNU MP Library is distributed in the hope that it will be useful, but
|
|
+WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
|
|
+or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Library General Public
|
|
+License for more details.
|
|
+
|
|
+You should have received a copy of the GNU Library General Public License
|
|
+along with the GNU MP Library; see the file COPYING.LIB. If not, write to
|
|
+the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
|
|
+MA 02111-1307, USA. */
|
|
+
|
|
+#define BITS_PER_MP_LIMB 64
|
|
+#define BYTES_PER_MP_LIMB 8
|
|
+#define BITS_PER_LONGINT 64
|
|
+#define BITS_PER_INT 32
|
|
+#define BITS_PER_SHORTINT 16
|
|
+#define BITS_PER_CHAR 8
|