gmp/gmp-4.0.1-s390.patch
Peter Schiffer de470d2d4d resolves: #702919
update to 5.0.2
resolves: #738091
removed unused direct shlib dependency on libm
updated license in gmp.h and gmp-mparam.h files
2011-09-20 10:18:47 +02:00

58 lines
2.1 KiB
Diff

diff -up gmp-5.0.2/configure.in.tmp gmp-5.0.2/configure.in
--- gmp-5.0.2/configure.in.tmp 2011-05-08 11:49:29.000000000 +0200
+++ gmp-5.0.2/configure.in 2011-08-15 14:34:22.543596916 +0200
@@ -1109,6 +1109,10 @@ case $host in
path="pyr"
;;
+ s390x-*-*)
+ gcc_cflags="-g -O2 $fomit_frame_pointer"
+ path="s390x"
+ ;;
# IBM s/370 and similar
[s3[6-9]0*-*-*])
diff -up gmp-5.0.2/mpn/s390/gmp-mparam.h.tmp gmp-5.0.2/mpn/s390/gmp-mparam.h
--- gmp-5.0.2/mpn/s390/gmp-mparam.h.tmp 2011-08-15 14:37:48.000000000 +0200
+++ gmp-5.0.2/mpn/s390/gmp-mparam.h 2011-08-15 14:38:22.884229091 +0200
@@ -18,7 +18,8 @@ You should have received a copy of the G
along with the GNU MP Library. If not, see http://www.gnu.org/licenses/. */
-/* GMP_LIMB_BITS etc generated by configure */
+#define BITS_PER_MP_LIMB 32
+#define BYTES_PER_MP_LIMB 4
/* Generated by tuneup.c, 2001-12-03, gcc 2.95 */
diff -up /dev/null gmp-4.3.1/mpn/s390x/gmp-mparam.h
--- /dev/null 2009-05-25 10:38:12.683001420 +0200
+++ gmp-4.3.1/mpn/s390x/gmp-mparam.h 2009-05-28 14:59:54.000000000 +0200
@@ -0,0 +1,26 @@
+/* gmp-mparam.h -- Compiler/machine parameter header file.
+
+Copyright 1991, 1993, 1994, 1995, 1996, 1997, 1999, 2000, 2001, 2002, 2003,
+2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation, Inc.
+
+This file is part of the GNU MP Library.
+
+The GNU MP Library is free software; you can redistribute it and/or modify
+it under the terms of the GNU Lesser General Public License as published by
+the Free Software Foundation; either version 3 of the License, or (at your
+option) any later version.
+
+The GNU MP Library is distributed in the hope that it will be useful, but
+WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public
+License for more details.
+
+You should have received a copy of the GNU Lesser General Public License
+along with the GNU MP Library. If not, see http://www.gnu.org/licenses/. */
+
+#define BITS_PER_MP_LIMB 64
+#define BYTES_PER_MP_LIMB 8
+#define BITS_PER_LONGINT 64
+#define BITS_PER_INT 32
+#define BITS_PER_SHORTINT 16
+#define BITS_PER_CHAR 8