remove obsolete patch, regenerate problematic one
This commit is contained in:
parent
35cb7c1b6a
commit
fbb8534d78
@ -1,6 +1,34 @@
|
||||
diff -up /dev/null gmp-4.2.2/mpn/s390x/gmp-mparam.h
|
||||
--- /dev/null 2008-09-01 10:12:52.609021969 +0200
|
||||
+++ gmp-4.2.2/mpn/s390x/gmp-mparam.h 2008-09-01 13:04:05.000000000 +0200
|
||||
diff -up gmp-4.3.1/configure.in.s390 gmp-4.3.1/configure.in
|
||||
--- gmp-4.3.1/configure.in.s390 2009-05-12 08:12:12.000000000 +0200
|
||||
+++ gmp-4.3.1/configure.in 2009-05-28 14:59:54.000000000 +0200
|
||||
@@ -1066,6 +1066,11 @@ case $host in
|
||||
;;
|
||||
|
||||
|
||||
+ s390x-*-*)
|
||||
+ gcc_cflags="-g -O2 $fomit_frame_pointer"
|
||||
+ path="s390x"
|
||||
+ #extra_functions="udiv_w_sdiv"
|
||||
+ ;;
|
||||
# IBM s/370 and similar
|
||||
[s3[6-9]0*-*-*])
|
||||
gcc_cflags="$gcc_cflags $fomit_frame_pointer"
|
||||
diff -up gmp-4.3.1/mpn/s390/gmp-mparam.h.s390 gmp-4.3.1/mpn/s390/gmp-mparam.h
|
||||
--- gmp-4.3.1/mpn/s390/gmp-mparam.h.s390 2009-05-12 08:12:12.000000000 +0200
|
||||
+++ gmp-4.3.1/mpn/s390/gmp-mparam.h 2009-05-28 14:59:54.000000000 +0200
|
||||
@@ -18,7 +18,8 @@ You should have received a copy of the G
|
||||
along with the GNU MP Library. If not, see http://www.gnu.org/licenses/. */
|
||||
|
||||
|
||||
-/* BITS_PER_MP_LIMB etc generated by configure */
|
||||
+#define BITS_PER_MP_LIMB 32
|
||||
+#define BYTES_PER_MP_LIMB 4
|
||||
|
||||
|
||||
/* Generated by tuneup.c, 2001-12-03, gcc 2.95 */
|
||||
diff -up /dev/null gmp-4.3.1/mpn/s390x/gmp-mparam.h
|
||||
--- /dev/null 2009-05-25 10:38:12.683001420 +0200
|
||||
+++ gmp-4.3.1/mpn/s390x/gmp-mparam.h 2009-05-28 14:59:54.000000000 +0200
|
||||
@@ -0,0 +1,27 @@
|
||||
+/* gmp-mparam.h -- Compiler/machine parameter header file.
|
||||
+
|
||||
@ -29,31 +57,3 @@ diff -up /dev/null gmp-4.2.2/mpn/s390x/gmp-mparam.h
|
||||
+#define BITS_PER_INT 32
|
||||
+#define BITS_PER_SHORTINT 16
|
||||
+#define BITS_PER_CHAR 8
|
||||
diff -up gmp-4.2.2/mpn/s390/gmp-mparam.h.s390 gmp-4.2.2/mpn/s390/gmp-mparam.h
|
||||
--- gmp-4.2.2/mpn/s390/gmp-mparam.h.s390 2007-08-30 20:31:41.000000000 +0200
|
||||
+++ gmp-4.2.2/mpn/s390/gmp-mparam.h 2008-09-01 13:04:05.000000000 +0200
|
||||
@@ -18,7 +18,8 @@ You should have received a copy of the G
|
||||
along with the GNU MP Library. If not, see http://www.gnu.org/licenses/. */
|
||||
|
||||
|
||||
-/* BITS_PER_MP_LIMB etc generated by configure */
|
||||
+#define BITS_PER_MP_LIMB 32
|
||||
+#define BYTES_PER_MP_LIMB 4
|
||||
|
||||
|
||||
/* Generated by tuneup.c, 2001-12-03, gcc 2.95 */
|
||||
diff -up gmp-4.2.2/configure.in.s390 gmp-4.2.2/configure.in
|
||||
--- gmp-4.2.2/configure.in.s390 2007-09-09 18:39:14.000000000 +0200
|
||||
+++ gmp-4.2.2/configure.in 2008-09-01 13:04:05.000000000 +0200
|
||||
@@ -1054,6 +1054,11 @@ case $host in
|
||||
;;
|
||||
|
||||
|
||||
+ s390x-*-*)
|
||||
+ gcc_cflags="-g -O2 $fomit_frame_pointer"
|
||||
+ path="s390x"
|
||||
+ #extra_functions="udiv_w_sdiv"
|
||||
+ ;;
|
||||
# IBM s/370 and similar
|
||||
[s3[6-9]0*-*-*])
|
||||
gcc_cflags="-O2 $fomit_frame_pointer"
|
||||
|
@ -1,34 +0,0 @@
|
||||
--- gmp-4.1.2/acinclude.m4.sopwith 2002-09-07 20:02:19.000000000 -0400
|
||||
+++ gmp-4.1.2/acinclude.m4 2003-02-11 10:48:30.000000000 -0500
|
||||
@@ -1003,7 +1003,7 @@
|
||||
${tmp_underscore}underscore_test$gmp_cv_asm_label_suffix
|
||||
EOF
|
||||
case $host in
|
||||
- *-*-aix*)
|
||||
+ *-*-aix*|powerpc64-*)
|
||||
cat >>conftes2.s <<EOF
|
||||
$gmp_cv_asm_globl .${tmp_underscore}underscore_test
|
||||
.${tmp_underscore}underscore_test$gmp_cv_asm_label_suffix
|
||||
--- gmp-4.1.2/configure.in.sopwith 2003-02-11 10:48:30.000000000 -0500
|
||||
+++ gmp-4.1.2/configure.in 2003-02-11 10:51:58.000000000 -0500
|
||||
@@ -669,6 +669,11 @@
|
||||
case $host_cpu in
|
||||
powerpc740 | powerpc750 | powerpc7400)
|
||||
path="powerpc32/750 powerpc32" ;;
|
||||
+ powerpc64)
|
||||
+ gcc_cflags="-g -O2"
|
||||
+ gcc_cflags_asm="-Wa,-mppc64"
|
||||
+ extra_functions=""
|
||||
+ ;;
|
||||
*)
|
||||
path="powerpc32" ;;
|
||||
esac
|
||||
@@ -1943,6 +1948,8 @@
|
||||
GMP_ASM_M68K_ADDRESSING
|
||||
GMP_ASM_M68K_BRANCHES
|
||||
;;
|
||||
+ powerpc64*-*-*)
|
||||
+ ;;
|
||||
powerpc*-*-*)
|
||||
GMP_ASM_POWERPC_R_REGISTERS
|
||||
GMP_INCLUDE_MPN(powerpc32/powerpc-defs.m4)
|
Loading…
Reference in New Issue
Block a user