- update to 5.0.1
This commit is contained in:
parent
86f93e5c12
commit
d8f955c3e3
@ -1 +1 @@
|
||||
gmp-4.3.1.tar.bz2
|
||||
gmp-5.0.1.tar.bz2
|
||||
|
@ -1,59 +0,0 @@
|
||||
diff -up gmp-4.3.1/configure.in.s390 gmp-4.3.1/configure.in
|
||||
--- gmp-4.3.1/configure.in.s390 2009-05-12 08:12:12.000000000 +0200
|
||||
+++ gmp-4.3.1/configure.in 2009-05-28 14:59:54.000000000 +0200
|
||||
@@ -1066,6 +1066,11 @@ case $host in
|
||||
;;
|
||||
|
||||
|
||||
+ s390x-*-*)
|
||||
+ gcc_cflags="-g -O2 $fomit_frame_pointer"
|
||||
+ path="s390x"
|
||||
+ #extra_functions="udiv_w_sdiv"
|
||||
+ ;;
|
||||
# IBM s/370 and similar
|
||||
[s3[6-9]0*-*-*])
|
||||
gcc_cflags="$gcc_cflags $fomit_frame_pointer"
|
||||
diff -up gmp-4.3.1/mpn/s390/gmp-mparam.h.s390 gmp-4.3.1/mpn/s390/gmp-mparam.h
|
||||
--- gmp-4.3.1/mpn/s390/gmp-mparam.h.s390 2009-05-12 08:12:12.000000000 +0200
|
||||
+++ gmp-4.3.1/mpn/s390/gmp-mparam.h 2009-05-28 14:59:54.000000000 +0200
|
||||
@@ -18,7 +18,8 @@ You should have received a copy of the G
|
||||
along with the GNU MP Library. If not, see http://www.gnu.org/licenses/. */
|
||||
|
||||
|
||||
-/* BITS_PER_MP_LIMB etc generated by configure */
|
||||
+#define BITS_PER_MP_LIMB 32
|
||||
+#define BYTES_PER_MP_LIMB 4
|
||||
|
||||
|
||||
/* Generated by tuneup.c, 2001-12-03, gcc 2.95 */
|
||||
diff -up /dev/null gmp-4.3.1/mpn/s390x/gmp-mparam.h
|
||||
--- /dev/null 2009-05-25 10:38:12.683001420 +0200
|
||||
+++ gmp-4.3.1/mpn/s390x/gmp-mparam.h 2009-05-28 14:59:54.000000000 +0200
|
||||
@@ -0,0 +1,27 @@
|
||||
+/* gmp-mparam.h -- Compiler/machine parameter header file.
|
||||
+
|
||||
+Copyright (C) 1991, 1993, 1994, 1995 Free Software Foundation, Inc.
|
||||
+
|
||||
+This file is part of the GNU MP Library.
|
||||
+
|
||||
+The GNU MP Library is free software; you can redistribute it and/or modify
|
||||
+it under the terms of the GNU Library General Public License as published by
|
||||
+the Free Software Foundation; either version 2 of the License, or (at your
|
||||
+option) any later version.
|
||||
+
|
||||
+The GNU MP Library is distributed in the hope that it will be useful, but
|
||||
+WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
|
||||
+or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Library General Public
|
||||
+License for more details.
|
||||
+
|
||||
+You should have received a copy of the GNU Library General Public License
|
||||
+along with the GNU MP Library; see the file COPYING.LIB. If not, write to
|
||||
+the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
|
||||
+MA 02111-1307, USA. */
|
||||
+
|
||||
+#define BITS_PER_MP_LIMB 64
|
||||
+#define BYTES_PER_MP_LIMB 8
|
||||
+#define BITS_PER_LONGINT 64
|
||||
+#define BITS_PER_INT 32
|
||||
+#define BITS_PER_SHORTINT 16
|
||||
+#define BITS_PER_CHAR 8
|
@ -1,21 +0,0 @@
|
||||
--- gmp-4.2.4/configure.in.BAD 2009-04-09 16:57:17.000000000 -0500
|
||||
+++ gmp-4.2.4/configure.in 2009-04-09 16:57:49.000000000 -0500
|
||||
@@ -36,18 +36,6 @@
|
||||
m4_pattern_allow(GMP_NAIL_BITS)
|
||||
m4_pattern_allow(GMP_NUMB_BITS)
|
||||
|
||||
-# If --target is not used then $target_alias is empty, but if say
|
||||
-# "./configure athlon-pc-freebsd3.5" is used, then all three of
|
||||
-# $build_alias, $host_alias and $target_alias are set to
|
||||
-# "athlon-pc-freebsd3.5".
|
||||
-#
|
||||
-if test -n "$target_alias" && test "$target_alias" != "$host_alias"; then
|
||||
- AC_MSG_ERROR([--target is not appropriate for GMP
|
||||
-Use --build=CPU-VENDOR-OS if you need to specify your CPU and/or system
|
||||
-explicitly. Use --host if cross-compiling (see "Installing GMP" in the
|
||||
-manual for more on this).])
|
||||
-fi
|
||||
-
|
||||
GMP_INIT(config.m4)
|
||||
|
||||
AC_CANONICAL_HOST
|
28
gmp-5.0.1-s390.patch
Normal file
28
gmp-5.0.1-s390.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -up gmp-5.0.1/configure.in.pom gmp-5.0.1/configure.in
|
||||
--- gmp-5.0.1/configure.in.pom 2010-02-06 13:43:13.000000000 +0100
|
||||
+++ gmp-5.0.1/configure.in 2010-05-24 13:36:37.000000000 +0200
|
||||
@@ -1095,6 +1095,11 @@ case $host in
|
||||
;;
|
||||
|
||||
|
||||
+ s390x-*-*)
|
||||
+ gcc_cflags="-g -O2 $fomit_frame_pointer"
|
||||
+ path="s390x"
|
||||
+ #extra_functions="udiv_w_sdiv"
|
||||
+ ;;
|
||||
# IBM s/370 and similar
|
||||
[s3[6-9]0*-*-*])
|
||||
gcc_cflags="$gcc_cflags $fomit_frame_pointer"
|
||||
diff -up gmp-5.0.1/mpn/s390/gmp-mparam.h.pom gmp-5.0.1/mpn/s390/gmp-mparam.h
|
||||
--- gmp-5.0.1/mpn/s390/gmp-mparam.h.pom 2010-02-06 13:43:14.000000000 +0100
|
||||
+++ gmp-5.0.1/mpn/s390/gmp-mparam.h 2010-05-24 13:39:21.000000000 +0200
|
||||
@@ -18,7 +18,8 @@ You should have received a copy of the G
|
||||
along with the GNU MP Library. If not, see http://www.gnu.org/licenses/. */
|
||||
|
||||
|
||||
-/* GMP_LIMB_BITS etc generated by configure */
|
||||
+#define BITS_PER_MP_LIMB 32
|
||||
+#define BYTES_PER_MP_LIMB 4
|
||||
|
||||
|
||||
/* Generated by tuneup.c, 2001-12-03, gcc 2.95 */
|
27
gmp.spec
27
gmp.spec
@ -5,13 +5,13 @@
|
||||
|
||||
Summary: A GNU arbitrary precision library
|
||||
Name: gmp
|
||||
Version: 4.3.1
|
||||
Release: 7%{?dist}
|
||||
Version: 5.0.1
|
||||
Release: 1%{?dist}
|
||||
URL: http://gmplib.org/
|
||||
Source0: ftp://ftp.gnu.org/pub/gnu/gmp/gmp-%{version}.tar.bz2
|
||||
Source2: gmp.h
|
||||
Source3: gmp-mparam.h
|
||||
Patch0: gmp-4.0.1-s390.patch
|
||||
Patch0: gmp-5.0.1-s390.patch
|
||||
# mpn/s390x/gmp-mparam.h: LGPLv2+
|
||||
# demos/calc/calc.c: GPLv3+
|
||||
License: LGPLv2+ and GPLv3+ and LGPLv3+
|
||||
@ -131,15 +131,15 @@ cd ..
|
||||
cd build-sse2
|
||||
export LD_LIBRARY_PATH=`pwd`/.libs
|
||||
mkdir $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
install -m 755 .libs/libgmp.so.3.* $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
cp -a .libs/libgmp.so.3 $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
chmod 755 $RPM_BUILD_ROOT%{_libdir}/sse2/libgmp.so.3
|
||||
install -m 755 .libs/libgmpxx.so.4.* $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
cp -a .libs/libgmpxx.so.4 $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
chmod 755 $RPM_BUILD_ROOT%{_libdir}/sse2/libgmpxx.so.4
|
||||
install -m 755 .libs/libmp.so.3.* $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
cp -a .libs/libmp.so.3 $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
chmod 755 $RPM_BUILD_ROOT%{_libdir}/sse2/libmp.so.3
|
||||
install -m 755 .libs/libgmp.so.*.* $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
cp -a .libs/libgmp.so.[^.]* $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
chmod 755 $RPM_BUILD_ROOT%{_libdir}/sse2/libgmp.so.[^.]*
|
||||
install -m 755 .libs/libgmpxx.so.*.* $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
cp -a .libs/libgmpxx.so.? $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
chmod 755 $RPM_BUILD_ROOT%{_libdir}/sse2/libgmpxx.so.?
|
||||
install -m 755 .libs/libmp.so.*.* $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
cp -a .libs/libmp.so.? $RPM_BUILD_ROOT%{_libdir}/sse2
|
||||
chmod 755 $RPM_BUILD_ROOT%{_libdir}/sse2/libmp.so.?
|
||||
cd ..
|
||||
%endif
|
||||
|
||||
@ -228,6 +228,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon May 24 2010 Ivana Hutarova Varekova <varekova@redhat.com> 5.0.1-1
|
||||
- update to 5.0.1
|
||||
|
||||
* Tue Mar 2 2010 Ivana Hutarova Varekova <varekova@redhat.com> 4.3.1-7
|
||||
- fix the license tag
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user