parent
17299e61c3
commit
4e6360d009
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/gmp-5.0.2.tar.bz2
|
/gmp-5.0.4.tar.bz2
|
||||||
|
@ -1,59 +0,0 @@
|
|||||||
diff -up gmp-4.3.1/configure.in.s390 gmp-4.3.1/configure.in
|
|
||||||
--- gmp-4.3.1/configure.in.s390 2009-05-12 08:12:12.000000000 +0200
|
|
||||||
+++ gmp-4.3.1/configure.in 2009-05-28 14:59:54.000000000 +0200
|
|
||||||
@@ -1066,6 +1066,11 @@ case $host in
|
|
||||||
;;
|
|
||||||
|
|
||||||
|
|
||||||
+ s390x-*-*)
|
|
||||||
+ gcc_cflags="-g -O2 $fomit_frame_pointer"
|
|
||||||
+ path="s390x"
|
|
||||||
+ #extra_functions="udiv_w_sdiv"
|
|
||||||
+ ;;
|
|
||||||
# IBM s/370 and similar
|
|
||||||
[s3[6-9]0*-*-*])
|
|
||||||
gcc_cflags="$gcc_cflags $fomit_frame_pointer"
|
|
||||||
diff -up gmp-4.3.1/mpn/s390/gmp-mparam.h.s390 gmp-4.3.1/mpn/s390/gmp-mparam.h
|
|
||||||
--- gmp-4.3.1/mpn/s390/gmp-mparam.h.s390 2009-05-12 08:12:12.000000000 +0200
|
|
||||||
+++ gmp-4.3.1/mpn/s390/gmp-mparam.h 2009-05-28 14:59:54.000000000 +0200
|
|
||||||
@@ -18,7 +18,8 @@ You should have received a copy of the G
|
|
||||||
along with the GNU MP Library. If not, see http://www.gnu.org/licenses/. */
|
|
||||||
|
|
||||||
|
|
||||||
-/* BITS_PER_MP_LIMB etc generated by configure */
|
|
||||||
+#define BITS_PER_MP_LIMB 32
|
|
||||||
+#define BYTES_PER_MP_LIMB 4
|
|
||||||
|
|
||||||
|
|
||||||
/* Generated by tuneup.c, 2001-12-03, gcc 2.95 */
|
|
||||||
diff -up /dev/null gmp-4.3.1/mpn/s390x/gmp-mparam.h
|
|
||||||
--- /dev/null 2009-05-25 10:38:12.683001420 +0200
|
|
||||||
+++ gmp-4.3.1/mpn/s390x/gmp-mparam.h 2009-05-28 14:59:54.000000000 +0200
|
|
||||||
@@ -0,0 +1,27 @@
|
|
||||||
+/* gmp-mparam.h -- Compiler/machine parameter header file.
|
|
||||||
+
|
|
||||||
+Copyright (C) 1991, 1993, 1994, 1995 Free Software Foundation, Inc.
|
|
||||||
+
|
|
||||||
+This file is part of the GNU MP Library.
|
|
||||||
+
|
|
||||||
+The GNU MP Library is free software; you can redistribute it and/or modify
|
|
||||||
+it under the terms of the GNU Library General Public License as published by
|
|
||||||
+the Free Software Foundation; either version 2 of the License, or (at your
|
|
||||||
+option) any later version.
|
|
||||||
+
|
|
||||||
+The GNU MP Library is distributed in the hope that it will be useful, but
|
|
||||||
+WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
|
|
||||||
+or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Library General Public
|
|
||||||
+License for more details.
|
|
||||||
+
|
|
||||||
+You should have received a copy of the GNU Library General Public License
|
|
||||||
+along with the GNU MP Library; see the file COPYING.LIB. If not, write to
|
|
||||||
+the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
|
|
||||||
+MA 02111-1307, USA. */
|
|
||||||
+
|
|
||||||
+#define BITS_PER_MP_LIMB 64
|
|
||||||
+#define BYTES_PER_MP_LIMB 8
|
|
||||||
+#define BITS_PER_LONGINT 64
|
|
||||||
+#define BITS_PER_INT 32
|
|
||||||
+#define BITS_PER_SHORTINT 16
|
|
||||||
+#define BITS_PER_CHAR 8
|
|
@ -1,7 +1,7 @@
|
|||||||
diff -up gmp-5.0.2/configure.in.tmp gmp-5.0.2/configure.in
|
diff -up gmp-5.0.4/configure.in.s390 gmp-5.0.4/configure.in
|
||||||
--- gmp-5.0.2/configure.in.tmp 2011-05-08 11:49:29.000000000 +0200
|
--- gmp-5.0.4/configure.in.s390 2012-02-10 11:23:05.000000000 +0100
|
||||||
+++ gmp-5.0.2/configure.in 2011-08-15 14:34:22.543596916 +0200
|
+++ gmp-5.0.4/configure.in 2012-04-18 12:49:59.681014202 +0200
|
||||||
@@ -1109,6 +1109,10 @@ case $host in
|
@@ -1097,6 +1097,10 @@ case $host in
|
||||||
path="pyr"
|
path="pyr"
|
||||||
;;
|
;;
|
||||||
|
|
||||||
@ -10,24 +10,11 @@ diff -up gmp-5.0.2/configure.in.tmp gmp-5.0.2/configure.in
|
|||||||
+ path="s390x"
|
+ path="s390x"
|
||||||
+ ;;
|
+ ;;
|
||||||
|
|
||||||
# IBM s/370 and similar
|
# IBM System/390 and z/Architecture
|
||||||
[s3[6-9]0*-*-*])
|
S390_PATTERN | S390X_PATTERN)
|
||||||
diff -up gmp-5.0.2/mpn/s390/gmp-mparam.h.tmp gmp-5.0.2/mpn/s390/gmp-mparam.h
|
diff -up gmp-5.0.4/mpn/s390x/gmp-mparam.h.s390 gmp-5.0.4/mpn/s390x/gmp-mparam.h
|
||||||
--- gmp-5.0.2/mpn/s390/gmp-mparam.h.tmp 2011-08-15 14:37:48.000000000 +0200
|
--- gmp-5.0.4/mpn/s390x/gmp-mparam.h.s390 2012-04-18 12:44:04.482509106 +0200
|
||||||
+++ gmp-5.0.2/mpn/s390/gmp-mparam.h 2011-08-15 14:38:22.884229091 +0200
|
+++ gmp-5.0.4/mpn/s390x/gmp-mparam.h 2012-04-18 12:44:04.482509106 +0200
|
||||||
@@ -18,7 +18,8 @@ You should have received a copy of the G
|
|
||||||
along with the GNU MP Library. If not, see http://www.gnu.org/licenses/. */
|
|
||||||
|
|
||||||
|
|
||||||
-/* GMP_LIMB_BITS etc generated by configure */
|
|
||||||
+#define BITS_PER_MP_LIMB 32
|
|
||||||
+#define BYTES_PER_MP_LIMB 4
|
|
||||||
|
|
||||||
|
|
||||||
/* Generated by tuneup.c, 2001-12-03, gcc 2.95 */
|
|
||||||
diff -up /dev/null gmp-4.3.1/mpn/s390x/gmp-mparam.h
|
|
||||||
--- /dev/null 2009-05-25 10:38:12.683001420 +0200
|
|
||||||
+++ gmp-4.3.1/mpn/s390x/gmp-mparam.h 2009-05-28 14:59:54.000000000 +0200
|
|
||||||
@@ -0,0 +1,26 @@
|
@@ -0,0 +1,26 @@
|
||||||
+/* gmp-mparam.h -- Compiler/machine parameter header file.
|
+/* gmp-mparam.h -- Compiler/machine parameter header file.
|
||||||
+
|
+
|
||||||
|
8
gmp.spec
8
gmp.spec
@ -5,8 +5,8 @@
|
|||||||
|
|
||||||
Summary: A GNU arbitrary precision library
|
Summary: A GNU arbitrary precision library
|
||||||
Name: gmp
|
Name: gmp
|
||||||
Version: 5.0.2
|
Version: 5.0.4
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
URL: http://gmplib.org/
|
URL: http://gmplib.org/
|
||||||
Source0: ftp://ftp.gnu.org/pub/gnu/gmp/gmp-%{version}.tar.bz2
|
Source0: ftp://ftp.gnu.org/pub/gnu/gmp/gmp-%{version}.tar.bz2
|
||||||
@ -236,6 +236,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 19 2012 Peter Schiffer <pschiffe@redhat.com> 1:5.0.4-1
|
||||||
|
- resolves: #785116
|
||||||
|
update to 5.0.4
|
||||||
|
|
||||||
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:5.0.2-6
|
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:5.0.2-6
|
||||||
- Rebuilt for c++ ABI breakage
|
- Rebuilt for c++ ABI breakage
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user