plus selected fixes to glusterfs.spec from 3.4.0, inclusing fix for broken hardening (PIE), corrected filtering of shlib provides, abbreviated ChangeLog and more
25 lines
909 B
Diff
25 lines
909 B
Diff
--- libglusterfs/src/Makefile.am.orig 2013-07-12 13:50:20.000000000 -0400
|
|
+++ libglusterfs/src/Makefile.am 2013-07-12 20:10:12.156000000 -0400
|
|
@@ -48,7 +48,8 @@
|
|
$(LEX) -t $(srcdir)/graph.l > $@
|
|
|
|
y.tab.h: graph.y
|
|
- $(YACC) -d $(srcdir)/graph.y
|
|
+ $(YACC) -d -b foo $(srcdir)/graph.y
|
|
+ mv foo.tab.h y.tab.h && mv foo.tab.c y.tab.c
|
|
|
|
CLEANFILES = graph.lex.c y.tab.c y.tab.h
|
|
CONFIG_CLEAN_FILES = $(CONTRIB_BUILDDIR)/uuid/uuid_types.h
|
|
--- libglusterfs/src/Makefile.in.orig 2013-07-12 20:10:12.157000000 -0400
|
|
+++ libglusterfs/src/Makefile.in 2013-07-12 20:12:43.022000000 -0400
|
|
@@ -1101,7 +1101,8 @@
|
|
$(LEX) -t $(srcdir)/graph.l > $@
|
|
|
|
y.tab.h: graph.y
|
|
- $(YACC) -d $(srcdir)/graph.y
|
|
+ $(YACC) -d -b foo $(srcdir)/graph.y
|
|
+ mv foo.tab.h y.tab.h && mv foo.tab.c y.tab.c
|
|
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|