glusterfs/glusterfs-3.2.5.libglusterfs.Makefile.patch
2012-02-16 11:24:06 -05:00

24 lines
873 B
Diff

--- libglusterfs/src/Makefile.am.orig 2011-11-23 14:04:41.810001717 -0500
+++ libglusterfs/src/Makefile.am 2011-11-23 14:30:49.940000394 -0500
@@ -16,6 +16,7 @@
$(LEX) -t $(srcdir)/graph.l > $@
y.tab.c y.tab.h: graph.y
- $(YACC) -d $(srcdir)/graph.y
+ $(YACC) -d -b foo $(srcdir)/graph.y
+ mv foo.tab.h y.tab.h && mv foo.tab.c y.tab.c
CLEANFILES = graph.lex.c y.tab.c y.tab.h
--- libglusterfs/src/Makefile.in.orig 2011-11-23 14:04:35.995001451 -0500
+++ libglusterfs/src/Makefile.in 2011-11-23 14:31:01.730999353 -0500
@@ -866,7 +866,8 @@
$(LEX) -t $(srcdir)/graph.l > $@
y.tab.c y.tab.h: graph.y
- $(YACC) -d $(srcdir)/graph.y
+ $(YACC) -d -b foo $(srcdir)/graph.y
+ mv foo.tab.h y.tab.h && mv foo.tab.c y.tab.c
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: