glusterfs/glusterfs-3.3.0.libglusterfs.Makefile.patch
2012-05-31 15:04:23 -04:00

25 lines
917 B
Diff

--- libglusterfs/src/Makefile.am.orig 2012-05-17 12:30:57.000000000 -0400
+++ libglusterfs/src/Makefile.am 2012-05-18 08:52:55.469998306 -0400
@@ -44,7 +44,8 @@
$(LEX) -t $(srcdir)/graph.l > $@
y.tab.h: graph.y
- $(YACC) -d $(srcdir)/graph.y
+ $(YACC) -d -b foo $(srcdir)/graph.y
+ mv foo.tab.h y.tab.h && mv foo.tab.c y.tab.c
CLEANFILES = graph.lex.c y.tab.c y.tab.h
CONFIG_CLEAN_FILES = $(CONTRIB_BUILDDIR)/uuid/uuid_types.h
--- libglusterfs/src/Makefile.in.orig 2012-05-17 12:31:12.000000000 -0400
+++ libglusterfs/src/Makefile.in 2012-05-18 09:02:31.108002281 -0400
@@ -941,7 +941,8 @@
$(LEX) -t $(srcdir)/graph.l > $@
y.tab.h: graph.y
- $(YACC) -d $(srcdir)/graph.y
+ $(YACC) -d -b foo $(srcdir)/graph.y
+ mv foo.tab.h y.tab.h && mv foo.tab.c y.tab.c
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: