update for glusterfs-3.3.0
This commit is contained in:
parent
78c6c34b69
commit
744ad50f31
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@ glusterfs-3.2.3.tar.gz
|
||||
glusterfs-3.2.4.tar.gz
|
||||
glusterfs-3.2.5.tar.gz
|
||||
/glusterfs-3.2.6.tar.gz
|
||||
/glusterfs-3.3.0.tar.gz
|
||||
|
24
glusterfs-3.3.0.libglusterfs.Makefile.patch
Normal file
24
glusterfs-3.3.0.libglusterfs.Makefile.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- libglusterfs/src/Makefile.am.orig 2012-05-17 12:30:57.000000000 -0400
|
||||
+++ libglusterfs/src/Makefile.am 2012-05-18 08:52:55.469998306 -0400
|
||||
@@ -44,7 +44,8 @@
|
||||
$(LEX) -t $(srcdir)/graph.l > $@
|
||||
|
||||
y.tab.h: graph.y
|
||||
- $(YACC) -d $(srcdir)/graph.y
|
||||
+ $(YACC) -d -b foo $(srcdir)/graph.y
|
||||
+ mv foo.tab.h y.tab.h && mv foo.tab.c y.tab.c
|
||||
|
||||
CLEANFILES = graph.lex.c y.tab.c y.tab.h
|
||||
CONFIG_CLEAN_FILES = $(CONTRIB_BUILDDIR)/uuid/uuid_types.h
|
||||
--- libglusterfs/src/Makefile.in.orig 2012-05-17 12:31:12.000000000 -0400
|
||||
+++ libglusterfs/src/Makefile.in 2012-05-18 09:02:31.108002281 -0400
|
||||
@@ -941,7 +941,8 @@
|
||||
$(LEX) -t $(srcdir)/graph.l > $@
|
||||
|
||||
y.tab.h: graph.y
|
||||
- $(YACC) -d $(srcdir)/graph.y
|
||||
+ $(YACC) -d -b foo $(srcdir)/graph.y
|
||||
+ mv foo.tab.h y.tab.h && mv foo.tab.c y.tab.c
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
.NOEXPORT:
|
@ -24,20 +24,20 @@
|
||||
|
||||
Summary: Cluster File System
|
||||
Name: glusterfs
|
||||
Version: 3.2.6
|
||||
Release: 2%{?dist}
|
||||
License: GPLv3
|
||||
Version: 3.3.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+ and (GPLv2 or LGPLv3+)
|
||||
Group: System Environment/Base
|
||||
Vendor: Red Hat
|
||||
URL: http://www.gluster.org//docs/index.php/GlusterFS
|
||||
Source0: http://download.gluster.com/pub/gluster/glusterfs/3.2/%{version}/glusterfs-%{version}.tar.gz
|
||||
Source0: http://download.gluster.org/pub/gluster/glusterfs/3.3/%{version}/glusterfs-%{version}.tar.gz
|
||||
Source1: glusterd.sysconfig
|
||||
Source2: glusterfsd.sysconfig
|
||||
Source3: umount.glusterfs
|
||||
Source4: glusterfs-fuse.logrotate
|
||||
Source5: glusterd.logrotate
|
||||
Source6: glusterfsd.logrotate
|
||||
Patch0: %{name}-3.2.5.libglusterfs.Makefile.patch
|
||||
Patch0: %{name}-3.3.0.libglusterfs.Makefile.patch
|
||||
Patch1: %{name}-3.2.5.configure.ac.patch
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
@ -74,9 +74,10 @@ Requires(postun): systemd-units
|
||||
BuildRequires: bison flex
|
||||
BuildRequires: gcc make automake libtool
|
||||
BuildRequires: ncurses-devel readline-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libxml2-devel openssl-devel
|
||||
BuildRequires: python-ctypes
|
||||
|
||||
Obsoletes: hekafs <= 0.7
|
||||
Obsoletes: %{name}-libs <= 2.0.0
|
||||
Obsoletes: %{name}-common < 3.1.0
|
||||
Provides: %{name}-libs = %{version}-%{release}
|
||||
@ -252,11 +253,6 @@ find %{buildroot}%{_libdir} -name '*.la' -delete
|
||||
# Remove installed docs, we include them ourselves as %%doc
|
||||
%{__rm} -rf %{buildroot}%{_datadir}/doc/glusterfs/
|
||||
|
||||
# Rename the samples, so we can include them as %%config
|
||||
for file in %{buildroot}%{_sysconfdir}/glusterfs/*.sample; do
|
||||
%{__mv} ${file} `dirname ${file}`/`basename ${file} .sample`
|
||||
done
|
||||
|
||||
# Create working directory
|
||||
%{__mkdir_p} %{buildroot}%{_sharedstatedir}/glusterd
|
||||
|
||||
@ -264,10 +260,6 @@ done
|
||||
sed -i 's|option working-directory /etc/glusterd|option working-directory %{_sharedstatedir}/glusterd|g' \
|
||||
%{buildroot}%{_sysconfdir}/glusterfs/glusterd.vol
|
||||
|
||||
# Clean up the examples we want to include as %%doc
|
||||
%{__cp} -a doc/examples examples
|
||||
%{__rm} -f examples/Makefile*
|
||||
|
||||
# Install init script and sysconfig file
|
||||
%_init_install %{SOURCE7} glusterd
|
||||
%_init_install %{SOURCE8} glusterfsd
|
||||
@ -305,14 +297,12 @@ sed -i 's|option working-directory /etc/glusterd|option working-directory %{_sha
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc ChangeLog COPYING INSTALL README THANKS
|
||||
%doc ChangeLog COPYING-GPLV2 COPYING-LGPLV3 INSTALL README THANKS
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/glusterd
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/glusterd
|
||||
%{_libdir}/glusterfs
|
||||
%{_libdir}/*.so.*
|
||||
%{_sbindir}/glusterfs*
|
||||
%{_sbindir}/gluster
|
||||
%{_sbindir}/glusterd
|
||||
%{_libexecdir}/glusterfs
|
||||
%{_mandir}/man8/*gluster*.8*
|
||||
%dir %{_localstatedir}/log/glusterfs
|
||||
@ -320,6 +310,12 @@ sed -i 's|option working-directory /etc/glusterd|option working-directory %{_sha
|
||||
%exclude %{_libdir}/glusterfs/%{version}/rpc-transport/rdma*
|
||||
%endif
|
||||
%exclude %{_libdir}/glusterfs/%{version}/xlator/mount/fuse*
|
||||
%exclude %{_libdir}/glusterfs/%{version}/xlator/storage*
|
||||
%exclude %{_libdir}/glusterfs/%{version}/xlator/features/posix*
|
||||
%exclude %{_libdir}/glusterfs/%{version}/xlator/protocol/server*
|
||||
%exclude %{_libdir}/glusterfs/%{version}/xlator/mgmt*
|
||||
%exclude %{_libdir}/glusterfs/%{version}/xlator/nfs*
|
||||
|
||||
|
||||
%if 0%{!?_without_rdma:1}
|
||||
%files rdma
|
||||
@ -354,7 +350,6 @@ sed -i 's|option working-directory /etc/glusterd|option working-directory %{_sha
|
||||
|
||||
%files server
|
||||
%defattr(-,root,root,-)
|
||||
%doc examples/ doc/glusterfs*.vol.sample
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/glusterd
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/glusterd
|
||||
%config(noreplace) %{_sysconfdir}/glusterfs
|
||||
@ -364,10 +359,18 @@ sed -i 's|option working-directory /etc/glusterd|option working-directory %{_sha
|
||||
%{_sharedstatedir}/glusterd
|
||||
%_init_file1
|
||||
%_init_file2
|
||||
%{_sbindir}/gluster
|
||||
%{_sbindir}/glusterd
|
||||
%{_libdir}/glusterfs/%{version}/xlator/storage*
|
||||
%{_libdir}/glusterfs/%{version}/xlator/features/posix*
|
||||
%{_libdir}/glusterfs/%{version}/xlator/protocol/server*
|
||||
%{_libdir}/glusterfs/%{version}/xlator/mgmt*
|
||||
%{_libdir}/glusterfs/%{version}/xlator/nfs*
|
||||
|
||||
|
||||
%files vim
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%doc COPYING-GPLV2 COPYING-LGPLV3
|
||||
%{_datadir}/vim/vimfiles/syntax/glusterfs.vim
|
||||
|
||||
%files devel
|
||||
@ -394,6 +397,9 @@ if [ $1 -ge 1 ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Thu May 31 2012 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 3.3.0-1
|
||||
- Update to 3.3.0
|
||||
|
||||
* Wed May 9 2012 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 3.2.6-2
|
||||
- Add BuildRequires: libxml2-devel, BZ 819916
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user