glusterfs package is retired on branch c10s for BAKERY-412
This commit is contained in:
parent
49171be524
commit
6ecfe713c3
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +0,0 @@
|
||||
gluster*.tar.gz
|
||||
*.src.rpm
|
@ -1,11 +0,0 @@
|
||||
--- glusterfs-11.0/configure.ac.orig 2023-02-07 08:27:06.663310072 -0500
|
||||
+++ glusterfs-11.0/configure.ac 2023-02-07 08:27:56.012452316 -0500
|
||||
@@ -1319,7 +1319,7 @@
|
||||
fi
|
||||
|
||||
GF_HOST_OS=""
|
||||
-GF_LDFLAGS="${GF_LDFLAGS} -rdynamic"
|
||||
+GF_LDFLAGS="${GF_LDFLAGS} -rdynamic -fuse-ld=mold"
|
||||
|
||||
dnl see --with-libtirpc option check above, libtirpc(-devel) is required for
|
||||
dnl ipv6-default
|
@ -1,212 +0,0 @@
|
||||
--- glusterfs-11.0/contrib/aclocal/python.m4.orig 2023-06-16 11:18:03.550994174 -0400
|
||||
+++ glusterfs-11.0/contrib/aclocal/python.m4 2023-06-16 11:18:47.875238947 -0400
|
||||
@@ -1,209 +1 @@
|
||||
-## ------------------------ -*- Autoconf -*-
|
||||
-## Python file handling
|
||||
-## From Andrew Dalke
|
||||
-## Updated by James Henstridge
|
||||
## ------------------------
|
||||
-# Copyright (C) 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2008, 2009
|
||||
-# Free Software Foundation, Inc.
|
||||
-#
|
||||
-# This file is free software; the Free Software Foundation
|
||||
-# gives unlimited permission to copy and/or distribute it,
|
||||
-# with or without modifications, as long as this notice is preserved.
|
||||
-
|
||||
-# AM_PATH_PYTHON([MINIMUM-VERSION], [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
|
||||
-# ---------------------------------------------------------------------------
|
||||
-# Adds support for distributing Python modules and packages. To
|
||||
-# install modules, copy them to $(pythondir), using the python_PYTHON
|
||||
-# automake variable. To install a package with the same name as the
|
||||
-# automake package, install to $(pkgpythondir), or use the
|
||||
-# pkgpython_PYTHON automake variable.
|
||||
-#
|
||||
-# The variables $(pyexecdir) and $(pkgpyexecdir) are provided as
|
||||
-# locations to install python extension modules (shared libraries).
|
||||
-# Another macro is required to find the appropriate flags to compile
|
||||
-# extension modules.
|
||||
-#
|
||||
-# If your package is configured with a different prefix to python,
|
||||
-# users will have to add the install directory to the PYTHONPATH
|
||||
-# environment variable, or create a .pth file (see the python
|
||||
-# documentation for details).
|
||||
-#
|
||||
-# If the MINIMUM-VERSION argument is passed, AM_PATH_PYTHON will
|
||||
-# cause an error if the version of python installed on the system
|
||||
-# doesn't meet the requirement. MINIMUM-VERSION should consist of
|
||||
-# numbers and dots only.
|
||||
-AC_DEFUN([AM_PATH_PYTHON],
|
||||
- [
|
||||
- dnl Find a Python interpreter. Python versions prior to 2.0 are not
|
||||
- dnl supported. (2.0 was released on October 16, 2000).
|
||||
- m4_define_default([_AM_PYTHON_INTERPRETER_LIST],
|
||||
- [python python2 python3 python3.2 python3.1 python3.0 python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 dnl
|
||||
-python2.1 python2.0])
|
||||
-
|
||||
- m4_if([$1],[],[
|
||||
- dnl No version check is needed.
|
||||
- # Find any Python interpreter.
|
||||
- if test -z "$PYTHON"; then
|
||||
- AC_PATH_PROGS([PYTHON], _AM_PYTHON_INTERPRETER_LIST, :)
|
||||
- fi
|
||||
- am_display_PYTHON=python
|
||||
- ], [
|
||||
- dnl A version check is needed.
|
||||
- if test -n "$PYTHON"; then
|
||||
- # If the user set $PYTHON, use it and don't search something else.
|
||||
- AC_MSG_CHECKING([whether $PYTHON version >= $1])
|
||||
- AM_PYTHON_CHECK_VERSION([$PYTHON], [$1],
|
||||
- [AC_MSG_RESULT(yes)],
|
||||
- [AC_MSG_ERROR(too old)])
|
||||
- am_display_PYTHON=$PYTHON
|
||||
- else
|
||||
- # Otherwise, try each interpreter until we find one that satisfies
|
||||
- # VERSION.
|
||||
- AC_CACHE_CHECK([for a Python interpreter with version >= $1],
|
||||
- [am_cv_pathless_PYTHON],[
|
||||
- for am_cv_pathless_PYTHON in _AM_PYTHON_INTERPRETER_LIST none; do
|
||||
- test "$am_cv_pathless_PYTHON" = none && break
|
||||
- AM_PYTHON_CHECK_VERSION([$am_cv_pathless_PYTHON], [$1], [break])
|
||||
- done])
|
||||
- # Set $PYTHON to the absolute path of $am_cv_pathless_PYTHON.
|
||||
- if test "$am_cv_pathless_PYTHON" = none; then
|
||||
- PYTHON=:
|
||||
- else
|
||||
- AC_PATH_PROG([PYTHON], [$am_cv_pathless_PYTHON])
|
||||
- fi
|
||||
- am_display_PYTHON=$am_cv_pathless_PYTHON
|
||||
- fi
|
||||
- ])
|
||||
-
|
||||
- if test "$PYTHON" = :; then
|
||||
- dnl Run any user-specified action, or abort.
|
||||
- m4_default([$3], [AC_MSG_ERROR([no suitable Python interpreter found])])
|
||||
- else
|
||||
-
|
||||
- dnl Query Python for its version number. Getting [:3] seems to be
|
||||
- dnl the best way to do this; it's what "site.py" does in the standard
|
||||
- dnl library.
|
||||
-
|
||||
- AC_CACHE_CHECK([for $am_display_PYTHON version], [am_cv_python_version],
|
||||
- [am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[[:3]])"`])
|
||||
- AC_SUBST([PYTHON_VERSION], [$am_cv_python_version])
|
||||
-
|
||||
- dnl Use the values of $prefix and $exec_prefix for the corresponding
|
||||
- dnl values of PYTHON_PREFIX and PYTHON_EXEC_PREFIX. These are made
|
||||
- dnl distinct variables so they can be overridden if need be. However,
|
||||
- dnl general consensus is that you shouldn't need this ability.
|
||||
-
|
||||
- AC_SUBST([PYTHON_PREFIX], ['${prefix}'])
|
||||
- AC_SUBST([PYTHON_EXEC_PREFIX], ['${exec_prefix}'])
|
||||
-
|
||||
- dnl At times (like when building shared libraries) you may want
|
||||
- dnl to know which OS platform Python thinks this is.
|
||||
-
|
||||
- AC_CACHE_CHECK([for $am_display_PYTHON platform], [am_cv_python_platform],
|
||||
- [am_cv_python_platform=`$PYTHON -c "import sys; sys.stdout.write(sys.platform)"`])
|
||||
- AC_SUBST([PYTHON_PLATFORM], [$am_cv_python_platform])
|
||||
-
|
||||
-
|
||||
- dnl Set up 4 directories:
|
||||
-
|
||||
- dnl pythondir -- where to install python scripts. This is the
|
||||
- dnl site-packages directory, not the python standard library
|
||||
- dnl directory like in previous automake betas. This behavior
|
||||
- dnl is more consistent with lispdir.m4 for example.
|
||||
- dnl Query distutils for this directory. distutils does not exist in
|
||||
- dnl Python 1.5, so we fall back to the hardcoded directory if it
|
||||
- dnl doesn't work.
|
||||
- AC_CACHE_CHECK([for $am_display_PYTHON script directory],
|
||||
- [am_cv_python_pythondir],
|
||||
- [if test "x$prefix" = xNONE
|
||||
- then
|
||||
- am_py_prefix=$ac_default_prefix
|
||||
- else
|
||||
- am_py_prefix=$prefix
|
||||
- fi
|
||||
- am_cv_python_pythondir=`$PYTHON -c "import sys; from distutils import sysconfig; sys.stdout.write(sysconfig.get_python_lib(0,0,prefix='$am_py_prefix'))" 2>/dev/null ||
|
||||
- echo "$PYTHON_PREFIX/lib/python$PYTHON_VERSION/site-packages"`
|
||||
- case $am_cv_python_pythondir in
|
||||
- $am_py_prefix*)
|
||||
- am__strip_prefix=`echo "$am_py_prefix" | sed 's|.|.|g'`
|
||||
- am_cv_python_pythondir=`echo "$am_cv_python_pythondir" | sed "s,^$am__strip_prefix,$PYTHON_PREFIX,"`
|
||||
- ;;
|
||||
- *)
|
||||
- case $am_py_prefix in
|
||||
- /usr|/System*) ;;
|
||||
- *)
|
||||
- am_cv_python_pythondir=$PYTHON_PREFIX/lib/python$PYTHON_VERSION/site-packages
|
||||
- ;;
|
||||
- esac
|
||||
- ;;
|
||||
- esac
|
||||
- ])
|
||||
- AC_SUBST([pythondir], [$am_cv_python_pythondir])
|
||||
-
|
||||
- dnl pkgpythondir -- $PACKAGE directory under pythondir. Was
|
||||
- dnl PYTHON_SITE_PACKAGE in previous betas, but this naming is
|
||||
- dnl more consistent with the rest of automake.
|
||||
-
|
||||
- AC_SUBST([pkgpythondir], [\${pythondir}/$PACKAGE])
|
||||
-
|
||||
- dnl pyexecdir -- directory for installing python extension modules
|
||||
- dnl (shared libraries)
|
||||
- dnl Query distutils for this directory. distutils does not exist in
|
||||
- dnl Python 1.5, so we fall back to the hardcoded directory if it
|
||||
- dnl doesn't work.
|
||||
- AC_CACHE_CHECK([for $am_display_PYTHON extension module directory],
|
||||
- [am_cv_python_pyexecdir],
|
||||
- [if test "x$exec_prefix" = xNONE
|
||||
- then
|
||||
- am_py_exec_prefix=$am_py_prefix
|
||||
- else
|
||||
- am_py_exec_prefix=$exec_prefix
|
||||
- fi
|
||||
- am_cv_python_pyexecdir=`$PYTHON -c "import sys; from distutils import sysconfig; sys.stdout.write(sysconfig.get_python_lib(1,0,prefix='$am_py_exec_prefix'))" 2>/dev/null ||
|
||||
- echo "$PYTHON_EXEC_PREFIX/lib/python$PYTHON_VERSION/site-packages"`
|
||||
- case $am_cv_python_pyexecdir in
|
||||
- $am_py_exec_prefix*)
|
||||
- am__strip_prefix=`echo "$am_py_exec_prefix" | sed 's|.|.|g'`
|
||||
- am_cv_python_pyexecdir=`echo "$am_cv_python_pyexecdir" | sed "s,^$am__strip_prefix,$PYTHON_EXEC_PREFIX,"`
|
||||
- ;;
|
||||
- *)
|
||||
- case $am_py_exec_prefix in
|
||||
- /usr|/System*) ;;
|
||||
- *)
|
||||
- am_cv_python_pyexecdir=$PYTHON_EXEC_PREFIX/lib/python$PYTHON_VERSION/site-packages
|
||||
- ;;
|
||||
- esac
|
||||
- ;;
|
||||
- esac
|
||||
- ])
|
||||
- AC_SUBST([pyexecdir], [$am_cv_python_pyexecdir])
|
||||
-
|
||||
- dnl pkgpyexecdir -- $(pyexecdir)/$(PACKAGE)
|
||||
-
|
||||
- AC_SUBST([pkgpyexecdir], [\${pyexecdir}/$PACKAGE])
|
||||
-
|
||||
- dnl Run any user-specified action.
|
||||
- $2
|
||||
- fi
|
||||
-
|
||||
-])
|
||||
-
|
||||
-
|
||||
-# AM_PYTHON_CHECK_VERSION(PROG, VERSION, [ACTION-IF-TRUE], [ACTION-IF-FALSE])
|
||||
-# ---------------------------------------------------------------------------
|
||||
-# Run ACTION-IF-TRUE if the Python interpreter PROG has version >= VERSION.
|
||||
-# Run ACTION-IF-FALSE otherwise.
|
||||
-# This test uses sys.hexversion instead of the string equivalent (first
|
||||
-# word of sys.version), in order to cope with versions such as 2.2c1.
|
||||
-# This supports Python 2.0 or higher. (2.0 was released on October 16, 2000).
|
||||
-AC_DEFUN([AM_PYTHON_CHECK_VERSION],
|
||||
- [prog="import sys
|
||||
-# split strings by '.' and convert to numeric. Append some zeros
|
||||
-# because we need at least 4 digits for the hex conversion.
|
||||
-# map returns an iterator in Python 3.0 and a list in 2.x
|
||||
-minver = list(map(int, '$2'.split('.'))) + [[0, 0, 0]]
|
||||
-minverhex = 0
|
||||
-# xrange is not present in Python 3.0 and range returns an iterator
|
||||
-for i in list(range(0, 4)): minverhex = (minverhex << 8) + minver[[i]]
|
||||
-sys.exit(sys.hexversion < minverhex)"
|
||||
- AS_IF([AM_RUN_LOG([$1 -c "$prog"])], [$3], [$4])])
|
21
README.md
21
README.md
@ -1,21 +0,0 @@
|
||||
# Gluster
|
||||
Gluster is a software defined distributed storage that can scale to several
|
||||
petabytes. It provides interfaces for object, block and file storage.
|
||||
|
||||
## Development
|
||||
Contributions to gluster in the form of patches and new feature additions can
|
||||
be made by following steps outlined at [Developers Guide](https://gluster.readthedocs.io/en/latest/Developer-guide/Developers-Index/#contributing-to-the-gluster-community).
|
||||
|
||||
## Documentation
|
||||
The Gluster documentation can be found at [Gluster Docs](http://gluster.readthedocs.io/en/latest).
|
||||
|
||||
## Deployment
|
||||
Quick instructions to build and install can be found in [INSTALL](INSTALL) file.
|
||||
|
||||
## Maintainers
|
||||
The list of Gluster maintainers is available in [MAINTAINERS](MAINTAINERS) file.
|
||||
|
||||
## License
|
||||
Gluster is dual licensed under [GPLV2](COPYING-GPLV2) and [LGPLV3+](COPYING-LGPLV3).
|
||||
|
||||
Please visit the [Gluster Home Page](http://www.gluster.org/) to find out more about Gluster.
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
||||
glusterfs package is retired on branch c10s for BAKERY-412
|
@ -1,6 +0,0 @@
|
||||
# Change the glusterd service defaults here.
|
||||
# See "glusterd --help" outpout for defaults and possible values.
|
||||
|
||||
#GLUSTERD_LOGFILE="/var/log/gluster/gluster.log"
|
||||
#GLUSTERD_LOGLEVEL="NORMAL"
|
||||
|
2851
glusterfs.spec
2851
glusterfs.spec
File diff suppressed because it is too large
Load Diff
107
glusterfsd.init
107
glusterfsd.init
@ -1,107 +0,0 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# glusterfsd Startup script for the glusterfs server
|
||||
#
|
||||
# chkconfig: - 20 80
|
||||
# description: Clustered file-system server
|
||||
|
||||
### BEGIN INIT INFO
|
||||
# Provides: glusterfsd
|
||||
# Required-Start: $local_fs $network
|
||||
# Required-Stop: $local_fs $network
|
||||
# Should-Start:
|
||||
# Should-Stop:
|
||||
# Default-Start:
|
||||
# Default-Stop: 0 1 2 3 4 5 6
|
||||
# Short-Description: glusterfs server
|
||||
# Description: Clustered file-system server
|
||||
### END INIT INFO
|
||||
|
||||
# Source function library.
|
||||
. /etc/rc.d/init.d/functions
|
||||
|
||||
exec="/usr/sbin/glusterfsd"
|
||||
prog="glusterfsd"
|
||||
|
||||
# Set defaults, then source config for eventual overrides
|
||||
GLUSTERFSD_NOFILE="65536"
|
||||
|
||||
[ -e /etc/sysconfig/$prog ] && . /etc/sysconfig/$prog
|
||||
|
||||
lockfile=/var/lock/subsys/$prog
|
||||
|
||||
start() {
|
||||
[ -x $exec ] || exit 5
|
||||
[ $GLUSTERFSD_CONFIG -a -f $GLUSTERFSD_CONFIG ] || exit 6
|
||||
ulimit -n $GLUSTERFSD_NOFILE
|
||||
echo -n $"Starting $prog: "
|
||||
daemon $exec${GLUSTERFSD_CONFIG+" -f $GLUSTERFSD_CONFIG"}${GLUSTERFSD_LOGFILE+" -l $GLUSTERFSD_LOGFILE"}${GLUSTERFSD_LOGLEVEL+" -L $GLUSTERFSD_LOGLEVEL"} -p /var/run/glusterfsd.pid
|
||||
retval=$?
|
||||
echo
|
||||
[ $retval -eq 0 ] && touch $lockfile
|
||||
return $retval
|
||||
}
|
||||
|
||||
stop() {
|
||||
echo -n $"Stopping $prog: "
|
||||
killproc $prog
|
||||
retval=$?
|
||||
echo
|
||||
[ $retval -eq 0 ] && rm -f $lockfile
|
||||
return $retval
|
||||
}
|
||||
|
||||
restart() {
|
||||
stop
|
||||
start
|
||||
}
|
||||
|
||||
reload() {
|
||||
restart
|
||||
}
|
||||
|
||||
force_reload() {
|
||||
restart
|
||||
}
|
||||
|
||||
rh_status() {
|
||||
status $prog
|
||||
}
|
||||
|
||||
rh_status_q() {
|
||||
rh_status &>/dev/null
|
||||
}
|
||||
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
rh_status_q && exit 0
|
||||
$1
|
||||
;;
|
||||
stop)
|
||||
rh_status_q || exit 0
|
||||
$1
|
||||
;;
|
||||
restart)
|
||||
$1
|
||||
;;
|
||||
reload)
|
||||
rh_status_q || exit 7
|
||||
$1
|
||||
;;
|
||||
force-reload)
|
||||
force_reload
|
||||
;;
|
||||
status)
|
||||
rh_status
|
||||
;;
|
||||
condrestart|try-restart)
|
||||
rh_status_q || exit 0
|
||||
restart
|
||||
;;
|
||||
*)
|
||||
echo $"Usage: $0 {start|stop|status|restart|condrestart|try-restart|reload|force-reload}"
|
||||
exit 2
|
||||
esac
|
||||
exit $?
|
||||
|
@ -1,16 +0,0 @@
|
||||
[Unit]
|
||||
Description=GlusterFS brick processes (stopping only)
|
||||
After=network.target glusterd.service
|
||||
|
||||
[Service]
|
||||
Type=oneshot
|
||||
# glusterd starts the glusterfsd processed on-demand
|
||||
# /bin/true will mark this service as started, RemainAfterExit keeps it active
|
||||
ExecStart=/bin/true
|
||||
RemainAfterExit=yes
|
||||
# if there are no glusterfsd processes, a stop/reload should not give an error
|
||||
ExecStop=/bin/sh -c "/bin/killall --wait glusterfsd || /bin/true"
|
||||
ExecReload=/bin/sh -c "/bin/killall -HUP glusterfsd || /bin/true"
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
@ -1,6 +0,0 @@
|
||||
# Change the glusterfsd service defaults here.
|
||||
# See "glusterfsd --help" outpout for defaults and possible values.
|
||||
|
||||
#GLUSTERFSD_CONFIG="/etc/glusterfs/glusterfsd.vol"
|
||||
#GLUSTERFSD_LOGFILE="/var/log/glusterfs/glusterfs.log"
|
||||
#GLUSTERFSD_LOGLEVEL="NORMAL"
|
Loading…
Reference in New Issue
Block a user