autobuild v3.12.2-34

Resolves: bz#1648893 bz#1656357
Signed-off-by: Milind Changire <mchangir@redhat.com>
This commit is contained in:
Milind Changire 2018-12-19 03:26:48 -05:00
parent 1f2f23ddef
commit 5f5929f321
3 changed files with 100 additions and 2 deletions

View File

@ -0,0 +1,43 @@
From 10868bfc5ed099a90fbfd2310bc89c299475d94e Mon Sep 17 00:00:00 2001
From: Mohit Agrawal <moagrawa@redhat.com>
Date: Wed, 19 Dec 2018 13:08:01 +0530
Subject: [PATCH 494/495] mem-pool: Resolve crash in mem_pool_destroy
Problem: In the commit c8e58e3a577e70a64df77fe885847285f682d9fb
change the code in mem_pool_destroy to delete pool->owner
without validate pool
Solution: To avoid the crash check the pool pointer
(gdb) f 0
921 LOCK (&pool->ctx->lock);
(gdb) p pool
$1 = (struct mem_pool *) 0x0
Change-Id: I34fdc8974c5c60767a5c26e7d1c9099d398b9722
BUG: 1648893
Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>
Reviewed-on: https://code.engineering.redhat.com/gerrit/159029
Tested-by: RHGS Build Bot <nigelb@redhat.com>
Reviewed-by: Sunil Kumar Heggodu Gopala Acharya <sheggodu@redhat.com>
---
libglusterfs/src/mem-pool.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/libglusterfs/src/mem-pool.c b/libglusterfs/src/mem-pool.c
index d82a371..76daca9 100644
--- a/libglusterfs/src/mem-pool.c
+++ b/libglusterfs/src/mem-pool.c
@@ -917,6 +917,9 @@ mem_put (void *ptr)
void
mem_pool_destroy (struct mem_pool *pool)
{
+ if (!pool)
+ return;
+
/* remove this pool from the owner (glusterfs_ctx_t) */
LOCK (&pool->ctx->lock);
{
--
1.8.3.1

View File

@ -0,0 +1,48 @@
From 24b37593679a8a3a3dbba14ff92ec92c6d83dbc6 Mon Sep 17 00:00:00 2001
From: Milind Changire <mchangir@redhat.com>
Date: Wed, 19 Dec 2018 13:17:42 +0530
Subject: [PATCH 495/495] build: add conditional dependency on server for devel
Add conditional depedency on server for glusterfs-devel
Label: DOWNSTREAM ONLY
BUG: 1656357
Change-Id: Icc45df3db137dbc03d240c1ac774b5c8735c5f2f
Signed-off-by: Milind Changire <mchangir@redhat.com>
Reviewed-on: https://code.engineering.redhat.com/gerrit/159030
Tested-by: RHGS Build Bot <nigelb@redhat.com>
Reviewed-by: Sunil Kumar Heggodu Gopala Acharya <sheggodu@redhat.com>
---
glusterfs.spec.in | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/glusterfs.spec.in b/glusterfs.spec.in
index 16dc5d7..0ad4ffc 100644
--- a/glusterfs.spec.in
+++ b/glusterfs.spec.in
@@ -339,7 +339,9 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{name}-extra-xlators = %{version}-%{release}
%endif
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
+%if ( 0%{?_build_server} )
Requires: %{name}-server%{?_isa} = %{version}-%{release}
+%endif
%description devel
GlusterFS is a distributed file-system capable of scaling to several
@@ -2171,6 +2173,11 @@ fi
%endif
%changelog
+* Wed Dec 19 2018 Milind Changire <mchangir@redhat.com>
+- Add explicit package dependencies (#1656357)
+- Remove absolute paths from spec file (#1350745)
+- Do not package crypt.so for FIPS compliance (#1653224)
+
* Thu Dec 13 2018 Krutika Dhananjay <kdhananj@redhat.com>
- Install /var/lib/glusterd/groups/distributed-virt by default (#1653613)
--
1.8.3.1

View File

@ -192,7 +192,7 @@ Release: 0.1%{?prereltag:.%{prereltag}}%{?dist}
%else
Name: glusterfs
Version: 3.12.2
Release: 33%{?dist}
Release: 34%{?dist}
%endif
License: GPLv2 or LGPLv3+
Group: System Environment/Base
@ -720,7 +720,7 @@ Patch0452: 0452-glusterd-make-max-bricks-per-process-default-value-t.patch
Patch0453: 0453-server-Resolve-memory-leak-path-in-server_init.patch
Patch0454: 0454-glusterd-set-cluster.max-bricks-per-process-to-250.patch
Patch0455: 0455-glusterd-fix-get_mux_limit_per_process-to-read-defau.patch
Patch0456: 0456-Update-rfc.sh-to-rhgs-3.4.3.patch
# Patch0456: 0456-Update-rfc.sh-to-rhgs-3.4.3.patch
Patch0457: 0457-cluster-dht-sync-brick-root-perms-on-add-brick.patch
Patch0458: 0458-glusterd-fix-crash.patch
Patch0459: 0459-glfsheal-add-a-nolog-flag.patch
@ -758,6 +758,8 @@ Patch0490: 0490-glusterd-migrating-rebalance-commands-to-mgmt_v3-fra.patch
Patch0491: 0491-glusterd-tag-rebalance-mgmt_v3-command-to-op-version.patch
Patch0492: 0492-mem-pool-track-glusterfs_ctx_t-in-struct-mem_pool.patch
Patch0493: 0493-mem-pool-count-allocations-done-per-user-pool.patch
Patch0494: 0494-mem-pool-Resolve-crash-in-mem_pool_destroy.patch
Patch0495: 0495-build-add-conditional-dependency-on-server-for-devel.patch
%description
GlusterFS is a distributed file-system capable of scaling to several
@ -834,7 +836,9 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{name}-extra-xlators = %{version}-%{release}
%endif
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%if ( 0%{?_build_server} )
Requires: %{name}-server%{?_isa} = %{version}-%{release}
%endif
%description devel
GlusterFS is a distributed file-system capable of scaling to several
@ -2716,6 +2720,9 @@ fi
%endif
%changelog
* Wed Dec 19 2018 Milind Changire <mchangir@redhat.com> - 3.12.2-34
- fixes bugs bz#1648893 bz#1656357
* Tue Dec 18 2018 Milind Changire <mchangir@redhat.com> - 3.12.2-33
- fixes bugs bz#1350745 bz#1362129 bz#1541568 bz#1597252 bz#1599220
bz#1633177 bz#1637564 bz#1639476 bz#1639568 bz#1643370 bz#1645480 bz#1648296