autobuild v6.0-43
Resolves: bz#1460657 Signed-off-by: Deepshikha Khandelwal <dkhandel@redhat.com>
This commit is contained in:
parent
79fc12f8a1
commit
2f5ee7359b
38
0467-build-Added-dependency-for-glusterfs-selinux.patch
Normal file
38
0467-build-Added-dependency-for-glusterfs-selinux.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
From 9176ee8f10c3c33f31d00261995ed27e8680934a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Rinku Kothiya <rkothiya@redhat.com>
|
||||||
|
Date: Thu, 3 Sep 2020 11:46:38 +0000
|
||||||
|
Subject: [PATCH 467/467] build: Added dependency for glusterfs-selinux
|
||||||
|
|
||||||
|
> Fixes: #1442
|
||||||
|
> Upstream-patch: https://review.gluster.org/#/c/glusterfs/+/24876/
|
||||||
|
> Change-Id: I7d79bceff329db4d525bc8a77ba7ffe41bf53c97
|
||||||
|
> Signed-off-by: Rinku Kothiya <rkothiya@redhat.com>
|
||||||
|
|
||||||
|
BUG: 1460657
|
||||||
|
|
||||||
|
Change-Id: I7d79bceff329db4d525bc8a77ba7ffe41bf53c97
|
||||||
|
Signed-off-by: Rinku Kothiya <rkothiya@redhat.com>
|
||||||
|
Reviewed-on: https://code.engineering.redhat.com/gerrit/210637
|
||||||
|
Tested-by: RHGS Build Bot <nigelb@redhat.com>
|
||||||
|
Reviewed-by: Sunil Kumar Heggodu Gopala Acharya <sheggodu@redhat.com>
|
||||||
|
---
|
||||||
|
glusterfs.spec.in | 3 +++
|
||||||
|
1 file changed, 3 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/glusterfs.spec.in b/glusterfs.spec.in
|
||||||
|
index 9def416..ed6bdf3 100644
|
||||||
|
--- a/glusterfs.spec.in
|
||||||
|
+++ b/glusterfs.spec.in
|
||||||
|
@@ -650,6 +650,9 @@ Summary: Clustered file-system server
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: %{name}-cli%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
|
+%if ( 0%{?fedora} && 0%{?fedora} >= 30 || ( 0%{?rhel} && 0%{?rhel} >= 8 ) )
|
||||||
|
+Requires: glusterfs-selinux >= 0.1.0-2
|
||||||
|
+%endif
|
||||||
|
# some daemons (like quota) use a fuse-mount, glusterfsd is part of -fuse
|
||||||
|
Requires: %{name}-fuse%{?_isa} = %{version}-%{release}
|
||||||
|
# self-heal daemon, rebalance, nfs-server etc. are actually clients
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
@ -237,7 +237,7 @@ Release: 0.1%{?prereltag:.%{prereltag}}%{?dist}
|
|||||||
%else
|
%else
|
||||||
Name: glusterfs
|
Name: glusterfs
|
||||||
Version: 6.0
|
Version: 6.0
|
||||||
Release: 42%{?dist}
|
Release: 43%{?dist}
|
||||||
ExcludeArch: i686
|
ExcludeArch: i686
|
||||||
%endif
|
%endif
|
||||||
License: GPLv2 or LGPLv3+
|
License: GPLv2 or LGPLv3+
|
||||||
@ -781,6 +781,7 @@ Patch0463: 0463-cluster-ec-Change-handling-of-heal-failure-to-avoid-.patch
|
|||||||
Patch0464: 0464-storage-posix-Remove-nr_files-usage.patch
|
Patch0464: 0464-storage-posix-Remove-nr_files-usage.patch
|
||||||
Patch0465: 0465-posix-Implement-a-janitor-thread-to-close-fd.patch
|
Patch0465: 0465-posix-Implement-a-janitor-thread-to-close-fd.patch
|
||||||
Patch0466: 0466-cluster-ec-Change-stale-index-handling.patch
|
Patch0466: 0466-cluster-ec-Change-stale-index-handling.patch
|
||||||
|
Patch0467: 0467-build-Added-dependency-for-glusterfs-selinux.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
GlusterFS is a distributed file-system capable of scaling to several
|
GlusterFS is a distributed file-system capable of scaling to several
|
||||||
@ -1118,6 +1119,9 @@ Summary: Clustered file-system server
|
|||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
Requires: %{name}-cli%{?_isa} = %{version}-%{release}
|
Requires: %{name}-cli%{?_isa} = %{version}-%{release}
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
|
%if ( 0%{?fedora} && 0%{?fedora} >= 30 || ( 0%{?rhel} && 0%{?rhel} >= 8 ) )
|
||||||
|
Requires: glusterfs-selinux >= 0.1.0-2
|
||||||
|
%endif
|
||||||
# some daemons (like quota) use a fuse-mount, glusterfsd is part of -fuse
|
# some daemons (like quota) use a fuse-mount, glusterfsd is part of -fuse
|
||||||
Requires: %{name}-fuse%{?_isa} = %{version}-%{release}
|
Requires: %{name}-fuse%{?_isa} = %{version}-%{release}
|
||||||
# self-heal daemon, rebalance, nfs-server etc. are actually clients
|
# self-heal daemon, rebalance, nfs-server etc. are actually clients
|
||||||
@ -2521,6 +2525,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 03 2020 Deepshikha Khandelwal <dkhandel@redhat.com> - 6.0-43
|
||||||
|
- fixes bugs bz#1460657
|
||||||
|
|
||||||
* Wed Sep 02 2020 Deepshikha Khandelwal <dkhandel@redhat.com> - 6.0-42
|
* Wed Sep 02 2020 Deepshikha Khandelwal <dkhandel@redhat.com> - 6.0-42
|
||||||
- fixes bugs bz#1785714
|
- fixes bugs bz#1785714
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user