autobuild v3.12.2-42
Resolves: bz#1410145 Signed-off-by: Milind Changire <mchangir@redhat.com>
This commit is contained in:
parent
2f3c8edfdf
commit
210265dcec
181
0530-spec-fix-lua-script-execution-during-install.patch
Normal file
181
0530-spec-fix-lua-script-execution-during-install.patch
Normal file
@ -0,0 +1,181 @@
|
|||||||
|
From 0cef0696d665b385706d9be7aad48afee2537775 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Milind Changire <mchangir@redhat.com>
|
||||||
|
Date: Tue, 12 Feb 2019 16:25:37 +0530
|
||||||
|
Subject: [PATCH 530/530] spec: fix lua script execution during install
|
||||||
|
|
||||||
|
Explicit bash shell invocation in the os.execute() API is not required.
|
||||||
|
Since the script starts with the #!/bin/sh hash-bang sequence,
|
||||||
|
os.execute() successfully spawns and runs the script.
|
||||||
|
|
||||||
|
Label: DOWNSTREAM ONLY
|
||||||
|
|
||||||
|
BUG: 1410145
|
||||||
|
Change-Id: I7774380adb1c164f50145270e91c1d2c086cd9d4
|
||||||
|
Signed-off-by: Milind Changire <mchangir@redhat.com>
|
||||||
|
Reviewed-on: https://code.engineering.redhat.com/gerrit/162774
|
||||||
|
Reviewed-by: Sunil Kumar Heggodu Gopala Acharya <sheggodu@redhat.com>
|
||||||
|
---
|
||||||
|
glusterfs.spec.in | 63 +++++++++++++------------------------------------------
|
||||||
|
1 file changed, 15 insertions(+), 48 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/glusterfs.spec.in b/glusterfs.spec.in
|
||||||
|
index 2680bec..89cd501 100644
|
||||||
|
--- a/glusterfs.spec.in
|
||||||
|
+++ b/glusterfs.spec.in
|
||||||
|
@@ -1640,10 +1640,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -1677,10 +1674,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -1714,10 +1708,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -1751,10 +1742,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -1788,10 +1776,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -1825,10 +1810,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -1862,10 +1844,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -1900,10 +1879,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -1938,10 +1914,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -1976,10 +1949,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -2015,10 +1985,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -2053,10 +2020,7 @@ if [ $? -eq 0 ]; then
|
||||||
|
fi
|
||||||
|
]]
|
||||||
|
|
||||||
|
--- Since we run pretrans scripts only for RPMs built for a server build,
|
||||||
|
--- we can now use os.tmpname() since it is available on RHEL6 and later
|
||||||
|
--- platforms which are server platforms.
|
||||||
|
-ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
||||||
|
+ok, how, val = os.execute(script)
|
||||||
|
if not (ok == 0) then
|
||||||
|
error("Detected running glusterfs processes", ok)
|
||||||
|
end
|
||||||
|
@@ -2113,6 +2077,9 @@ fi
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
+* Tue Feb 09 2019 Milind Changire <mchangir@redhat.com>
|
||||||
|
+- Fix lua script execution during install (#1410145)
|
||||||
|
+
|
||||||
|
* Sat Feb 09 2019 Milind Changire <mchangir@redhat.com>
|
||||||
|
- Avoid creation of temporary file in lua script during install (#1410145)
|
||||||
|
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
@ -192,7 +192,7 @@ Release: 0.1%{?prereltag:.%{prereltag}}%{?dist}
|
|||||||
%else
|
%else
|
||||||
Name: glusterfs
|
Name: glusterfs
|
||||||
Version: 3.12.2
|
Version: 3.12.2
|
||||||
Release: 41%{?dist}
|
Release: 42%{?dist}
|
||||||
%endif
|
%endif
|
||||||
License: GPLv2 or LGPLv3+
|
License: GPLv2 or LGPLv3+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -794,6 +794,7 @@ Patch0526: 0526-fuse-interrupt-handling-framework.patch
|
|||||||
Patch0527: 0527-fuse-diagnostic-FLUSH-interrupt.patch
|
Patch0527: 0527-fuse-diagnostic-FLUSH-interrupt.patch
|
||||||
Patch0528: 0528-locks-handle-clear-locks-xattr-in-fgetxattr-too.patch
|
Patch0528: 0528-locks-handle-clear-locks-xattr-in-fgetxattr-too.patch
|
||||||
Patch0529: 0529-fuse-SETLKW-interrupt.patch
|
Patch0529: 0529-fuse-SETLKW-interrupt.patch
|
||||||
|
Patch0530: 0530-spec-fix-lua-script-execution-during-install.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
GlusterFS is a distributed file-system capable of scaling to several
|
GlusterFS is a distributed file-system capable of scaling to several
|
||||||
@ -2221,10 +2222,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2258,10 +2256,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2295,10 +2290,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2332,10 +2324,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2369,10 +2358,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2406,10 +2392,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2443,10 +2426,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2481,10 +2461,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2519,10 +2496,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2557,10 +2531,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2596,10 +2567,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2634,10 +2602,7 @@ if [ $? -eq 0 ]; then
|
|||||||
fi
|
fi
|
||||||
]]
|
]]
|
||||||
|
|
||||||
-- Since we run pretrans scripts only for RPMs built for a server build,
|
ok, how, val = os.execute(script)
|
||||||
-- we can now use os.tmpname() since it is available on RHEL6 and later
|
|
||||||
-- platforms which are server platforms.
|
|
||||||
ok, how, val = os.execute("/bin/bash -c \"" .. script .. "\"")
|
|
||||||
if not (ok == 0) then
|
if not (ok == 0) then
|
||||||
error("Detected running glusterfs processes", ok)
|
error("Detected running glusterfs processes", ok)
|
||||||
end
|
end
|
||||||
@ -2694,6 +2659,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 12 2019 Milind Changire <mchangir@redhat.com> - 3.12.2-42
|
||||||
|
- fixes bugs bz#1410145
|
||||||
|
|
||||||
* Tue Feb 12 2019 Milind Changire <mchangir@redhat.com> - 3.12.2-41
|
* Tue Feb 12 2019 Milind Changire <mchangir@redhat.com> - 3.12.2-41
|
||||||
- fixes bugs bz#1390151 bz#1410145 bz#1429190 bz#1510752 bz#1511779
|
- fixes bugs bz#1390151 bz#1410145 bz#1429190 bz#1510752 bz#1511779
|
||||||
bz#1570958 bz#1574490 bz#1595246 bz#1618669 bz#1661393 bz#1668989 bz#1669020
|
bz#1570958 bz#1574490 bz#1595246 bz#1618669 bz#1661393 bz#1668989 bz#1669020
|
||||||
|
Loading…
Reference in New Issue
Block a user