autobuild v6.0-61
Related: rhbz#2055630 Resolves: bz#1973566 Signed-off-by: Gluster Jenkins <dkhandel+glusterjenkins@redhat.com>
This commit is contained in:
parent
8c93bcfac1
commit
028025a295
54
0611-SELinux-Fix-boolean-management-again.patch
Normal file
54
0611-SELinux-Fix-boolean-management-again.patch
Normal file
@ -0,0 +1,54 @@
|
|||||||
|
From 5ad4711f40c0e8ab7c196ac1c9025bf78b8b94e0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Kaleb S. KEITHLEY" <kkeithle@redhat.com>
|
||||||
|
Date: Thu, 18 Nov 2021 09:21:56 -0500
|
||||||
|
Subject: [PATCH 611/611] SELinux: Fix boolean management, again
|
||||||
|
|
||||||
|
When upgrading from a version of the package that does not include
|
||||||
|
the previous fix this means the flawed scriptlet is still executed,
|
||||||
|
undoing the setting of the boolean.
|
||||||
|
|
||||||
|
In order to work the boolean needs to be set in %posttrans. This is
|
||||||
|
a temporary change that can (or should) be removed in the next version
|
||||||
|
of RHGS, i.e. 3.5.7.
|
||||||
|
|
||||||
|
Issue: https://github.com/gluster/glusterfs/issues/2522
|
||||||
|
Resolves: rhbz#1973566
|
||||||
|
Resolves: rhbz#1975400
|
||||||
|
|
||||||
|
Label: DOWNSTREAM ONLY
|
||||||
|
|
||||||
|
BUG: 1973566
|
||||||
|
Change-Id: Ida39a3ee5e6b4b0d3255bfef95601890afd80709
|
||||||
|
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
|
||||||
|
Reviewed-on: https://code.engineering.redhat.com/gerrit/c/rhs-glusterfs/+/292189
|
||||||
|
Tested-by: RHGS Build Bot <nigelb@redhat.com>
|
||||||
|
Reviewed-by: Sunil Kumar Heggodu Gopala Acharya <sheggodu@redhat.com>
|
||||||
|
---
|
||||||
|
glusterfs.spec.in | 11 +++++++++++
|
||||||
|
1 file changed, 11 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/glusterfs.spec.in b/glusterfs.spec.in
|
||||||
|
index 8b6646f..87176c9 100644
|
||||||
|
--- a/glusterfs.spec.in
|
||||||
|
+++ b/glusterfs.spec.in
|
||||||
|
@@ -1123,6 +1123,17 @@ exit 0
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
|
+%if ( 0%{!?_without_server:1} )
|
||||||
|
+%if ( ( 0%{?fedora} && 0%{?fedora} > 25 ) || ( 0%{?rhel} && 0%{?rhel} > 6 ) )
|
||||||
|
+# temporary fix to be removed in the next version (i.e. RHGS 3.5.7). This
|
||||||
|
+# is only needed when upgrading from the flawed versions (e.g. RHGS 3.5.5
|
||||||
|
+# and earlier.)
|
||||||
|
+%posttrans ganesha
|
||||||
|
+semanage boolean -m ganesha_use_fusefs --on -S targeted
|
||||||
|
+exit 0
|
||||||
|
+%endif
|
||||||
|
+%endif
|
||||||
|
+
|
||||||
|
##-----------------------------------------------------------------------------
|
||||||
|
## All %%files should be placed here and keep them grouped
|
||||||
|
##
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
@ -237,7 +237,7 @@ Release: 0.2%{?prereltag:.%{prereltag}}%{?dist}
|
|||||||
%else
|
%else
|
||||||
Name: glusterfs
|
Name: glusterfs
|
||||||
Version: 6.0
|
Version: 6.0
|
||||||
Release: 60%{?dist}
|
Release: 61%{?dist}
|
||||||
ExcludeArch: i686
|
ExcludeArch: i686
|
||||||
%endif
|
%endif
|
||||||
License: GPLv2 or LGPLv3+
|
License: GPLv2 or LGPLv3+
|
||||||
@ -927,6 +927,7 @@ Patch0607: 0607-SELinux-Fix-boolean-management.patch
|
|||||||
Patch0608: 0608-cluster-ec-Track-heal-statistics-in-shd.patch
|
Patch0608: 0608-cluster-ec-Track-heal-statistics-in-shd.patch
|
||||||
Patch0609: 0609-feature-shard-wrong-dname-results-in-dentry-not-foun.patch
|
Patch0609: 0609-feature-shard-wrong-dname-results-in-dentry-not-foun.patch
|
||||||
Patch0610: 0610-glusterfs.spec.in-remove-condtionals-from-tar-depend.patch
|
Patch0610: 0610-glusterfs.spec.in-remove-condtionals-from-tar-depend.patch
|
||||||
|
Patch0611: 0611-SELinux-Fix-boolean-management-again.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
GlusterFS is a distributed file-system capable of scaling to several
|
GlusterFS is a distributed file-system capable of scaling to several
|
||||||
@ -1810,6 +1811,17 @@ exit 0
|
|||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%if ( 0%{!?_without_server:1} )
|
||||||
|
%if ( ( 0%{?fedora} && 0%{?fedora} > 25 ) || ( 0%{?rhel} && 0%{?rhel} > 6 ) )
|
||||||
|
# temporary fix to be removed in the next version (i.e. RHGS 3.5.7). This
|
||||||
|
# is only needed when upgrading from the flawed versions (e.g. RHGS 3.5.5
|
||||||
|
# and earlier.)
|
||||||
|
%posttrans ganesha
|
||||||
|
semanage boolean -m ganesha_use_fusefs --on -S targeted
|
||||||
|
exit 0
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
##-----------------------------------------------------------------------------
|
##-----------------------------------------------------------------------------
|
||||||
## All %%files should be placed here and keep them grouped
|
## All %%files should be placed here and keep them grouped
|
||||||
##
|
##
|
||||||
@ -2680,7 +2692,6 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
|
||||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 6.0-57.4
|
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 6.0-57.4
|
||||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
Related: rhbz#1991688
|
Related: rhbz#1991688
|
||||||
@ -2694,6 +2705,9 @@ fi
|
|||||||
- Fix changlog chronological order by removing unneeded changelogs
|
- Fix changlog chronological order by removing unneeded changelogs
|
||||||
- fixes bug bz#1939340
|
- fixes bug bz#1939340
|
||||||
|
|
||||||
|
* Mon Nov 29 2021 Gluster Jenkins <dkhandel+glusterjenkins@redhat.com> - 6.0-61
|
||||||
|
- fixes bugs bz#1973566
|
||||||
|
|
||||||
* Mon Oct 11 2021 Gluster Jenkins <dkhandel+glusterjenkins@redhat.com> - 6.0-60
|
* Mon Oct 11 2021 Gluster Jenkins <dkhandel+glusterjenkins@redhat.com> - 6.0-60
|
||||||
- fixes bugs bz#1668303 bz#1853631 bz#1901468 bz#1904137 bz#1911665
|
- fixes bugs bz#1668303 bz#1853631 bz#1901468 bz#1904137 bz#1911665
|
||||||
bz#1962972 bz#1973566 bz#1994593 bz#1995029 bz#1997447 bz#2006205
|
bz#1962972 bz#1973566 bz#1994593 bz#1995029 bz#1997447 bz#2006205
|
||||||
|
Loading…
Reference in New Issue
Block a user