import glslang-3.1-0.10.20180727.gite99a268.el8
This commit is contained in:
commit
10bcac0ae8
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/glslang-e99a26810f65314183163c07664a40e05647c15f.tar.gz
|
1
.glslang.metadata
Normal file
1
.glslang.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
e353c3ca32360949af788df57b8da29623624c2b SOURCES/glslang-e99a26810f65314183163c07664a40e05647c15f.tar.gz
|
9
SOURCES/glslang-default-resource-limits_staticlib.patch
Normal file
9
SOURCES/glslang-default-resource-limits_staticlib.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
--- a/StandAlone/CMakeLists.txt
|
||||||
|
+++ b/StandAlone/CMakeLists.txt
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-add_library(glslang-default-resource-limits
|
||||||
|
+add_library(glslang-default-resource-limits STATIC
|
||||||
|
${CMAKE_CURRENT_SOURCE_DIR}/ResourceLimits.cpp)
|
||||||
|
set_property(TARGET glslang-default-resource-limits PROPERTY FOLDER glslang)
|
||||||
|
set_property(TARGET glslang-default-resource-limits PROPERTY POSITION_INDEPENDENT_CODE ON)
|
||||||
|
|
21
SOURCES/glslang_tests.patch
Normal file
21
SOURCES/glslang_tests.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
--- glslang-715c353a15836e5ae192a64a4cf54e2ce7e8d66a/Test/runtests
|
||||||
|
+++ glslang-715c353a15836e5ae192a64a4cf54e2ce7e8d66a-new/Test/runtests
|
||||||
|
@@ -2,8 +2,8 @@
|
||||||
|
|
||||||
|
TARGETDIR=localResults
|
||||||
|
BASEDIR=baseResults
|
||||||
|
-EXE=../build/install/bin/glslangValidator
|
||||||
|
-REMAPEXE=../build/install/bin/spirv-remap
|
||||||
|
+EXE=../build/StandAlone/glslangValidator
|
||||||
|
+REMAPEXE=../build/StandAlone/spirv-remap
|
||||||
|
HASERROR=0
|
||||||
|
mkdir -p localResults
|
||||||
|
|
||||||
|
|
||||||
|
--- glslang-715c353a15836e5ae192a64a4cf54e2ce7e8d66a/Test/glslangValidator
|
||||||
|
+++ glslang-715c353a15836e5ae192a64a4cf54e2ce7e8d66a-new/Test/glslangValidator
|
||||||
|
@@ -1,2 +1,2 @@
|
||||||
|
#!/usr/bin/env bash
|
||||||
|
-../build/install/bin/glslangValidator $*
|
||||||
|
+../build/StandAlone/glslangValidator $*
|
||||||
|
|
20
SOURCES/nodate.patch
Normal file
20
SOURCES/nodate.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
From: Jan Engelhardt <jengelh@inai.de>
|
||||||
|
Date: 2017-08-07 20:22:29.456870387 +0200
|
||||||
|
|
||||||
|
---
|
||||||
|
StandAlone/spirv-remap.cpp | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
Index: glslang/StandAlone/spirv-remap.cpp
|
||||||
|
===================================================================
|
||||||
|
--- a/StandAlone/spirv-remap.cpp
|
||||||
|
+++ b/StandAlone/spirv-remap.cpp
|
||||||
|
@@ -227,7 +227,7 @@ namespace {
|
||||||
|
}
|
||||||
|
}
|
||||||
|
else if (arg == "--version" || arg == "-V") {
|
||||||
|
- std::cout << basename(argv[0]) << " version 0.97 " << __DATE__ << " " << __TIME__ << std::endl;
|
||||||
|
+ std::cout << basename(argv[0]) << " version 0.97 " << std::endl;
|
||||||
|
exit(0);
|
||||||
|
} else if (arg == "--input" || arg == "-i") {
|
||||||
|
// Collect input files
|
113
SPECS/glslang.spec
Normal file
113
SPECS/glslang.spec
Normal file
@ -0,0 +1,113 @@
|
|||||||
|
%global commit e99a26810f65314183163c07664a40e05647c15f
|
||||||
|
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
|
%global commit_date 20180727
|
||||||
|
%global gitrel .%{commit_date}.git%{shortcommit}
|
||||||
|
|
||||||
|
Name: glslang
|
||||||
|
Version: 3.1
|
||||||
|
Release: 0.10%{?gitrel}%{?dist}
|
||||||
|
Summary: OpenGL and OpenGL ES shader front end and validator
|
||||||
|
|
||||||
|
License: BSD and GPLv3+ and ASL 2.0
|
||||||
|
URL: https://github.com/KhronosGroup
|
||||||
|
Source0: %url/%{name}/archive/%{commit}.tar.gz#/%{name}-%{commit}.tar.gz
|
||||||
|
Patch0: nodate.patch
|
||||||
|
Patch1: glslang-default-resource-limits_staticlib.patch
|
||||||
|
Patch2: glslang_tests.patch
|
||||||
|
|
||||||
|
BuildRequires: cmake3
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: ninja-build
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{name} is the official reference compiler front end for the OpenGL
|
||||||
|
ES and OpenGL shading languages. It implements a strict
|
||||||
|
interpretation of the specifications for these languages.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
%{name} is the official reference compiler front end for the OpenGL
|
||||||
|
ES and OpenGL shading languages. It implements a strict
|
||||||
|
interpretation of the specifications for these languages.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1 -n %{name}-%{commit}
|
||||||
|
# Fix rpmlint warning on debuginfo
|
||||||
|
find . -name '*.h' -or -name '*.cpp' -or -name '*.hpp'| xargs chmod a-x
|
||||||
|
|
||||||
|
%build
|
||||||
|
%__mkdir_p build
|
||||||
|
pushd build
|
||||||
|
%cmake3 -DCMAKE_BUILD_TYPE=Release \
|
||||||
|
-DCMAKE_INSTALL_LIBDIR=%{_libdir} \
|
||||||
|
-DCMAKE_SKIP_RPATH:BOOL=yes \
|
||||||
|
-DBUILD_SHARED_LIBS=OFF \
|
||||||
|
-GNinja ..
|
||||||
|
%{ninja_build}
|
||||||
|
popd
|
||||||
|
|
||||||
|
%install
|
||||||
|
%{ninja_install} -C build
|
||||||
|
|
||||||
|
%ifnarch s390x ppc64
|
||||||
|
%check
|
||||||
|
pushd Test
|
||||||
|
./runtests
|
||||||
|
popd
|
||||||
|
%endif
|
||||||
|
|
||||||
|
# Install libglslang-default-resource-limits.a
|
||||||
|
install -pm 0644 build/StandAlone/libglslang-default-resource-limits.a %{buildroot}%{_libdir}/
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc README.md README-spirv-remap.txt
|
||||||
|
%{_bindir}/glslangValidator
|
||||||
|
%{_bindir}/spirv-remap
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/SPIRV/
|
||||||
|
%{_includedir}/glslang/
|
||||||
|
%{_libdir}/libHLSL.a
|
||||||
|
%{_libdir}/libOGLCompiler.a
|
||||||
|
%{_libdir}/libOSDependent.a
|
||||||
|
%{_libdir}/libSPIRV.a
|
||||||
|
%{_libdir}/libSPVRemapper.a
|
||||||
|
%{_libdir}/libglslang.a
|
||||||
|
%{_libdir}/libglslang-default-resource-limits.a
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Aug 07 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.10.20180727.gite99a268
|
||||||
|
- Update for vulkan 1.1.82.0
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.9.20180416.git3bb4c48
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Apr 23 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.8.20180416.git3bb4c48
|
||||||
|
- Update for vulkan 1.1.73.0
|
||||||
|
|
||||||
|
* Wed Mar 07 2018 Adam Williamson <awilliam@redhat.com> - 3.1-0.7.20180205.git2651cca
|
||||||
|
- Rebuild to fix GCC 8 mis-compilation
|
||||||
|
See https://da.gd/YJVwk ("GCC 8 ABI change on x86_64")
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.6.20180205.git2651cca
|
||||||
|
- Update for vulkan 1.0.68.0
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.5.20171028.git715c353
|
||||||
|
- Use ninja to build
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.4.20171028.git715c353
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 03 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.3.20171028.git715c353
|
||||||
|
- Exclude s390x and ppc64 from check section
|
||||||
|
|
||||||
|
* Wed Jan 03 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.2.20171028.git715c353
|
||||||
|
- Add check section to run tests
|
||||||
|
- Split binaries into main package
|
||||||
|
|
||||||
|
* Thu Jul 13 2017 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.1.20171028.git715c353
|
||||||
|
- First build
|
||||||
|
|
Loading…
Reference in New Issue
Block a user