e43852d149
* Thu Oct 13 2022 Arjun Shankar <arjun@redhat.com> - 2.34-48 - Handle non-hostname CNAME aliases during name resolution (#2129005) - Sync with upstream branch release/2.34/master, commit e3976287b22422787f3cc6fc9adda58304b55bd9: - nscd: Drop local address tuple variable [BZ #29607] - x86-64: Require BMI1/BMI2 for AVX2 strrchr and wcsrchr implementations - x86-64: Require BMI2 and LZCNT for AVX2 memrchr implementation - x86-64: Require BMI2 for AVX2 (raw|w)memchr implementations - x86-64: Require BMI2 for AVX2 wcs(n)cmp implementations - x86-64: Require BMI2 for AVX2 strncmp implementation - x86-64: Require BMI2 for AVX2 strcmp implementation - x86-64: Require BMI2 for AVX2 str(n)casecmp implementations - x86: include BMI1 and BMI2 in x86-64-v3 level - nptl: Add backoff mechanism to spinlock loop - sysdeps: Add 'get_fast_jitter' interace in fast-jitter.h - nptl: Effectively skip CAS in spinlock loop - Move assignment out of the CAS condition - Add LLL_MUTEX_READ_LOCK [BZ #28537] - Avoid extra load with CAS in __pthread_mutex_clocklock_common [BZ #28537] - Avoid extra load with CAS in __pthread_mutex_lock_full [BZ #28537] - resolv: Fix building tst-resolv-invalid-cname for earlier C standards - nss_dns: Rewrite _nss_dns_gethostbyname4_r using current interfaces - resolv: Add new tst-resolv-invalid-cname - nss_dns: In gaih_getanswer_slice, skip strange aliases (bug 12154) (#2129005) - nss_dns: Rewrite getanswer_r to match getanswer_ptr (bug 12154, bug 29305) - nss_dns: Remove remnants of IPv6 address mapping - nss_dns: Rewrite _nss_dns_gethostbyaddr2_r and getanswer_ptr - nss_dns: Split getanswer_ptr from getanswer_r - resolv: Add DNS packet parsing helpers geared towards wire format - resolv: Add internal __ns_name_length_uncompressed function - resolv: Add the __ns_samebinaryname function - resolv: Add internal __res_binary_hnok function - resolv: Add tst-resolv-aliases - resolv: Add tst-resolv-byaddr for testing reverse lookup - gconv: Use 64-bit interfaces in gconv_parseconfdir (bug 29583) - elf: Fix hwcaps string size overestimation - nscd: Fix netlink cache invalidation if epoll is used [BZ #29415] - Apply asm redirections in wchar.h before first use - Apply asm redirections in stdio.h before first use [BZ #27087] - elf: Call __libc_early_init for reused namespaces (bug 29528) Resolves: #2129005 Resolves: #2116960
183 lines
6.1 KiB
Diff
183 lines
6.1 KiB
Diff
commit bb8adbba4f5d9237a144786ba8e504039beff161
|
|
Author: Florian Weimer <fweimer@redhat.com>
|
|
Date: Tue Aug 30 10:02:49 2022 +0200
|
|
|
|
resolv: Add the __ns_samebinaryname function
|
|
|
|
During packet parsing, only the binary name is available. If the name
|
|
equality check is performed before conversion to text, we can sometimes
|
|
skip the last step.
|
|
|
|
Reviewed-by: Siddhesh Poyarekar <siddhesh@sourceware.org>
|
|
(cherry picked from commit 394085a34d25a51513019a4dc411acd3527fbd33)
|
|
|
|
diff --git a/include/arpa/nameser.h b/include/arpa/nameser.h
|
|
index 53f1dbc7c3f659e9..bb1dede187cf1500 100644
|
|
--- a/include/arpa/nameser.h
|
|
+++ b/include/arpa/nameser.h
|
|
@@ -55,6 +55,12 @@ int __ns_name_ntop (const unsigned char *, char *, size_t) __THROW;
|
|
int __ns_name_unpack (const unsigned char *, const unsigned char *,
|
|
const unsigned char *, unsigned char *, size_t) __THROW;
|
|
|
|
+/* Like ns_samename, but for uncompressed binary names. Return true
|
|
+ if the two arguments compare are equal as case-insensitive domain
|
|
+ names. */
|
|
+_Bool __ns_samebinaryname (const unsigned char *, const unsigned char *)
|
|
+ attribute_hidden;
|
|
+
|
|
#define ns_msg_getflag(handle, flag) \
|
|
(((handle)._flags & _ns_flagdata[flag].mask) >> _ns_flagdata[flag].shift)
|
|
|
|
diff --git a/resolv/Makefile b/resolv/Makefile
|
|
index 567f4c2dcf5749df..0b4fa30716af3b8a 100644
|
|
--- a/resolv/Makefile
|
|
+++ b/resolv/Makefile
|
|
@@ -46,6 +46,7 @@ routines := \
|
|
ns_name_skip \
|
|
ns_name_uncompress \
|
|
ns_name_unpack \
|
|
+ ns_samebinaryname \
|
|
ns_samename \
|
|
nsap_addr \
|
|
nss_dns_functions \
|
|
@@ -107,6 +108,10 @@ tests += \
|
|
tests-internal += tst-resolv-txnid-collision
|
|
tests-static += tst-resolv-txnid-collision
|
|
|
|
+# Likewise for __ns_samebinaryname.
|
|
+tests-internal += tst-ns_samebinaryname
|
|
+tests-static += tst-ns_samebinaryname
|
|
+
|
|
# These tests need libdl.
|
|
ifeq (yes,$(build-shared))
|
|
tests += \
|
|
diff --git a/resolv/ns_samebinaryname.c b/resolv/ns_samebinaryname.c
|
|
new file mode 100644
|
|
index 0000000000000000..9a47d8e97a84c759
|
|
--- /dev/null
|
|
+++ b/resolv/ns_samebinaryname.c
|
|
@@ -0,0 +1,55 @@
|
|
+/* Compare two binary domain names for quality.
|
|
+ Copyright (C) 2022 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <arpa/nameser.h>
|
|
+#include <stdbool.h>
|
|
+
|
|
+/* Convert ASCII letters to upper case. */
|
|
+static inline int
|
|
+ascii_toupper (unsigned char ch)
|
|
+{
|
|
+ if (ch >= 'a' && ch <= 'z')
|
|
+ return ch - 'a' + 'A';
|
|
+ else
|
|
+ return ch;
|
|
+}
|
|
+
|
|
+bool
|
|
+__ns_samebinaryname (const unsigned char *a, const unsigned char *b)
|
|
+{
|
|
+ while (*a != 0 && *b != 0)
|
|
+ {
|
|
+ if (*a != *b)
|
|
+ /* Different label length. */
|
|
+ return false;
|
|
+ int labellen = *a;
|
|
+ ++a;
|
|
+ ++b;
|
|
+ for (int i = 0; i < labellen; ++i)
|
|
+ {
|
|
+ if (*a != *b && ascii_toupper (*a) != ascii_toupper (*b))
|
|
+ /* Different character in label. */
|
|
+ return false;
|
|
+ ++a;
|
|
+ ++b;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ /* Match if both names are at the root label. */
|
|
+ return *a == 0 && *b == 0;
|
|
+}
|
|
diff --git a/resolv/tst-ns_samebinaryname.c b/resolv/tst-ns_samebinaryname.c
|
|
new file mode 100644
|
|
index 0000000000000000..b06ac610b4cde8be
|
|
--- /dev/null
|
|
+++ b/resolv/tst-ns_samebinaryname.c
|
|
@@ -0,0 +1,62 @@
|
|
+/* Test the __ns_samebinaryname function.
|
|
+ Copyright (C) 2022 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <arpa/nameser.h>
|
|
+#include <array_length.h>
|
|
+#include <stdbool.h>
|
|
+#include <stdio.h>
|
|
+#include <support/check.h>
|
|
+
|
|
+/* First character denotes the comparison group: All names with the
|
|
+ same first character are expected to compare equal. */
|
|
+static const char *const cases[] =
|
|
+ {
|
|
+ " ",
|
|
+ "1\001a", "1\001A",
|
|
+ "2\002ab", "2\002aB", "2\002Ab", "2\002AB",
|
|
+ "3\001a\002ab", "3\001A\002ab",
|
|
+ "w\003www\007example\003com", "w\003Www\007Example\003Com",
|
|
+ "w\003WWW\007EXAMPLE\003COM",
|
|
+ "W\003WWW", "W\003www",
|
|
+ };
|
|
+
|
|
+static int
|
|
+do_test (void)
|
|
+{
|
|
+ for (int i = 0; i < array_length (cases); ++i)
|
|
+ for (int j = 0; j < array_length (cases); ++j)
|
|
+ {
|
|
+ unsigned char *a = (unsigned char *) &cases[i][1];
|
|
+ unsigned char *b = (unsigned char *) &cases[j][1];
|
|
+ bool actual = __ns_samebinaryname (a, b);
|
|
+ bool expected = cases[i][0] == cases[j][0];
|
|
+ if (actual != expected)
|
|
+ {
|
|
+ char a1[NS_MAXDNAME];
|
|
+ TEST_VERIFY (ns_name_ntop (a, a1, sizeof (a1)) > 0);
|
|
+ char b1[NS_MAXDNAME];
|
|
+ TEST_VERIFY (ns_name_ntop (b, b1, sizeof (b1)) > 0);
|
|
+ printf ("error: \"%s\" \"%s\": expected %s\n",
|
|
+ a1, b1, expected ? "equal" : "unqueal");
|
|
+ support_record_failure ();
|
|
+ }
|
|
+ }
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+#include <support/test-driver.c>
|