2a30b8f4b2
Upstream commit: dcaf51b41e259387602774829c45222d0507f90a - elf: Change ldconfig auxcache magic number (bug 32231) - Make tst-strtod-underflow type-generic - Add crt1-2.0.o for glibc 2.0 compatibility tests - Add tests of more strtod special cases - Add more tests of strtod end pointer - Make tst-strtod2 and tst-strtod5 type-generic - powerpc64le: Build new strtod tests with long double ABI flags (bug 32145) - Do not set errno for overflowing NaN payload in strtod/nan (bug 32045) - Improve NaN payload testing - Make __strtod_internal tests type-generic - Fix strtod subnormal rounding (bug 30220) - More thoroughly test underflow / errno in tst-strtod-round - Test errno setting on strtod overflow in tst-strtod-round - Add tests of fread - stdio-common: Add new test for fdopen - libio: Attempt wide backup free only for non-legacy code - debug: Fix read error handling in pcprofiledump - elf: Fix tst-dlopen-tlsreinit1.out test dependency - elf: Avoid re-initializing already allocated TLS in dlopen (bug 31717) - elf: Clarify and invert second argument of _dl_allocate_tls_init - elf: Support recursive use of dynamic TLS in interposed malloc - nptl: Use <support/check.h> facilities in tst-setuid3 - posix: Use <support/check.h> facilities in tst-truncate and tst-truncate64 - ungetc: Fix backup buffer leak on program exit [BZ #27821] - ungetc: Fix uninitialized read when putting into unused streams [BZ #27821] - Make tst-ungetc use libsupport - stdio-common: Add test for vfscanf with matches longer than INT_MAX [BZ #27650] - support: Add FAIL test failure helper - string: strerror, strsignal cannot use buffer after dlmopen (bug 32026) - Define __libc_initial for the static libc - x86: Fix bug in strchrnul-evex512 [BZ #32078] - Adjust check-local-headers test for libaudit 4.0 - x32/cet: Support shadow stack during startup for Linux 6.10 - x86-64: Remove sysdeps/x86_64/x32/dl-machine.h - support: Add options list terminator to the test driver - manual/stdio: Further clarify putc, putwc, getc, and getwc - Fix name space violation in fortify wrappers (bug 32052) - resolv: Fix tst-resolv-short-response for older GCC (bug 32042) - Add mremap tests - mremap: Update manual entry - linux: Update the mremap C implementation [BZ #31968] - Enhanced test coverage for strncmp, wcsncmp - Enhance test coverage for strnlen, wcsnlen Resolves: RHEL-57776 Resolves: RHEL-57777 Resolves: RHEL-61392
28 lines
1.2 KiB
Diff
28 lines
1.2 KiB
Diff
commit 7f5027995f45337a3fc4bb6d0b2039ee1e685f2e
|
|
Author: Florian Weimer <fweimer@redhat.com>
|
|
Date: Mon Sep 9 21:10:23 2024 +0200
|
|
|
|
elf: Fix tst-dlopen-tlsreinit1.out test dependency
|
|
|
|
Fixes commit 5097cd344fd243fb8deb6dec96e8073753f962f9
|
|
("elf: Avoid re-initializing already allocated TLS in dlopen
|
|
(bug 31717)").
|
|
|
|
Reported-by: Patsy Griffin <patsy@redhat.com>
|
|
Reviewed-by: Patsy Griffin <patsy@redhat.com>
|
|
(cherry picked from commit e82a7cb1622bff08d8e3a144d7c5516a088f1cbc)
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index a90305d39b68fb5e..8a5678aa63736812 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -3113,7 +3113,7 @@ $(objpfx)tst-dlopen-tlsreinit4: \
|
|
# tst-dlopen-tlsreinitmod3.so. The dependency is provided via
|
|
# $(objpfx)tst-dlopen-tlsreinitmod1.so.
|
|
tst-dlopen-tlsreinitmod2.so-no-z-defs = yes
|
|
-$(objpfx)tst-dlopen-tlsreinit.out: $(objpfx)tst-dlopen-tlsreinitmod1.so \
|
|
+$(objpfx)tst-dlopen-tlsreinit1.out: $(objpfx)tst-dlopen-tlsreinitmod1.so \
|
|
$(objpfx)tst-dlopen-tlsreinitmod2.so $(objpfx)tst-dlopen-tlsreinitmod3.so
|
|
# Reuse an audit module which provides ample debug logging.
|
|
$(objpfx)tst-dlopen-tlsreinit3.out: $(objpfx)tst-auditmod1.so
|