601650f878
* Tue May 31 2022 Arjun Shankar <arjun@redhat.com> - 2.34-35 - Sync with upstream branch release/2.34/master, commit ff450cdbdee0b8cb6b9d653d6d2fa892de29be31: - Fix deadlock when pthread_atfork handler calls pthread_atfork or dlclose - x86: Fallback {str|wcs}cmp RTM in the ncmp overflow case [BZ #29127] - string.h: fix __fortified_attr_access macro call [BZ #29162] - linux: Add a getauxval test [BZ #23293] - rtld: Use generic argv adjustment in ld.so [BZ #23293] - S390: Enable static PIE * Thu May 19 2022 Florian Weimer <fweimer@redhat.com> - 2.34-34 - Sync with upstream branch release/2.34/master, commit ede8d94d154157d269b18f3601440ac576c1f96a: - csu: Implement and use _dl_early_allocate during static startup - Linux: Introduce __brk_call for invoking the brk system call - Linux: Implement a useful version of _startup_fatal - ia64: Always define IA64_USE_NEW_STUB as a flag macro - Linux: Define MMAP_CALL_INTERNAL - i386: Honor I386_USE_SYSENTER for 6-argument Linux system calls - i386: Remove OPTIMIZE_FOR_GCC_5 from Linux libc-do-syscall.S - elf: Remove __libc_init_secure - Linux: Consolidate auxiliary vector parsing (redo) - Linux: Include <dl-auxv.h> in dl-sysdep.c only for SHARED - Revert "Linux: Consolidate auxiliary vector parsing" - Linux: Consolidate auxiliary vector parsing - Linux: Assume that NEED_DL_SYSINFO_DSO is always defined - Linux: Remove DL_FIND_ARG_COMPONENTS - Linux: Remove HAVE_AUX_SECURE, HAVE_AUX_XID, HAVE_AUX_PAGESIZE - elf: Merge dl-sysdep.c into the Linux version - elf: Remove unused NEED_DL_BASE_ADDR and _dl_base_addr - x86: Optimize {str|wcs}rchr-evex - x86: Optimize {str|wcs}rchr-avx2 - x86: Optimize {str|wcs}rchr-sse2 - x86: Cleanup page cross code in memcmp-avx2-movbe.S - x86: Remove memcmp-sse4.S - x86: Small improvements for wcslen - x86: Remove AVX str{n}casecmp - x86: Add EVEX optimized str{n}casecmp - x86: Add AVX2 optimized str{n}casecmp - x86: Optimize str{n}casecmp TOLOWER logic in strcmp-sse42.S - x86: Optimize str{n}casecmp TOLOWER logic in strcmp.S - x86: Remove strspn-sse2.S and use the generic implementation - x86: Remove strpbrk-sse2.S and use the generic implementation - x87: Remove strcspn-sse2.S and use the generic implementation - x86: Optimize strspn in strspn-c.c - x86: Optimize strcspn and strpbrk in strcspn-c.c - x86: Code cleanup in strchr-evex and comment justifying branch - x86: Code cleanup in strchr-avx2 and comment justifying branch - x86_64: Remove bcopy optimizations - x86-64: Remove bzero weak alias in SS2 memset - x86_64/multiarch: Sort sysdep_routines and put one entry per line - x86: Improve L to support L(XXX_SYMBOL (YYY, ZZZ)) - fortify: Ensure that __glibc_fortify condition is a constant [BZ #29141] * Thu May 12 2022 Florian Weimer <fweimer@redhat.com> - 2.34-33 - Sync with upstream branch release/2.34/master, commit 91c2e6c3db44297bf4cb3a2e3c40236c5b6a0b23: - dlfcn: Implement the RTLD_DI_PHDR request type for dlinfo - manual: Document the dlinfo function - x86: Fix fallback for wcsncmp_avx2 in strcmp-avx2.S [BZ #28896] - x86: Fix bug in strncmp-evex and strncmp-avx2 [BZ #28895] - x86: Set .text section in memset-vec-unaligned-erms - x86-64: Optimize bzero - x86: Remove SSSE3 instruction for broadcast in memset.S (SSE2 Only) - x86: Improve vec generation in memset-vec-unaligned-erms.S - x86-64: Fix strcmp-evex.S - x86-64: Fix strcmp-avx2.S - x86: Optimize strcmp-evex.S - x86: Optimize strcmp-avx2.S - manual: Clarify that abbreviations of long options are allowed - Add HWCAP2_AFP, HWCAP2_RPRES from Linux 5.17 to AArch64 bits/hwcap.h - aarch64: Add HWCAP2_ECV from Linux 5.16 - Add SOL_MPTCP, SOL_MCTP from Linux 5.16 to bits/socket.h - Update kernel version to 5.17 in tst-mman-consts.py - Update kernel version to 5.16 in tst-mman-consts.py - Update syscall lists for Linux 5.17 - Add ARPHRD_CAN, ARPHRD_MCTP to net/if_arp.h - Update kernel version to 5.15 in tst-mman-consts.py - Add PF_MCTP, AF_MCTP from Linux 5.15 to bits/socket.h Resolves: #2091541
171 lines
6.1 KiB
Diff
171 lines
6.1 KiB
Diff
commit e4a2fb76efb45210c541ee3f8ef32f317783c3a8
|
|
Author: Florian Weimer <fweimer@redhat.com>
|
|
Date: Wed May 11 20:30:49 2022 +0200
|
|
|
|
manual: Document the dlinfo function
|
|
|
|
Reviewed-by: Carlos O'Donell <carlos@redhat.com>
|
|
Tested-by: Carlos O'Donell <carlos@rehdat.com>
|
|
(cherry picked from commit 93804a1ee084d4bdc620b2b9f91615c7da0fabe1)
|
|
|
|
Also includes partial backport of commit 5d28a8962dcb6ec056b81d730e
|
|
(the addition of manual/dynlink.texi).
|
|
|
|
diff --git a/manual/Makefile b/manual/Makefile
|
|
index e83444341e282916..31678681ef059e0f 100644
|
|
--- a/manual/Makefile
|
|
+++ b/manual/Makefile
|
|
@@ -39,7 +39,7 @@ chapters = $(addsuffix .texi, \
|
|
pipe socket terminal syslog math arith time \
|
|
resource setjmp signal startup process ipc job \
|
|
nss users sysinfo conf crypt debug threads \
|
|
- probes tunables)
|
|
+ dynlink probes tunables)
|
|
appendices = lang.texi header.texi install.texi maint.texi platform.texi \
|
|
contrib.texi
|
|
licenses = freemanuals.texi lgpl-2.1.texi fdl-1.3.texi
|
|
diff --git a/manual/dynlink.texi b/manual/dynlink.texi
|
|
new file mode 100644
|
|
index 0000000000000000..dbf3de11769d8e57
|
|
--- /dev/null
|
|
+++ b/manual/dynlink.texi
|
|
@@ -0,0 +1,100 @@
|
|
+@node Dynamic Linker
|
|
+@c @node Dynamic Linker, Internal Probes, Threads, Top
|
|
+@c %MENU% Loading programs and shared objects.
|
|
+@chapter Dynamic Linker
|
|
+@cindex dynamic linker
|
|
+@cindex dynamic loader
|
|
+
|
|
+The @dfn{dynamic linker} is responsible for loading dynamically linked
|
|
+programs and their dependencies (in the form of shared objects). The
|
|
+dynamic linker in @theglibc{} also supports loading shared objects (such
|
|
+as plugins) later at run time.
|
|
+
|
|
+Dynamic linkers are sometimes called @dfn{dynamic loaders}.
|
|
+
|
|
+@menu
|
|
+* Dynamic Linker Introspection:: Interfaces for querying mapping information.
|
|
+@end menu
|
|
+
|
|
+@node Dynamic Linker Introspection
|
|
+@section Dynamic Linker Introspection
|
|
+
|
|
+@Theglibc{} provides various functions for querying information from the
|
|
+dynamic linker.
|
|
+
|
|
+@deftypefun {int} dlinfo (void *@var{handle}, int @var{request}, void *@var{arg})
|
|
+@safety{@mtsafe{}@asunsafe{@asucorrupt{}}@acunsafe{@acucorrupt{}}}
|
|
+@standards{GNU, dlfcn.h}
|
|
+This function returns information about @var{handle} in the memory
|
|
+location @var{arg}, based on @var{request}. The @var{handle} argument
|
|
+must be a pointer returned by @code{dlopen} or @code{dlmopen}; it must
|
|
+not have been closed by @code{dlclose}.
|
|
+
|
|
+On success, @code{dlinfo} returns 0. If there is an error, the function
|
|
+returns @math{-1}, and @code{dlerror} can be used to obtain a
|
|
+corresponding error message.
|
|
+
|
|
+The following operations are defined for use with @var{request}:
|
|
+
|
|
+@vtable @code
|
|
+@item RTLD_DI_LINKMAP
|
|
+The corresponding @code{struct link_map} pointer for @var{handle} is
|
|
+written to @code{*@var{arg}}. The @var{arg} argument must be the
|
|
+address of an object of type @code{struct link_map *}.
|
|
+
|
|
+@item RTLD_DI_LMID
|
|
+The namespace identifier of @var{handle} is written to
|
|
+@code{*@var{arg}}. The @var{arg} argument must be the address of an
|
|
+object of type @code{Lmid_t}.
|
|
+
|
|
+@item RTLD_DI_ORIGIN
|
|
+The value of the @code{$ORIGIN} dynamic string token for @var{handle} is
|
|
+written to the character array starting at @var{arg} as a
|
|
+null-terminated string.
|
|
+
|
|
+This request type should not be used because it is prone to buffer
|
|
+overflows.
|
|
+
|
|
+@item RTLD_DI_SERINFO
|
|
+@itemx RTLD_DI_SERINFOSIZE
|
|
+These requests can be used to obtain search path information for
|
|
+@var{handle}. For both requests, @var{arg} must point to a
|
|
+@code{Dl_serinfo} object. The @code{RTLD_DI_SERINFOSIZE} request must
|
|
+be made first; it updates the @code{dls_size} and @code{dls_cnt} members
|
|
+of the @code{Dl_serinfo} object. The caller should then allocate memory
|
|
+to store at least @code{dls_size} bytes and pass that buffer to a
|
|
+@code{RTLD_DI_SERINFO} request. This second request fills the
|
|
+@code{dls_serpath} array. The number of array elements was returned in
|
|
+the @code{dls_cnt} member in the initial @code{RTLD_DI_SERINFOSIZE}
|
|
+request. The caller is responsible for freeing the allocated buffer.
|
|
+
|
|
+This interface is prone to buffer overflows in multi-threaded processes
|
|
+because the required size can change between the
|
|
+@code{RTLD_DI_SERINFOSIZE} and @code{RTLD_DI_SERINFO} requests.
|
|
+
|
|
+@item RTLD_DI_TLS_DATA
|
|
+This request writes the address of the TLS block (in the current thread)
|
|
+for the shared object identified by @var{handle} to @code{*@var{arg}}.
|
|
+The argument @var{arg} must be the address of an object of type
|
|
+@code{void *}. A null pointer is written if the object does not have
|
|
+any associated TLS block.
|
|
+
|
|
+@item RTLD_DI_TLS_MODID
|
|
+This request writes the TLS module ID for the shared object @var{handle}
|
|
+to @code{*@var{arg}}. The argument @var{arg} must be the address of an
|
|
+object of type @code{size_t}. The module ID is zero if the object
|
|
+does not have an associated TLS block.
|
|
+@end vtable
|
|
+
|
|
+The @code{dlinfo} function is a GNU extension.
|
|
+@end deftypefun
|
|
+
|
|
+@c FIXME these are undocumented:
|
|
+@c dladdr
|
|
+@c dladdr1
|
|
+@c dlclose
|
|
+@c dlerror
|
|
+@c dlmopen
|
|
+@c dlopen
|
|
+@c dlsym
|
|
+@c dlvsym
|
|
diff --git a/manual/libdl.texi b/manual/libdl.texi
|
|
deleted file mode 100644
|
|
index e3fe0452d9f41d47..0000000000000000
|
|
--- a/manual/libdl.texi
|
|
+++ /dev/null
|
|
@@ -1,10 +0,0 @@
|
|
-@c FIXME these are undocumented:
|
|
-@c dladdr
|
|
-@c dladdr1
|
|
-@c dlclose
|
|
-@c dlerror
|
|
-@c dlinfo
|
|
-@c dlmopen
|
|
-@c dlopen
|
|
-@c dlsym
|
|
-@c dlvsym
|
|
diff --git a/manual/probes.texi b/manual/probes.texi
|
|
index 4aae76b81921f347..ee019e651706f492 100644
|
|
--- a/manual/probes.texi
|
|
+++ b/manual/probes.texi
|
|
@@ -1,5 +1,5 @@
|
|
@node Internal Probes
|
|
-@c @node Internal Probes, Tunables, Threads, Top
|
|
+@c @node Internal Probes, Tunables, Dynamic Linker, Top
|
|
@c %MENU% Probes to monitor libc internal behavior
|
|
@chapter Internal probes
|
|
|
|
diff --git a/manual/threads.texi b/manual/threads.texi
|
|
index 06b6b277a1228af1..7f166bfa87e88c36 100644
|
|
--- a/manual/threads.texi
|
|
+++ b/manual/threads.texi
|
|
@@ -1,5 +1,5 @@
|
|
@node Threads
|
|
-@c @node Threads, Internal Probes, Debugging Support, Top
|
|
+@c @node Threads, Dynamic Linker, Debugging Support, Top
|
|
@c %MENU% Functions, constants, and data types for working with threads
|
|
@chapter Threads
|
|
@cindex threads
|