103 lines
3.6 KiB
Diff
103 lines
3.6 KiB
Diff
Backport of the test case from the upstream commit. Note
|
|
that the test fails in the version included here.
|
|
|
|
commit c980549cc6a1c03c23cc2fe3e7b0fe626a0364b0
|
|
Author: Carlos O'Donell <carlos@redhat.com>
|
|
Date: Thu Jan 19 12:50:20 2023 +0100
|
|
|
|
Account for grouping in printf width (bug 30068)
|
|
|
|
This is a partial fix for mishandling of grouping when formatting
|
|
integers. It properly computes the width in the presence of grouping
|
|
characters when the width is larger than the number of significant
|
|
digits. The precision related issue is documented in bug 23432.
|
|
|
|
Co-authored-by: Andreas Schwab <schwab@suse.de>
|
|
|
|
Conflicts:
|
|
stdio-common/Makefile
|
|
(missing tests downstream)
|
|
stdio-common/vfprintf-process-arg.c
|
|
(not included in backport)
|
|
|
|
diff --git a/stdio-common/Makefile b/stdio-common/Makefile
|
|
index e3939b112ca2037f..74e0edff73a9e468 100644
|
|
--- a/stdio-common/Makefile
|
|
+++ b/stdio-common/Makefile
|
|
@@ -222,6 +222,7 @@ tests := \
|
|
tst-gets \
|
|
tst-grouping \
|
|
tst-grouping2 \
|
|
+ tst-grouping3 \
|
|
tst-long-dbl-fphex \
|
|
tst-obprintf \
|
|
tst-perror \
|
|
@@ -375,6 +376,7 @@ $(objpfx)tst-sprintf.out: $(gen-locales)
|
|
$(objpfx)tst-sscanf.out: $(gen-locales)
|
|
$(objpfx)tst-swprintf.out: $(gen-locales)
|
|
$(objpfx)tst-vfprintf-mbs-prec.out: $(gen-locales)
|
|
+$(objpfx)tst-grouping3.out: $(gen-locales)
|
|
endif
|
|
|
|
tst-printf-bz18872-ENV = MALLOC_TRACE=$(objpfx)tst-printf-bz18872.mtrace \
|
|
diff --git a/stdio-common/tst-grouping3.c b/stdio-common/tst-grouping3.c
|
|
new file mode 100644
|
|
index 0000000000000000..e9e39218e25a2720
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-grouping3.c
|
|
@@ -0,0 +1,54 @@
|
|
+/* Test printf with grouping and padding (bug 30068)
|
|
+ Copyright (C) 2023 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <locale.h>
|
|
+#include <stdio.h>
|
|
+#include <support/check.h>
|
|
+#include <support/support.h>
|
|
+
|
|
+static int
|
|
+do_test (void)
|
|
+{
|
|
+ char buf[80];
|
|
+
|
|
+ xsetlocale (LC_NUMERIC, "de_DE.UTF-8");
|
|
+
|
|
+ /* The format string has the following conversion specifier:
|
|
+ ' - Use thousands grouping.
|
|
+ + - The result of a signed conversion shall begin with a sign.
|
|
+ - - Left justified.
|
|
+ 13 - Minimum 13 bytes of width.
|
|
+ 9 - Minimum 9 digits of precision.
|
|
+
|
|
+ In bug 30068 the grouping characters were not accounted for in
|
|
+ the width, and were added after the fact resulting in a 15-byte
|
|
+ output instead of a 13-byte output. The two additional bytes
|
|
+ come from the locale-specific thousands separator. This increase
|
|
+ in size could result in a buffer overflow if a reasonable caller
|
|
+ calculated the size of the expected buffer using nl_langinfo to
|
|
+ determine the sie of THOUSEP in bytes.
|
|
+
|
|
+ This bug is distinct from bug 23432 which has to do with the
|
|
+ minimum precision calculation (digit based). */
|
|
+ sprintf (buf, "%+-'13.9d", 1234567);
|
|
+ TEST_COMPARE_STRING (buf, "+001.234.567 ");
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+#include <support/test-driver.c>
|