glibc/glibc-upstream-2.39-84.patch
Arjun Shankar 2118accf25 Sync with glibc-2.39-22.fc40 (RHEL-45522)
Resolves: RHEL-45522

Fedora 40 commit: 9404e14f4d
Upstream commit: 4bdcc1963bc2b5ba5f8e319e402d9eb2cb6096c1

Fedora 40 changes:

- Backport /etc/resolv.conf enhancements to thelp with RHEL-18039 testing

Related: RHEL-50663

- Support --without testsuite builds without perl installed (#2292195)
- Use release instead of baserelease for glibc32 conflict
- Add Conflicts:/Obsoletes: for glibc32 to glibc.i686

- ppc64le: Build early startup code with -mcpu=power8

Resolves: RHEL-43456

- Move ANSI_X3.110-1983 support from main package to glibc-gconv-extra.

Resolves: RHEL-41206

Upstream changes:

- manual: make setrlimit() description less ambiguous
- manual/stdio: Clarify putc and putwc
- malloc: add multi-threaded tests for aligned_alloc/calloc/malloc
- malloc: avoid global locks in tst-aligned_alloc-lib.c

- resolv: Track single-request fallback via _res._flags (bug 31476)
- resolv: Do not wait for non-existing second DNS response after error (bug 30081)
- resolv: Allow short error responses to match any query (bug 31890)

Resolves: RHEL-50663

- elf: Fix localplt.awk for DT_RELR-enabled builds (BZ 31978)
- Fix usage of _STACK_GROWS_DOWN and _STACK_GROWS_UP defines [BZ 31989]
- Linux: Make __rseq_size useful for feature detection (bug 31965)
- elf: Make dl-rseq-symbols Linux only
- nptl: fix potential merge of __rseq_* relro symbols

- s390x: Fix segfault in wcsncmp [BZ #31934]

Resolves: RHEL-49488

- stdlib: fix arc4random fallback to /dev/urandom (BZ 31612)
- math: Provide missing math symbols on libc.a (BZ 31781)
- math: Fix isnanf128 static build (BZ 31774)
- math: Fix i386 and m68k exp10 on static build (BZ 31775)
- math: Fix i386 and m68k fmod/fmodf on static build (BZ 31488)
- posix: Fix pidfd_spawn/pidfd_spawnp leak if execve fails (BZ 31695)
2024-08-14 17:57:11 +02:00

44 lines
1.2 KiB
Diff

commit 143a7a06235cf091b63f58a739c8367ffe54a722
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
Date: Thu Jul 4 10:09:07 2024 -0300
elf: Make dl-rseq-symbols Linux only
And avoid a Hurd build failures.
Checked on x86_64-linux-gnu.
(cherry picked from commit 9fc639f654dc004736836613be703e6bed0c36a8)
diff --git a/elf/Makefile b/elf/Makefile
index 0049ffa13c8d3e51..a50a988e7362cf3b 100644
--- a/elf/Makefile
+++ b/elf/Makefile
@@ -73,7 +73,6 @@ dl-routines = \
dl-origin \
dl-printf \
dl-reloc \
- dl-rseq-symbols \
dl-runtime \
dl-scope \
dl-setup_hash \
diff --git a/sysdeps/unix/sysv/linux/Makefile b/sysdeps/unix/sysv/linux/Makefile
index 415aa1f14dd20ba6..6ab9b901234dc72e 100644
--- a/sysdeps/unix/sysv/linux/Makefile
+++ b/sysdeps/unix/sysv/linux/Makefile
@@ -615,6 +615,10 @@ tests += \
endif
ifeq ($(subdir),elf)
+dl-routines += \
+ dl-rseq-symbols \
+ # dl-routines
+
sysdep-rtld-routines += \
dl-brk \
dl-getcwd \
diff --git a/elf/dl-rseq-symbols.S b/sysdeps/unix/sysv/linux/dl-rseq-symbols.S
similarity index 100%
rename from elf/dl-rseq-symbols.S
rename to sysdeps/unix/sysv/linux/dl-rseq-symbols.S