glibc/glibc-upstream-2.39-29.patch
Arjun Shankar b88a2e4886 Sync with upstream branch release/2.39/master (RHEL-31801)
Upstream commit: 31da30f23cddd36db29d5b6a1c7619361b271fb4

- iconv: ISO-2022-CN-EXT: fix out-of-bound writes when writing escape sequence (CVE-2024-2961)

Resolves: RHEL-31801

- x86_64: Exclude SSE, AVX and FMA4 variants in libm multiarch
- Apply the Makefile sorting fix
- powerpc: Fix ld.so address determination for PCREL mode (bug 31640)
- x86-64: Simplify minimum ISA check ifdef conditional with if
- x86-64: Don't use SSE resolvers for ISA level 3 or above
- AArch64: Check kernel version for SVE ifuncs
- aarch64: fix check for SVE support in assembler
- aarch64/fpu: Sync libmvec routines from 2.39 and before with AOR
- i386: Use generic memrchr in libc (bug 31316)

Related: RHEL-35602

Fedora 40 commit: 1bea1361dc740cb07eff8eace4f58619cf8f4fe4
2024-06-07 16:25:50 +02:00

247 lines
5.9 KiB
Diff

commit 04df8652eb1919da18d54b3dcd6db1675993d45d
Author: H.J. Lu <hjl.tools@gmail.com>
Date: Thu Feb 15 11:19:56 2024 -0800
Apply the Makefile sorting fix
Apply the Makefile sorting fix generated by sort-makefile-lines.py.
(cherry picked from commit ef7f4b1fef67430a8f3cfc77fa6aada2add851d7)
diff --git a/sysdeps/loongarch/lp64/multiarch/Makefile b/sysdeps/loongarch/lp64/multiarch/Makefile
index fe863e1ba411cc4b..01762ef526854d54 100644
--- a/sysdeps/loongarch/lp64/multiarch/Makefile
+++ b/sysdeps/loongarch/lp64/multiarch/Makefile
@@ -1,52 +1,52 @@
ifeq ($(subdir),string)
sysdep_routines += \
- strlen-aligned \
- strlen-lsx \
- strlen-lasx \
- strnlen-aligned \
- strnlen-lsx \
- strnlen-lasx \
+ memchr-aligned \
+ memchr-lasx \
+ memchr-lsx \
+ memcmp-aligned \
+ memcmp-lasx \
+ memcmp-lsx \
+ memcpy-aligned \
+ memcpy-unaligned \
+ memmove-lasx \
+ memmove-lsx \
+ memmove-unaligned \
+ memrchr-generic \
+ memrchr-lasx \
+ memrchr-lsx \
+ memset-aligned \
+ memset-lasx \
+ memset-lsx \
+ memset-unaligned \
+ rawmemchr-aligned \
+ rawmemchr-lasx \
+ rawmemchr-lsx \
+ stpcpy-aligned \
+ stpcpy-lasx \
+ stpcpy-lsx \
+ stpcpy-unaligned \
strchr-aligned \
- strchr-lsx \
strchr-lasx \
- strrchr-aligned \
- strrchr-lsx \
- strrchr-lasx \
+ strchr-lsx \
strchrnul-aligned \
- strchrnul-lsx \
strchrnul-lasx \
+ strchrnul-lsx \
strcmp-aligned \
strcmp-lsx \
- strncmp-aligned \
- strncmp-lsx \
strcpy-aligned \
- strcpy-unaligned \
- strcpy-lsx \
strcpy-lasx \
- stpcpy-aligned \
- stpcpy-unaligned \
- stpcpy-lsx \
- stpcpy-lasx \
- memcpy-aligned \
- memcpy-unaligned \
- memmove-unaligned \
- memmove-lsx \
- memmove-lasx \
- rawmemchr-aligned \
- rawmemchr-lsx \
- rawmemchr-lasx \
- memchr-aligned \
- memchr-lsx \
- memchr-lasx \
- memrchr-generic \
- memrchr-lsx \
- memrchr-lasx \
- memset-aligned \
- memset-unaligned \
- memset-lsx \
- memset-lasx \
- memcmp-aligned \
- memcmp-lsx \
- memcmp-lasx \
+ strcpy-lsx \
+ strcpy-unaligned \
+ strlen-aligned \
+ strlen-lasx \
+ strlen-lsx \
+ strncmp-aligned \
+ strncmp-lsx \
+ strnlen-aligned \
+ strnlen-lasx \
+ strnlen-lsx \
+ strrchr-aligned \
+ strrchr-lasx \
+ strrchr-lsx \
# sysdep_routines
endif
diff --git a/sysdeps/x86/Makefile b/sysdeps/x86/Makefile
index 992aabe43ec60abf..5311b594aff62f7c 100644
--- a/sysdeps/x86/Makefile
+++ b/sysdeps/x86/Makefile
@@ -15,18 +15,18 @@ CFLAGS-dl-get-cpu-features.os += $(rtld-early-cflags)
CFLAGS-get-cpuid-feature-leaf.o += $(no-stack-protector)
tests += \
- tst-get-cpu-features \
- tst-get-cpu-features-static \
tst-cpu-features-cpuinfo \
tst-cpu-features-cpuinfo-static \
tst-cpu-features-supports \
tst-cpu-features-supports-static \
+ tst-get-cpu-features \
+ tst-get-cpu-features-static \
tst-hwcap-tunables \
# tests
tests-static += \
- tst-get-cpu-features-static \
tst-cpu-features-cpuinfo-static \
tst-cpu-features-supports-static \
+ tst-get-cpu-features-static \
# tests-static
ifeq (yes,$(have-ifunc))
ifeq (yes,$(have-gcc-ifunc))
diff --git a/sysdeps/x86_64/Makefile b/sysdeps/x86_64/Makefile
index 9d374a329916fc45..0ede447405d549b5 100644
--- a/sysdeps/x86_64/Makefile
+++ b/sysdeps/x86_64/Makefile
@@ -252,6 +252,10 @@ sysdep-dl-routines += dl-cet
tests += \
tst-cet-legacy-1 \
+ tst-cet-legacy-10 \
+ tst-cet-legacy-10-static \
+ tst-cet-legacy-10a \
+ tst-cet-legacy-10a-static \
tst-cet-legacy-1a \
tst-cet-legacy-2 \
tst-cet-legacy-2a \
@@ -263,15 +267,11 @@ tests += \
tst-cet-legacy-8 \
tst-cet-legacy-9 \
tst-cet-legacy-9-static \
- tst-cet-legacy-10 \
- tst-cet-legacy-10-static \
- tst-cet-legacy-10a \
- tst-cet-legacy-10a-static \
# tests
tests-static += \
- tst-cet-legacy-9-static \
tst-cet-legacy-10-static \
tst-cet-legacy-10a-static \
+ tst-cet-legacy-9-static \
# tests-static
tst-cet-legacy-1a-ARGS = -- $(host-test-program-cmd)
diff --git a/sysdeps/x86_64/fpu/multiarch/Makefile b/sysdeps/x86_64/fpu/multiarch/Makefile
index ea81753b708fcb8d..e1a490dd98b4be07 100644
--- a/sysdeps/x86_64/fpu/multiarch/Makefile
+++ b/sysdeps/x86_64/fpu/multiarch/Makefile
@@ -4,10 +4,10 @@ libm-sysdep_routines += \
s_ceilf-c \
s_floor-c \
s_floorf-c \
- s_rint-c \
- s_rintf-c \
s_nearbyint-c \
s_nearbyintf-c \
+ s_rint-c \
+ s_rintf-c \
s_roundeven-c \
s_roundevenf-c \
s_trunc-c \
@@ -21,10 +21,10 @@ libm-sysdep_routines += \
s_floorf-sse4_1 \
s_nearbyint-sse4_1 \
s_nearbyintf-sse4_1 \
- s_roundeven-sse4_1 \
- s_roundevenf-sse4_1 \
s_rint-sse4_1 \
s_rintf-sse4_1 \
+ s_roundeven-sse4_1 \
+ s_roundevenf-sse4_1 \
s_trunc-sse4_1 \
s_truncf-sse4_1 \
# libm-sysdep_routines
@@ -84,12 +84,12 @@ CFLAGS-s_cosf-fma.c = -mfma -mavx2
CFLAGS-s_sincosf-fma.c = -mfma -mavx2
libm-sysdep_routines += \
+ e_asin-fma4 \
+ e_atan2-fma4 \
e_exp-fma4 \
e_log-fma4 \
e_pow-fma4 \
- e_asin-fma4 \
s_atan-fma4 \
- e_atan2-fma4 \
s_sin-fma4 \
s_sincos-fma4 \
s_tan-fma4 \
@@ -106,10 +106,10 @@ CFLAGS-s_tan-fma4.c = -mfma4
CFLAGS-s_sincos-fma4.c = -mfma4
libm-sysdep_routines += \
+ e_atan2-avx \
e_exp-avx \
e_log-avx \
s_atan-avx \
- e_atan2-avx \
s_sin-avx \
s_sincos-avx \
s_tan-avx \
diff --git a/sysdeps/x86_64/multiarch/Makefile b/sysdeps/x86_64/multiarch/Makefile
index e1e894c963afb8b1..d3d2270394bd635d 100644
--- a/sysdeps/x86_64/multiarch/Makefile
+++ b/sysdeps/x86_64/multiarch/Makefile
@@ -4,8 +4,8 @@ sysdep_routines += \
memchr-avx2 \
memchr-avx2-rtm \
memchr-evex \
- memchr-evex512 \
memchr-evex-rtm \
+ memchr-evex512 \
memchr-sse2 \
memcmp-avx2-movbe \
memcmp-avx2-movbe-rtm \
@@ -37,8 +37,8 @@ sysdep_routines += \
rawmemchr-avx2 \
rawmemchr-avx2-rtm \
rawmemchr-evex \
- rawmemchr-evex512 \
rawmemchr-evex-rtm \
+ rawmemchr-evex512 \
rawmemchr-sse2 \
stpcpy-avx2 \
stpcpy-avx2-rtm \