2a30b8f4b2
Upstream commit: dcaf51b41e259387602774829c45222d0507f90a - elf: Change ldconfig auxcache magic number (bug 32231) - Make tst-strtod-underflow type-generic - Add crt1-2.0.o for glibc 2.0 compatibility tests - Add tests of more strtod special cases - Add more tests of strtod end pointer - Make tst-strtod2 and tst-strtod5 type-generic - powerpc64le: Build new strtod tests with long double ABI flags (bug 32145) - Do not set errno for overflowing NaN payload in strtod/nan (bug 32045) - Improve NaN payload testing - Make __strtod_internal tests type-generic - Fix strtod subnormal rounding (bug 30220) - More thoroughly test underflow / errno in tst-strtod-round - Test errno setting on strtod overflow in tst-strtod-round - Add tests of fread - stdio-common: Add new test for fdopen - libio: Attempt wide backup free only for non-legacy code - debug: Fix read error handling in pcprofiledump - elf: Fix tst-dlopen-tlsreinit1.out test dependency - elf: Avoid re-initializing already allocated TLS in dlopen (bug 31717) - elf: Clarify and invert second argument of _dl_allocate_tls_init - elf: Support recursive use of dynamic TLS in interposed malloc - nptl: Use <support/check.h> facilities in tst-setuid3 - posix: Use <support/check.h> facilities in tst-truncate and tst-truncate64 - ungetc: Fix backup buffer leak on program exit [BZ #27821] - ungetc: Fix uninitialized read when putting into unused streams [BZ #27821] - Make tst-ungetc use libsupport - stdio-common: Add test for vfscanf with matches longer than INT_MAX [BZ #27650] - support: Add FAIL test failure helper - string: strerror, strsignal cannot use buffer after dlmopen (bug 32026) - Define __libc_initial for the static libc - x86: Fix bug in strchrnul-evex512 [BZ #32078] - Adjust check-local-headers test for libaudit 4.0 - x32/cet: Support shadow stack during startup for Linux 6.10 - x86-64: Remove sysdeps/x86_64/x32/dl-machine.h - support: Add options list terminator to the test driver - manual/stdio: Further clarify putc, putwc, getc, and getwc - Fix name space violation in fortify wrappers (bug 32052) - resolv: Fix tst-resolv-short-response for older GCC (bug 32042) - Add mremap tests - mremap: Update manual entry - linux: Update the mremap C implementation [BZ #31968] - Enhanced test coverage for strncmp, wcsncmp - Enhance test coverage for strnlen, wcsnlen Resolves: RHEL-57776 Resolves: RHEL-57777 Resolves: RHEL-61392
150 lines
4.8 KiB
Diff
150 lines
4.8 KiB
Diff
commit 6624318c89185fe8b9d1f61e7a6841a843b8f9f3
|
|
Author: Joseph Myers <josmyers@redhat.com>
|
|
Date: Wed Sep 4 13:21:23 2024 +0000
|
|
|
|
Do not set errno for overflowing NaN payload in strtod/nan (bug 32045)
|
|
|
|
As reported in bug 32045, it's incorrect for strtod/nan functions to
|
|
set errno based on overflowing payload (strtod should only set errno
|
|
for overflow / underflow of its actual result, and potentially if
|
|
nothing in the string can be parsed as a number at all; nan should be
|
|
a pure function that never sets it). Save and restore errno around
|
|
the internal strtoull call and add associated test coverage.
|
|
|
|
Tested for x86_64.
|
|
|
|
(cherry picked from commit 64f62c47e9c350f353336f2df6714e1d48ec50d8)
|
|
|
|
diff --git a/math/Makefile b/math/Makefile
|
|
index 79ef4ebb65cd40ea..14107855e88bc96b 100644
|
|
--- a/math/Makefile
|
|
+++ b/math/Makefile
|
|
@@ -462,6 +462,7 @@ CFLAGS-test-flt-eval-method.c += -fexcess-precision=standard
|
|
CFLAGS-test-fe-snans-always-signal.c += $(config-cflags-signaling-nans)
|
|
|
|
CFLAGS-test-nan-const.c += -fno-builtin
|
|
+CFLAGS-test-nan-payload.c += -fno-builtin
|
|
|
|
include ../Rules
|
|
|
|
diff --git a/math/test-nan-payload.c b/math/test-nan-payload.c
|
|
index 55c13de14eb6a4d0..413791e09f8b348d 100644
|
|
--- a/math/test-nan-payload.c
|
|
+++ b/math/test-nan-payload.c
|
|
@@ -18,6 +18,7 @@
|
|
|
|
#define _LIBC_TEST 1
|
|
#define __STDC_WANT_IEC_60559_TYPES_EXT__
|
|
+#include <errno.h>
|
|
#include <float.h>
|
|
#include <math.h>
|
|
#include <stdio.h>
|
|
@@ -82,6 +83,26 @@
|
|
} \
|
|
while (0)
|
|
|
|
+#define CLEAR_ERRNO \
|
|
+ do \
|
|
+ { \
|
|
+ errno = 12345; \
|
|
+ } \
|
|
+ while (0)
|
|
+
|
|
+#define CHECK_ERRNO(TYPE, A) \
|
|
+ do \
|
|
+ { \
|
|
+ if (errno == 12345) \
|
|
+ puts ("PASS: " #TYPE " " #A " errno"); \
|
|
+ else \
|
|
+ { \
|
|
+ puts ("FAIL: " #TYPE " " #A " errno"); \
|
|
+ result = 1; \
|
|
+ } \
|
|
+ } \
|
|
+ while (0)
|
|
+
|
|
/* Cannot test payloads by memcmp for formats where NaNs have padding
|
|
bits. */
|
|
#define CAN_TEST_EQ(MANT_DIG) ((MANT_DIG) != 64 && (MANT_DIG) != 106)
|
|
@@ -89,26 +110,58 @@
|
|
#define RUN_TESTS(TYPE, SFUNC, FUNC, PLFUNC, MANT_DIG) \
|
|
do \
|
|
{ \
|
|
+ CLEAR_ERRNO; \
|
|
TYPE n123 = WRAP_NAN (FUNC, "123"); \
|
|
+ CHECK_ERRNO (TYPE, n123); \
|
|
CHECK_IS_NAN (TYPE, n123); \
|
|
+ CLEAR_ERRNO; \
|
|
TYPE s123 = WRAP_STRTO (SFUNC, "NAN(123)"); \
|
|
+ CHECK_ERRNO (TYPE, s123); \
|
|
CHECK_IS_NAN (TYPE, s123); \
|
|
+ CLEAR_ERRNO; \
|
|
TYPE n456 = WRAP_NAN (FUNC, "456"); \
|
|
+ CHECK_ERRNO (TYPE, n456); \
|
|
CHECK_IS_NAN (TYPE, n456); \
|
|
+ CLEAR_ERRNO; \
|
|
TYPE s456 = WRAP_STRTO (SFUNC, "NAN(456)"); \
|
|
+ CHECK_ERRNO (TYPE, s456); \
|
|
CHECK_IS_NAN (TYPE, s456); \
|
|
+ CLEAR_ERRNO; \
|
|
TYPE nh123 = WRAP_NAN (FUNC, "0x123"); \
|
|
+ CHECK_ERRNO (TYPE, nh123); \
|
|
CHECK_IS_NAN (TYPE, nh123); \
|
|
+ CLEAR_ERRNO; \
|
|
TYPE sh123 = WRAP_STRTO (SFUNC, "NAN(0x123)"); \
|
|
+ CHECK_ERRNO (TYPE, sh123); \
|
|
CHECK_IS_NAN (TYPE, sh123); \
|
|
+ CLEAR_ERRNO; \
|
|
TYPE n123x = WRAP_NAN (FUNC, "123)"); \
|
|
+ CHECK_ERRNO (TYPE, n123x); \
|
|
CHECK_IS_NAN (TYPE, n123x); \
|
|
+ CLEAR_ERRNO; \
|
|
TYPE nemp = WRAP_NAN (FUNC, ""); \
|
|
+ CHECK_ERRNO (TYPE, nemp); \
|
|
CHECK_IS_NAN (TYPE, nemp); \
|
|
+ CLEAR_ERRNO; \
|
|
TYPE semp = WRAP_STRTO (SFUNC, "NAN()"); \
|
|
+ CHECK_ERRNO (TYPE, semp); \
|
|
CHECK_IS_NAN (TYPE, semp); \
|
|
+ CLEAR_ERRNO; \
|
|
TYPE sx = WRAP_STRTO (SFUNC, "NAN"); \
|
|
+ CHECK_ERRNO (TYPE, sx); \
|
|
CHECK_IS_NAN (TYPE, sx); \
|
|
+ CLEAR_ERRNO; \
|
|
+ TYPE novf = WRAP_NAN (FUNC, "9999999999" \
|
|
+ "99999999999999999999" \
|
|
+ "9999999999"); \
|
|
+ CHECK_ERRNO (TYPE, novf); \
|
|
+ CHECK_IS_NAN (TYPE, novf); \
|
|
+ CLEAR_ERRNO; \
|
|
+ TYPE sovf = WRAP_STRTO (SFUNC, "NAN(9999999999" \
|
|
+ "99999999999999999999" \
|
|
+ "9999999999)"); \
|
|
+ CHECK_ERRNO (TYPE, sovf); \
|
|
+ CHECK_IS_NAN (TYPE, sovf); \
|
|
if (CAN_TEST_EQ (MANT_DIG)) \
|
|
CHECK_SAME_NAN (TYPE, n123, s123); \
|
|
CHECK_PAYLOAD (TYPE, PLFUNC, n123, 123); \
|
|
diff --git a/stdlib/strtod_nan_main.c b/stdlib/strtod_nan_main.c
|
|
index 4cb286d2b3fb0676..39fb7e9f75bc5dbd 100644
|
|
--- a/stdlib/strtod_nan_main.c
|
|
+++ b/stdlib/strtod_nan_main.c
|
|
@@ -16,6 +16,7 @@
|
|
License along with the GNU C Library; if not, see
|
|
<https://www.gnu.org/licenses/>. */
|
|
|
|
+#include <errno.h>
|
|
#include <ieee754.h>
|
|
#include <locale.h>
|
|
#include <math.h>
|
|
@@ -50,7 +51,9 @@ STRTOD_NAN (const STRING_TYPE *str, STRING_TYPE **endptr, STRING_TYPE endc)
|
|
STRING_TYPE *endp;
|
|
unsigned long long int mant;
|
|
|
|
+ int save_errno = errno;
|
|
mant = STRTOULL (str, &endp, 0);
|
|
+ __set_errno (save_errno);
|
|
if (endp == cp)
|
|
SET_NAN_PAYLOAD (retval, mant);
|
|
|