fb633eaa14
remaining patches into distinct patchfiles. Thanks to Dmitry V. Levin for identifying them! Drop ia64 specific patches and specfile fragments
37 lines
1.1 KiB
Diff
37 lines
1.1 KiB
Diff
From b82207b25ed05d2e31563859382036ec385fc650 Mon Sep 17 00:00:00 2001
|
|
From: Andreas Schwab <schwab@redhat.com>
|
|
Date: Mon, 21 Jun 2010 16:54:50 +0200
|
|
Subject: [PATCH] Workaround assembler bug sneaking in nopl
|
|
|
|
* sysdeps/i386/i686/Makefile: Don't pass -mtune to assembler.
|
|
|
|
---
|
|
ChangeLog | 4 ++++
|
|
sysdeps/i386/i686/Makefile | 16 ----------------
|
|
2 files changed, 4 insertions(+), 16 deletions(-)
|
|
|
|
diff --git a/sysdeps/i386/i686/Makefile b/sysdeps/i386/i686/Makefile
|
|
index e6b2924..dbcf1c3 100644
|
|
--- a/sysdeps/i386/i686/Makefile
|
|
+++ b/sysdeps/i386/i686/Makefile
|
|
@@ -9,19 +9,3 @@ stack-align-test-flags += -msse
|
|
ifeq ($(subdir),string)
|
|
sysdep_routines += cacheinfo
|
|
endif
|
|
-
|
|
-ifeq (yes,$(config-asflags-i686))
|
|
-CFLAGS-.o += -Wa,-mtune=i686
|
|
-CFLAGS-.os += -Wa,-mtune=i686
|
|
-CFLAGS-.op += -Wa,-mtune=i686
|
|
-CFLAGS-.og += -Wa,-mtune=i686
|
|
-CFLAGS-.ob += -Wa,-mtune=i686
|
|
-CFLAGS-.oS += -Wa,-mtune=i686
|
|
-
|
|
-ASFLAGS-.o += -Wa,-mtune=i686
|
|
-ASFLAGS-.os += -Wa,-mtune=i686
|
|
-ASFLAGS-.op += -Wa,-mtune=i686
|
|
-ASFLAGS-.og += -Wa,-mtune=i686
|
|
-ASFLAGS-.ob += -Wa,-mtune=i686
|
|
-ASFLAGS-.oS += -Wa,-mtune=i686
|
|
-endif
|