24af28d49b
Upstream commit: 5d070d12b3a52bc44dd1b71743abc4b6243862ae - x86: Expand the comment on when REP STOSB is used on memset - x86: Do not prefer ERMS for memset on Zen3+ - x86: Fix Zen3/Zen4 ERMS selection (BZ 30994) - Add tst-gnu2-tls2mod1 to test-internal-extras - elf: Enable TLS descriptor tests on aarch64 - arm: Update _dl_tlsdesc_dynamic to preserve caller-saved registers (BZ 31372) - Ignore undefined symbols for -mtls-dialect=gnu2 - x86-64: Allocate state buffer space for RDI, RSI and RBX - x86-64: Update _dl_tlsdesc_dynamic to preserve AMX registers - x86: Update _dl_tlsdesc_dynamic to preserve caller-saved registers - x86-64: Save APX registers in ld.so trampoline - LoongArch: Correct {__ieee754, _}_scalb -> {__ieee754, _}_scalbf - powerpc: Placeholder and infrastructure/build support to add Power11 related changes. - powerpc: Add HWCAP3/HWCAP4 data to TCB for Power Architecture.
25 lines
838 B
Diff
25 lines
838 B
Diff
commit 5a461f2949ded98d8211939f84988bc464c7b4fe
|
|
Author: Andreas Schwab <schwab@suse.de>
|
|
Date: Tue Mar 19 13:49:50 2024 +0100
|
|
|
|
Add tst-gnu2-tls2mod1 to test-internal-extras
|
|
|
|
That allows sysdeps/x86_64/tst-gnu2-tls2mod1.S to use internal headers.
|
|
|
|
Fixes: 717ebfa85c ("x86-64: Allocate state buffer space for RDI, RSI and RBX")
|
|
(cherry picked from commit fd7ee2e6c5eb49e4a630a9978b4d668bff6354ee)
|
|
|
|
diff --git a/sysdeps/x86_64/Makefile b/sysdeps/x86_64/Makefile
|
|
index e8babc9a4edbf90b..9d374a329916fc45 100644
|
|
--- a/sysdeps/x86_64/Makefile
|
|
+++ b/sysdeps/x86_64/Makefile
|
|
@@ -210,6 +210,8 @@ tst-plt-rewrite2-ENV = GLIBC_TUNABLES=glibc.cpu.plt_rewrite=2
|
|
$(objpfx)tst-plt-rewrite2: $(objpfx)tst-plt-rewritemod2.so
|
|
endif
|
|
|
|
+test-internal-extras += tst-gnu2-tls2mod1
|
|
+
|
|
endif # $(subdir) == elf
|
|
|
|
ifeq ($(subdir),csu)
|