9651e7c5de
Upstream commit: fd658f026f25cf59e8db243bc3b3e09cd5a20ba0
nscd is currently not build, so the security fixes below
are not relevant.
- elf: Also compile dl-misc.os with $(rtld-early-cflags)
- CVE-2024-33601, CVE-2024-33602: nscd: netgroup: Use two buffers in addgetnetgrentX (bug 31680)
- CVE-2024-33600: nscd: Avoid null pointer crashes after notfound response (bug 31678)
- CVE-2024-33600: nscd: Do not send missing not-found response in addgetnetgrentX (bug 31678)
- CVE-2024-33599: nscd: Stack-based buffer overflow in netgroup cache (bug 31677)
- x86: Define MINIMUM_X86_ISA_LEVEL in config.h [BZ #31676]
Related: RHEL-31738
- i386: ulp update for SSE2 --disable-multi-arch configurations
- nptl: Fix tst-cancel30 on kernels without ppoll_time64 support
Related: RHEL-35602
Fedora 40 commit: 94914be52f
50 lines
2.1 KiB
Diff
50 lines
2.1 KiB
Diff
commit fd658f026f25cf59e8db243bc3b3e09cd5a20ba0
|
|
Author: H.J. Lu <hjl.tools@gmail.com>
|
|
Date: Thu Apr 25 08:06:52 2024 -0700
|
|
|
|
elf: Also compile dl-misc.os with $(rtld-early-cflags)
|
|
|
|
Also compile dl-misc.os with $(rtld-early-cflags) to avoid
|
|
|
|
Program received signal SIGILL, Illegal instruction.
|
|
0x00007ffff7fd36ea in _dl_strtoul (nptr=nptr@entry=0x7fffffffe2c9 "2",
|
|
endptr=endptr@entry=0x7fffffffd728) at dl-misc.c:156
|
|
156 bool positive = true;
|
|
(gdb) bt
|
|
#0 0x00007ffff7fd36ea in _dl_strtoul (nptr=nptr@entry=0x7fffffffe2c9 "2",
|
|
endptr=endptr@entry=0x7fffffffd728) at dl-misc.c:156
|
|
#1 0x00007ffff7fdb1a9 in tunable_initialize (
|
|
cur=cur@entry=0x7ffff7ffbc00 <tunable_list+2176>,
|
|
strval=strval@entry=0x7fffffffe2c9 "2", len=len@entry=1)
|
|
at dl-tunables.c:131
|
|
#2 0x00007ffff7fdb3a2 in parse_tunables (valstring=<optimized out>)
|
|
at dl-tunables.c:258
|
|
#3 0x00007ffff7fdb5d9 in __GI___tunables_init (envp=0x7fffffffdd58)
|
|
at dl-tunables.c:288
|
|
#4 0x00007ffff7fe44c3 in _dl_sysdep_start (
|
|
start_argptr=start_argptr@entry=0x7fffffffdcb0,
|
|
dl_main=dl_main@entry=0x7ffff7fe5f80 <dl_main>)
|
|
at ../sysdeps/unix/sysv/linux/dl-sysdep.c:110
|
|
#5 0x00007ffff7fe5cae in _dl_start_final (arg=0x7fffffffdcb0) at rtld.c:494
|
|
#6 _dl_start (arg=0x7fffffffdcb0) at rtld.c:581
|
|
#7 0x00007ffff7fe4b38 in _start ()
|
|
(gdb)
|
|
|
|
when setting GLIBC_TUNABLES in glibc compiled with APX.
|
|
Reviewed-by: Florian Weimer <fweimer@redhat.com>
|
|
|
|
(cherry picked from commit 049b7684c912dd32b67b1b15b0f43bf07d5f512e)
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index 69aa423c4b90127d..a50a988e7362cf3b 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -170,6 +170,7 @@ CFLAGS-.op += $(call elide-stack-protector,.op,$(elide-routines.os))
|
|
CFLAGS-.os += $(call elide-stack-protector,.os,$(all-rtld-routines))
|
|
|
|
# Add the requested compiler flags to the early startup code.
|
|
+CFLAGS-dl-misc.os += $(rtld-early-cflags)
|
|
CFLAGS-dl-printf.os += $(rtld-early-cflags)
|
|
CFLAGS-dl-setup_hash.os += $(rtld-early-cflags)
|
|
CFLAGS-dl-sysdep.os += $(rtld-early-cflags)
|