16 lines
462 B
Diff
16 lines
462 B
Diff
diff --git a/sysdeps/pthread/Makefile b/sysdeps/pthread/Makefile
|
|
index 1080dc9..af1a44d 100644
|
|
--- a/sysdeps/pthread/Makefile
|
|
+++ b/sysdeps/pthread/Makefile
|
|
@@ -16,8 +16,10 @@
|
|
# License along with the GNU C Library; if not, see
|
|
# <http://www.gnu.org/licenses/>.
|
|
|
|
+ifeq ($(subdir),rt)
|
|
ifeq (yes,$(build-shared))
|
|
$(objpfx)tst-timer: $(objpfx)librt.so $(shared-thread-library)
|
|
else
|
|
$(objpfx)tst-timer: $(objpfx)librt.a $(static-thread-library)
|
|
endif
|
|
+endif
|