42 lines
1.2 KiB
Diff
42 lines
1.2 KiB
Diff
diff --git a/Makefile.in b/Makefile.in
|
||
index 710ce7e..3fe9e73 100644
|
||
--- a/Makefile.in
|
||
+++ b/Makefile.in
|
||
@@ -12,7 +12,7 @@ install:
|
||
LC_ALL=C; export LC_ALL; \
|
||
$(MAKE) -r PARALLELMFLAGS="$(PARALLELMFLAGS)" -C $(srcdir) objdir=`pwd` $@
|
||
|
||
-bench bench-clean:
|
||
+bench bench-clean bench-build:
|
||
$(MAKE) -C $(srcdir)/benchtests $(PARALLELMFLAGS) objdir=`pwd` $@
|
||
|
||
# Convenience target to rebuild ULPs for all math tests.
|
||
diff --git a/Rules b/Rules
|
||
index 4f9cdf3..42d0368 100644
|
||
--- a/Rules
|
||
+++ b/Rules
|
||
@@ -83,7 +83,7 @@ common-generated += dummy.o dummy.c
|
||
|
||
# This makes all the auxiliary and test programs.
|
||
|
||
-.PHONY: others tests bench
|
||
+.PHONY: others tests bench bench-build
|
||
|
||
ifeq ($(build-programs),yes)
|
||
others: $(addprefix $(objpfx),$(others) $(sysdep-others) $(extra-objs))
|
||
diff --git a/benchtests/Makefile b/benchtests/Makefile
|
||
index fd3036d..7cbceaa 100644
|
||
--- a/benchtests/Makefile
|
||
+++ b/benchtests/Makefile
|
||
@@ -103,6 +103,10 @@ bench-clean:
|
||
|
||
bench: $(timing-type) $(gen-locales) bench-set bench-func bench-malloc
|
||
|
||
+bench-build: bench-set-build bench-func-build
|
||
+bench-set-build: $(binaries-benchset)
|
||
+bench-func-build: $(binaries-bench) $(binaries-bench-malloc)
|
||
+
|
||
bench-set: $(binaries-benchset)
|
||
for run in $^; do \
|
||
echo "Running $${run}"; \
|