0980ba190b
Upstream commit: 6b86036452b9ac47b4ee7789a50f2f37df7ecc4f - CVE-2017-15804: glob: Fix buffer overflow during GLOB_TILDE unescaping - powerpc: Use latest string function optimization for internal function calls - math: No _Float128 support for ppc64le -mlong-double-64 (swbz#22402) - tpi_PG locale: Fix wrong d_fmt - aarch64: Disable lazy symbol binding of TLSDESC - tpi_PG locale: fix syntax error (swbz#22382) - i586: Use conditional branches in strcpy.S (swbz#22353) - ffsl, ffsll: Declare under __USE_MISC, not just __USE_GNU - csb_PL locale: Fix abmon/mon for March (swbz#19485) - locale: Various yesstr/nostr/yesexpr/noexpr fixes (swbz#15260, swbz#15261) - localedef: Add --no-warnings/--warnings option - powerpc: Replace lxvd2x/stxvd2x with lvx/stvx in P7's memcpy/memmove - locale: Use ASCII as much as possible in LC_MESSAGES - Add new locale yuw_PG (swbz#20952) - malloc: Add single-threaded path to malloc/realloc/calloc/memalloc - i386: Replace assembly versions of e_powf with generic e_powf.c - i386: Replace assembly versions of e_log2f with generic e_log2f.c - x86-64: Add powf with FMA - x86-64: Add logf with FMA - i386: Replace assembly versions of e_logf with generic e_logf.c - i386: Replace assembly versions of e_exp2f with generic e_exp2f.c - x86-64: Add exp2f with FMA - i386: Replace assembly versions of e_expf with generic e_expf.c
13 lines
520 B
Diff
13 lines
520 B
Diff
diff --git a/localedata/Makefile b/localedata/Makefile
|
|
index a5f3c92d58954dfc..56719c7c714aa0f1 100644
|
|
--- a/localedata/Makefile
|
|
+++ b/localedata/Makefile
|
|
@@ -218,6 +218,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
|
|
echo -n '...'; \
|
|
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
|
|
$(LOCALEDEF) $$flags --alias-file=../intl/locale.alias \
|
|
+ --no-archive \
|
|
-i locales/$$input -f charmaps/$$charset \
|
|
$(addprefix --prefix=,$(install_root)) $$locale \
|
|
&& echo ' done'; \
|