73667d0be6
* Thu Apr 28 2022 Carlos O'Donell <carlos@redhat.com> - 2.34-32 - Sync with upstream branch release/2.34/master, commit c66c92181ddbd82306537a608e8c0282587131de: - posix/glob.c: update from gnulib (BZ#25659) - linux: Fix fchmodat with AT_SYMLINK_NOFOLLOW for 64 bit time_t (BZ#29097) * Wed Apr 27 2022 Carlos O'Donell <carlos@redhat.com> - 2.34-31 - Sync with upstream branch release/2.34/master, commit 55640ed3fde48360a8e8083be4843bd2dc7cecfe: - i386: Regenerate ulps - linux: Fix missing internal 64 bit time_t stat usage - x86: Optimize L(less_vec) case in memcmp-evex-movbe.S - x86: Don't set Prefer_No_AVX512 for processors with AVX512 and AVX-VNNI - x86-64: Use notl in EVEX strcmp [BZ #28646] - x86: Shrink memcmp-sse4.S code size - x86: Double size of ERMS rep_movsb_threshold in dl-cacheinfo.h - x86: Optimize memmove-vec-unaligned-erms.S - x86-64: Replace movzx with movzbl - x86-64: Remove Prefer_AVX2_STRCMP - x86-64: Improve EVEX strcmp with masked load - x86: Replace sse2 instructions with avx in memcmp-evex-movbe.S - x86: Optimize memset-vec-unaligned-erms.S - x86: Optimize memcmp-evex-movbe.S for frontend behavior and size - x86: Modify ENTRY in sysdep.h so that p2align can be specified - x86-64: Optimize load of all bits set into ZMM register [BZ #28252] - scripts/glibcelf.py: Mark as UNSUPPORTED on Python 3.5 and earlier - dlfcn: Do not use rtld_active () to determine ld.so state (bug 29078) - INSTALL: Rephrase -with-default-link documentation - misc: Fix rare fortify crash on wchar funcs. [BZ 29030] - Default to --with-default-link=no (bug 25812) - scripts: Add glibcelf.py module * Thu Apr 21 2022 Carlos O'Donell <carlos@redhat.com> - 2.34-30 - Sync with upstream branch release/2.34/master, commit 71326f1f2fd09dafb9c34404765fb88129e94237: - nptl: Fix pthread_cancel cancelhandling atomic operations - mips: Fix mips64n32 64 bit time_t stat support (BZ#29069) - hurd: Fix arbitrary error code - nptl: Handle spurious EINTR when thread cancellation is disabled (BZ#29029) - S390: Add new s390 platform z16. - NEWS: Update fixed bug list for LD_AUDIT backports. - hppa: Fix bind-now audit (BZ #28857) - elf: Replace tst-audit24bmod2.so with tst-audit24bmod2 - Fix elf/tst-audit25a with default bind now toolchains - elf: Fix runtime linker auditing on aarch64 (BZ #26643) - elf: Issue la_symbind for bind-now (BZ #23734) - elf: Fix initial-exec TLS access on audit modules (BZ #28096) - elf: Add la_activity during application exit - elf: Do not fail for failed dlmopen on audit modules (BZ #28061) - elf: Issue audit la_objopen for vDSO - elf: Add audit tests for modules with TLSDESC - elf: Avoid unnecessary slowdown from profiling with audit (BZ#15533) - elf: Add _dl_audit_pltexit - elf: Add _dl_audit_pltenter - elf: Add _dl_audit_preinit - elf: Add _dl_audit_symbind_alt and _dl_audit_symbind - elf: Add _dl_audit_objclose - elf: Add _dl_audit_objsearch - elf: Add _dl_audit_activity_map and _dl_audit_activity_nsid - elf: Add _dl_audit_objopen - elf: Move la_activity (LA_ACT_ADD) after _dl_add_to_namespace_list() (BZ #28062) - elf: Move LAV_CURRENT to link_lavcurrent.h - elf: Fix elf_get_dynamic_info() for bootstrap - elf: Fix dynamic-link.h usage on rtld.c - elf: Fix elf_get_dynamic_info definition - elf: Avoid nested functions in the loader [BZ #27220] - powerpc: Delete unneeded ELF_MACHINE_BEFORE_RTLD_RELOC - hppa: Use END instead of PSEUDO_END in swapcontext.S - hppa: Implement swapcontext in assembler (bug 28960) Resolves: #2003291 Resolves: #2064181 Resolves: #2072328 Resolves: #2075713 Resolves: #2077838
115 lines
4.4 KiB
Diff
115 lines
4.4 KiB
Diff
commit 4dca2d3a7b43bf99bd6a567870a3144af4e763ef
|
|
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
Date: Fri Feb 4 15:54:59 2022 -0300
|
|
|
|
hppa: Fix bind-now audit (BZ #28857)
|
|
|
|
On hppa, a function pointer returned by la_symbind is actually a function
|
|
descriptor has the plabel bit set (bit 30). This must be cleared to get
|
|
the actual address of the descriptor. If the descriptor has been bound,
|
|
the first word of the descriptor is the physical address of theA function,
|
|
otherwise, the first word of the descriptor points to a trampoline in the
|
|
PLT.
|
|
|
|
This patch also adds a workaround on tests because on hppa (and it seems
|
|
to be the only ABI I have see it), some shared library adds a dynamic PLT
|
|
relocation to am empty symbol name:
|
|
|
|
$ readelf -r elf/tst-audit25mod1.so
|
|
[...]
|
|
Relocation section '.rela.plt' at offset 0x464 contains 6 entries:
|
|
Offset Info Type Sym.Value Sym. Name + Addend
|
|
00002008 00000081 R_PARISC_IPLT 508
|
|
[...]
|
|
|
|
It breaks some assumptions on the test, where a symbol with an empty
|
|
name ("") is passed on la_symbind.
|
|
|
|
Checked on x86_64-linux-gnu and hppa-linux-gnu.
|
|
|
|
(cherry picked from commit 9e94f57484a2aba0fe67ea2059b5843f651887c2)
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index 57059293d0bc86cb..3e17a0706f5ec2df 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -2116,7 +2116,7 @@ $(objpfx)tst-audit24c.out: $(objpfx)tst-auditmod24c.so
|
|
$(objpfx)tst-audit24c: $(objpfx)tst-audit24amod1.so \
|
|
$(objpfx)tst-audit24amod2.so
|
|
tst-audit24c-ENV = LD_BIND_NOW=1 LD_AUDIT=$(objpfx)tst-auditmod24c.so
|
|
-LDFLAGS-tst-audit24b = -Wl,-z,lazy
|
|
+LDFLAGS-tst-audit24c = -Wl,-z,lazy
|
|
|
|
$(objpfx)tst-audit24d.out: $(objpfx)tst-auditmod24d.so
|
|
$(objpfx)tst-audit24d: $(objpfx)tst-audit24dmod1.so \
|
|
diff --git a/elf/dl-audit.c b/elf/dl-audit.c
|
|
index 72a50717ef60a357..ec9b032eae37c103 100644
|
|
--- a/elf/dl-audit.c
|
|
+++ b/elf/dl-audit.c
|
|
@@ -257,7 +257,8 @@ _dl_audit_symbind (struct link_map *l, struct reloc_result *reloc_result,
|
|
reloc_result->flags = flags;
|
|
}
|
|
|
|
- DL_FIXUP_BINDNOW_RELOC (value, new_value, sym.st_value);
|
|
+ if (flags & LA_SYMB_ALTVALUE)
|
|
+ DL_FIXUP_BINDNOW_RELOC (value, new_value, sym.st_value);
|
|
}
|
|
|
|
void
|
|
diff --git a/elf/tst-auditmod24a.c b/elf/tst-auditmod24a.c
|
|
index d8e88f3984af1707..3075dfae2fd3d288 100644
|
|
--- a/elf/tst-auditmod24a.c
|
|
+++ b/elf/tst-auditmod24a.c
|
|
@@ -110,5 +110,7 @@ la_symbind32 (Elf32_Sym *sym, unsigned int ndx,
|
|
return sym->st_value;
|
|
}
|
|
|
|
- abort ();
|
|
+ if (symname[0] != '\0')
|
|
+ abort ();
|
|
+ return sym->st_value;
|
|
}
|
|
diff --git a/elf/tst-auditmod24d.c b/elf/tst-auditmod24d.c
|
|
index 8c803ecc0a48f21b..badc6be451ee0357 100644
|
|
--- a/elf/tst-auditmod24d.c
|
|
+++ b/elf/tst-auditmod24d.c
|
|
@@ -116,5 +116,7 @@ la_symbind32 (Elf32_Sym *sym, unsigned int ndx,
|
|
}
|
|
}
|
|
|
|
- abort ();
|
|
+ if (symname[0] != '\0')
|
|
+ abort ();
|
|
+ return sym->st_value;
|
|
}
|
|
diff --git a/elf/tst-auditmod25.c b/elf/tst-auditmod25.c
|
|
index 526f5c54bc2c3b8c..20640a8daf346b5f 100644
|
|
--- a/elf/tst-auditmod25.c
|
|
+++ b/elf/tst-auditmod25.c
|
|
@@ -72,7 +72,7 @@ la_symbind32 (Elf32_Sym *sym, unsigned int ndx,
|
|
unsigned int *flags, const char *symname)
|
|
#endif
|
|
{
|
|
- if (*refcook != -1 && *defcook != -1)
|
|
+ if (*refcook != -1 && *defcook != -1 && symname[0] != '\0')
|
|
fprintf (stderr, "la_symbind: %s %u\n", symname,
|
|
*flags & (LA_SYMB_NOPLTENTER | LA_SYMB_NOPLTEXIT) ? 1 : 0);
|
|
return sym->st_value;
|
|
diff --git a/sysdeps/hppa/dl-lookupcfg.h b/sysdeps/hppa/dl-lookupcfg.h
|
|
index f4f00714fa158e18..92fd0b7c844713ce 100644
|
|
--- a/sysdeps/hppa/dl-lookupcfg.h
|
|
+++ b/sysdeps/hppa/dl-lookupcfg.h
|
|
@@ -80,7 +80,9 @@ void attribute_hidden _dl_unmap (struct link_map *map);
|
|
/* Extract the code address from a fixup value */
|
|
#define DL_FIXUP_VALUE_CODE_ADDR(value) ((value).ip)
|
|
#define DL_FIXUP_VALUE_ADDR(value) ((uintptr_t) &(value))
|
|
-#define DL_FIXUP_ADDR_VALUE(addr) (*(struct fdesc *) (addr))
|
|
+/* Clear the plabel bit to get the actual address of the descriptor. */
|
|
+#define DL_FIXUP_ADDR_VALUE(addr) \
|
|
+ (*(DL_FIXUP_VALUE_TYPE *) ((uintptr_t) (addr) & ~2))
|
|
#define DL_FIXUP_BINDNOW_ADDR_VALUE(addr) (addr)
|
|
-#define DL_FIXUP_BINDNOW_RELOC(value, new_value, st_value) \
|
|
- (*value) = *(struct fdesc *) (st_value)
|
|
+#define DL_FIXUP_BINDNOW_RELOC(value, new_value, st_value) \
|
|
+ *(value) = *(DL_FIXUP_VALUE_TYPE *) ((uintptr_t) (new_value) & ~2)
|