fb633eaa14
remaining patches into distinct patchfiles. Thanks to Dmitry V. Levin for identifying them! Drop ia64 specific patches and specfile fragments
75 lines
2.1 KiB
Diff
75 lines
2.1 KiB
Diff
2004-11-26 Jakub Jelinek <jakub@redhat.com>
|
|
|
|
* posix/Makefile (generated: Add getconf.speclist.
|
|
($(inst_libexecdir)/getconf): Use getconf.speclist instead of
|
|
getconf output.
|
|
($(objpfx)getconf.speclist): New rule.
|
|
* posix/getconf.speclist.h: New file.
|
|
|
|
diff -Nrup a/posix/Makefile b/posix/Makefile
|
|
--- a/posix/Makefile 2012-06-05 07:42:49.000000000 -0600
|
|
+++ b/posix/Makefile 2012-06-07 12:15:21.820318664 -0600
|
|
@@ -305,15 +305,8 @@ $(inst_libexecdir)/getconf: $(inst_bindi
|
|
mv -f $@/$$spec.new $@/$$spec; \
|
|
done < $(objpfx)getconf.speclist
|
|
|
|
-$(objpfx)getconf.speclist: $(objpfx)getconf
|
|
-ifeq (no,$(cross-compiling))
|
|
- LC_ALL=C GETCONF_DIR=/dev/null \
|
|
- $(run-program-prefix) $< _POSIX_V7_WIDTH_RESTRICTED_ENVS > $@.new
|
|
- LC_ALL=C GETCONF_DIR=/dev/null \
|
|
- $(run-program-prefix) $< _POSIX_V6_WIDTH_RESTRICTED_ENVS >> $@.new
|
|
- LC_ALL=C GETCONF_DIR=/dev/null \
|
|
- $(run-program-prefix) $< _XBS5_WIDTH_RESTRICTED_ENVS >> $@.new
|
|
-else
|
|
- > $@.new
|
|
-endif
|
|
+$(objpfx)getconf.speclist: getconf.speclist.h
|
|
+ $(CC) -E $(CFLAGS) $(CPPFLAGS) $< \
|
|
+ | sed -n -e '/START_OF_STRINGS/,$${/\(POSIX_V[67]\|XBS5\)_/{s/^[^"]*"//;s/".*$$//;p}}' \
|
|
+ > $@.new
|
|
mv -f $@.new $@
|
|
diff -Nrup a/posix/getconf.speclist.h b/posix/getconf.speclist.h
|
|
--- a/posix/getconf.speclist.h 1969-12-31 17:00:00.000000000 -0700
|
|
+++ b/posix/getconf.speclist.h 2012-06-07 12:15:21.820318664 -0600
|
|
@@ -0,0 +1,39 @@
|
|
+#include <unistd.h>
|
|
+const char *START_OF_STRINGS =
|
|
+#if _POSIX_V7_ILP32_OFF32 == 1
|
|
+"POSIX_V7_ILP32_OFF32"
|
|
+#endif
|
|
+#if _POSIX_V7_ILP32_OFFBIG == 1
|
|
+"POSIX_V7_ILP32_OFFBIG"
|
|
+#endif
|
|
+#if _POSIX_V7_LP64_OFF64 == 1
|
|
+"POSIX_V7_LP64_OFF64"
|
|
+#endif
|
|
+#if _POSIX_V7_LPBIG_OFFBIG == 1
|
|
+"POSIX_V7_LPBIG_OFFBIG"
|
|
+#endif
|
|
+#if _POSIX_V6_ILP32_OFF32 == 1
|
|
+"POSIX_V6_ILP32_OFF32"
|
|
+#endif
|
|
+#if _POSIX_V6_ILP32_OFFBIG == 1
|
|
+"POSIX_V6_ILP32_OFFBIG"
|
|
+#endif
|
|
+#if _POSIX_V6_LP64_OFF64 == 1
|
|
+"POSIX_V6_LP64_OFF64"
|
|
+#endif
|
|
+#if _POSIX_V6_LPBIG_OFFBIG == 1
|
|
+"POSIX_V6_LPBIG_OFFBIG"
|
|
+#endif
|
|
+#if _XBS5_ILP32_OFF32 == 1
|
|
+"XBS5_ILP32_OFF32"
|
|
+#endif
|
|
+#if _XBS5_ILP32_OFFBIG == 1
|
|
+"XBS5_ILP32_OFFBIG"
|
|
+#endif
|
|
+#if _XBS5_LP64_OFF64 == 1
|
|
+"XBS5_LP64_OFF64"
|
|
+#endif
|
|
+#if _XBS5_LPBIG_OFFBIG == 1
|
|
+"XBS5_LPBIG_OFFBIG"
|
|
+#endif
|
|
+"";
|