459 lines
19 KiB
Diff
459 lines
19 KiB
Diff
commit 63c81fa0dbf741b33bbac03bf204d896ee8e4694
|
|
Author: Maciej W. Rozycki <macro@redhat.com>
|
|
Date: Fri Mar 28 12:35:52 2025 +0000
|
|
|
|
stdio-common: Add tests for formatted vscanf input specifiers
|
|
|
|
Wire vscanf into test infrastructure for formatted scanf input
|
|
specifiers.
|
|
|
|
Reviewed-by: Joseph Myers <josmyers@redhat.com>
|
|
|
|
diff --git a/stdio-common/Makefile b/stdio-common/Makefile
|
|
index 3e165685af09a1c3..3a09b5bfbc930b45 100644
|
|
--- a/stdio-common/Makefile
|
|
+++ b/stdio-common/Makefile
|
|
@@ -52,7 +52,7 @@ nonfmt-xprintf-stems := \
|
|
xprintf-stems := $(sort $(fmt-xprintf-stems) $(nonfmt-xprintf-stems))
|
|
|
|
# List of markers for scanf family function tests.
|
|
-xscanf-funcs := s f ss
|
|
+xscanf-funcs := s f ss v
|
|
|
|
# List of data types and formats for individual per-conversion scanf tests.
|
|
# Further conversions are provided by sysdeps.
|
|
diff --git a/stdio-common/tst-scanf-format-v-c.c b/stdio-common/tst-scanf-format-v-c.c
|
|
new file mode 100644
|
|
index 0000000000000000..0e2c000ce0218e92
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-c.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for the character conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-character.h"
|
|
+#include "tst-scanf-format-skeleton-c.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-char.c b/stdio-common/tst-scanf-format-v-char.c
|
|
new file mode 100644
|
|
index 0000000000000000..be3a56c663b457ee
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-char.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for signed char conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-integer.h"
|
|
+#include "tst-scanf-format-skeleton-char.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-double.c b/stdio-common/tst-scanf-format-v-double.c
|
|
new file mode 100644
|
|
index 0000000000000000..91886318e800f274
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-double.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for double conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-real.h"
|
|
+#include "tst-scanf-format-skeleton-double.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-float.c b/stdio-common/tst-scanf-format-v-float.c
|
|
new file mode 100644
|
|
index 0000000000000000..5d289d3e8be7a640
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-float.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for float conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-real.h"
|
|
+#include "tst-scanf-format-skeleton-float.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-int.c b/stdio-common/tst-scanf-format-v-int.c
|
|
new file mode 100644
|
|
index 0000000000000000..770a686bb1a355fa
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-int.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for int conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-integer.h"
|
|
+#include "tst-scanf-format-skeleton-int.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-ldouble.c b/stdio-common/tst-scanf-format-v-ldouble.c
|
|
new file mode 100644
|
|
index 0000000000000000..8215ea7ecb4f785a
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-ldouble.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for long double conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-real.h"
|
|
+#include "tst-scanf-format-skeleton-ldouble.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-llong.c b/stdio-common/tst-scanf-format-v-llong.c
|
|
new file mode 100644
|
|
index 0000000000000000..2a1ef02844fc7c27
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-llong.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for long long conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-integer.h"
|
|
+#include "tst-scanf-format-skeleton-llong.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-long.c b/stdio-common/tst-scanf-format-v-long.c
|
|
new file mode 100644
|
|
index 0000000000000000..8376032bd459d253
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-long.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for long conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-integer.h"
|
|
+#include "tst-scanf-format-skeleton-long.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-short.c b/stdio-common/tst-scanf-format-v-short.c
|
|
new file mode 100644
|
|
index 0000000000000000..23b9c568874d89bb
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-short.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for short int conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-integer.h"
|
|
+#include "tst-scanf-format-skeleton-short.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-uchar.c b/stdio-common/tst-scanf-format-v-uchar.c
|
|
new file mode 100644
|
|
index 0000000000000000..861db22fbafe508e
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-uchar.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for unsigned char conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-integer.h"
|
|
+#include "tst-scanf-format-skeleton-uchar.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-uint.c b/stdio-common/tst-scanf-format-v-uint.c
|
|
new file mode 100644
|
|
index 0000000000000000..30e58c591723d719
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-uint.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for unsigned int conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-integer.h"
|
|
+#include "tst-scanf-format-skeleton-uint.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-ullong.c b/stdio-common/tst-scanf-format-v-ullong.c
|
|
new file mode 100644
|
|
index 0000000000000000..ee2914d3e932e5cf
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-ullong.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for unsigned long long int conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-integer.h"
|
|
+#include "tst-scanf-format-skeleton-ullong.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-ulong.c b/stdio-common/tst-scanf-format-v-ulong.c
|
|
new file mode 100644
|
|
index 0000000000000000..f7864dd57636c6b2
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-ulong.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for unsigned long int conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-integer.h"
|
|
+#include "tst-scanf-format-skeleton-ulong.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v-ushort.c b/stdio-common/tst-scanf-format-v-ushort.c
|
|
new file mode 100644
|
|
index 0000000000000000..79ca16b4e8f953d0
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v-ushort.c
|
|
@@ -0,0 +1,22 @@
|
|
+/* Test for formatted 'vscanf' input for unsigned short int conversions.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include "tst-scanf-format-skeleton.h"
|
|
+#include "tst-scanf-format-v.h"
|
|
+#include "tst-scanf-format-integer.h"
|
|
+#include "tst-scanf-format-skeleton-ushort.c"
|
|
diff --git a/stdio-common/tst-scanf-format-v.h b/stdio-common/tst-scanf-format-v.h
|
|
new file mode 100644
|
|
index 0000000000000000..bf19877670d7aea3
|
|
--- /dev/null
|
|
+++ b/stdio-common/tst-scanf-format-v.h
|
|
@@ -0,0 +1,36 @@
|
|
+/* Test feature wrapper for formatted 'vscanf' input.
|
|
+ Copyright (C) 2025 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <stdarg.h>
|
|
+#include <stdio.h>
|
|
+
|
|
+static int
|
|
+scanf_under_test (const char *restrict fmt, ...)
|
|
+{
|
|
+ va_list ap;
|
|
+ int result;
|
|
+
|
|
+ va_start (ap, fmt);
|
|
+ result = vscanf (fmt, ap);
|
|
+ va_end (ap);
|
|
+ if (ferror (stdin))
|
|
+ result = INPUT_ERROR;
|
|
+ else if (result == EOF)
|
|
+ result = INPUT_EOF;
|
|
+ return result;
|
|
+}
|