c2879fd933
* Thu Jan 13 2022 Florian Weimer <fweimer@redhat.com> - 2.34-18 - Backport optimized ELF dependency sorting algorithm (#2032647) * Thu Jan 13 2022 Florian Weimer <fweimer@redhat.com> - 2.34-17 - Sync with upstream branch release/2.34/master, commit 2fe2af88abd13ae5636881da2e26f461ecb7dfb5 - i386: Remove broken CAN_USE_REGISTER_ASM_EBP (bug 28771) - Update syscall lists for Linux 5.15 - powerpc: Fix unrecognized instruction errors with recent GCC - timezone: test-case for BZ #28707 - timezone: handle truncated timezones from tzcode-2021d and later (BZ #28707) - Fix subscript error with odd TZif file [BZ #28338] - AArch64: Check for SVE in ifuncs [BZ #28744] - intl/plural.y: Avoid conflicting declarations of yyerror and yylex - Linux: Fix 32-bit vDSO for clock_gettime on powerpc32 - linux: Add sparck brk implementation - Update sparc libm-test-ulps - Update hppa libm-test-ulps - riscv: align stack before calling _dl_init [BZ #28703] - riscv: align stack in clone [BZ #28702] - powerpc64[le]: Allocate extra stack frame on syscall.S - elf: Fix tst-cpu-features-cpuinfo for KVM guests on some AMD systems [BZ #28704] - nss: Use "files dns" as the default for the hosts database (bug 28700) - arm: Guard ucontext _rtld_global_ro access by SHARED, not PIC macro - mips: increase stack alignment in clone to match the ABI - mips: align stack in clone [BZ #28223] Resolves: #2032647 Resolves: #2033649
46 lines
1.6 KiB
Diff
46 lines
1.6 KiB
Diff
commit 1f67d8286b5da9266a138198ef1f15c27cbb0010
|
|
Author: H.J. Lu <hjl.tools@gmail.com>
|
|
Date: Mon Nov 15 16:28:39 2021 -0800
|
|
|
|
elf: Use a temporary file to generate Makefile fragments [BZ #28550]
|
|
|
|
1. Use a temporary file to generate Makefile fragments for DSO sorting
|
|
tests and use -include on them.
|
|
2. Add Makefile fragments to postclean-generated so that a "make clean"
|
|
removes the autogenerated fragments and a subsequent "make" regenerates
|
|
them.
|
|
|
|
This partially fixes BZ #28550.
|
|
|
|
Reviewed-by: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index 02ee834fdaf00a26..535ba4260fb98e64 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -471,6 +471,7 @@ tests-special += $(objpfx)order-cmp.out $(objpfx)tst-array1-cmp.out \
|
|
$(objpfx)tst-unused-dep-cmp.out
|
|
endif
|
|
|
|
+ifndef avoid-generated
|
|
# DSO sorting tests:
|
|
# The dso-ordering-test.py script generates testcase source files in $(objpfx),
|
|
# creating a $(objpfx)<testcase-name>-dir for each testcase, and creates a
|
|
@@ -478,9 +479,14 @@ endif
|
|
define include_dsosort_tests
|
|
$(objpfx)$(1).generated-makefile: $(1)
|
|
$(PYTHON) $(..)scripts/dso-ordering-test.py \
|
|
- --description-file $$< --objpfx $(objpfx) --output-makefile $$@
|
|
-include $(objpfx)$(1).generated-makefile
|
|
+ --description-file $$< --objpfx $(objpfx) --output-makefile $$@T
|
|
+ mv $$@T $$@
|
|
+-include $(objpfx)$(1).generated-makefile
|
|
endef
|
|
+endif
|
|
+
|
|
+postclean-generated += $(objpfx)/dso-sort-tests-2.generated-makefile \
|
|
+ $(objpfx)/dso-sort-tests-2.generated-makefile
|
|
|
|
# Generate from each testcase description file
|
|
ifeq (yes,$(have-tunables))
|