83835daada
Fedora commit: 4f55bd2df5c705c99f21e1d35941843212b3e3a1 Related: #1945473 Resolves: #1945472 Resolves: #1915330
81 lines
2.6 KiB
Diff
81 lines
2.6 KiB
Diff
commit b5b4aa62c124cf5c6c8d7a520137acbc0f3dc525
|
|
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
Date: Fri Apr 9 10:02:30 2021 -0300
|
|
|
|
libsupport: Add support_select_modifies_timeout
|
|
|
|
It will be used on a select() test.
|
|
|
|
(cherry picked from commit 5628f103f5937611730845390928cb43ef716012)
|
|
|
|
diff --git a/support/Makefile b/support/Makefile
|
|
index bb9889efb4be3630..4fd76b0e5e4add3f 100644
|
|
--- a/support/Makefile
|
|
+++ b/support/Makefile
|
|
@@ -67,6 +67,7 @@ libsupport-routines = \
|
|
support_quote_string \
|
|
support_record_failure \
|
|
support_run_diff \
|
|
+ support_select_modifies_timeout \
|
|
support_set_small_thread_stack_size \
|
|
support_shared_allocate \
|
|
support_small_stack_thread_attribute \
|
|
diff --git a/support/support.h b/support/support.h
|
|
index 9cbc45572054fd90..9c9612644a70e46f 100644
|
|
--- a/support/support.h
|
|
+++ b/support/support.h
|
|
@@ -23,6 +23,7 @@
|
|
#ifndef SUPPORT_H
|
|
#define SUPPORT_H
|
|
|
|
+#include <stdbool.h>
|
|
#include <stddef.h>
|
|
#include <sys/cdefs.h>
|
|
/* For mode_t. */
|
|
@@ -129,6 +130,10 @@ extern void support_copy_file (const char *from, const char *to);
|
|
extern ssize_t support_copy_file_range (int, off64_t *, int, off64_t *,
|
|
size_t, unsigned int);
|
|
|
|
+/* Return true if select modify the timeout to reflect the amount of time
|
|
+ no slept. */
|
|
+extern bool support_select_modifies_timeout (void);
|
|
+
|
|
__END_DECLS
|
|
|
|
#endif /* SUPPORT_H */
|
|
diff --git a/support/support_select_modifies_timeout.c b/support/support_select_modifies_timeout.c
|
|
new file mode 100644
|
|
index 0000000000000000..653ea2cc9850b005
|
|
--- /dev/null
|
|
+++ b/support/support_select_modifies_timeout.c
|
|
@@ -0,0 +1,29 @@
|
|
+/* Return whether select modifies the timeout.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <support/support.h>
|
|
+
|
|
+bool
|
|
+support_select_modifies_timeout (void)
|
|
+{
|
|
+#ifdef __linux__
|
|
+ return true;
|
|
+#else
|
|
+ return false;
|
|
+#endif
|
|
+}
|