0bc968985e
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/glibc.git#df07cd507e60fb1effac0d28d1bb0137235725ee
78 lines
2.9 KiB
Diff
78 lines
2.9 KiB
Diff
commit dd8023c2ac0af28a6e391a2eb5038bb351694243
|
|
Author: Florian Weimer <fweimer@redhat.com>
|
|
Date: Mon Mar 15 10:33:43 2021 +0100
|
|
|
|
elf: ld.so --help calls _dl_init_paths without a main map [BZ #27577]
|
|
|
|
In this case, use the link map of the dynamic loader itself as
|
|
a replacement. This is more than just a hack: if we ever support
|
|
DT_RUNPATH/DT_RPATH for the dynamic loader, reporting it for
|
|
ld.so --help (without further command line arguments) would be the
|
|
right thing to do.
|
|
|
|
Fixes commit 332421312576bd7095e70589154af99b124dd2d1 ("elf: Always
|
|
set l in _dl_init_paths (bug 23462)").
|
|
|
|
(cherry picked from commit 4e6db99c665d3b82a70a3e218860ef087b1555b4)
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index 63da0ed64f6234a8..4b92f8b3054b556e 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -245,7 +245,7 @@ tests += $(tests-execstack-$(have-z-execstack))
|
|
ifeq ($(run-built-tests),yes)
|
|
tests-special += $(objpfx)tst-leaks1-mem.out \
|
|
$(objpfx)tst-leaks1-static-mem.out $(objpfx)noload-mem.out \
|
|
- $(objpfx)tst-ldconfig-X.out
|
|
+ $(objpfx)tst-ldconfig-X.out $(objpfx)tst-rtld-help.out
|
|
endif
|
|
tlsmod17a-suffixes = 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
|
|
tlsmod18a-suffixes = 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
|
|
@@ -433,7 +433,8 @@ endif
|
|
ifeq (yes,$(build-shared))
|
|
ifeq ($(run-built-tests),yes)
|
|
tests-special += $(objpfx)tst-pathopt.out $(objpfx)tst-rtld-load-self.out \
|
|
- $(objpfx)tst-rtld-preload.out $(objpfx)argv0test.out
|
|
+ $(objpfx)tst-rtld-preload.out $(objpfx)argv0test.out \
|
|
+ $(objpfx)tst-rtld-help.out
|
|
endif
|
|
tests-special += $(objpfx)check-textrel.out $(objpfx)check-execstack.out \
|
|
$(objpfx)check-wx-segment.out \
|
|
@@ -1908,3 +1909,16 @@ $(objpfx)list-tunables.out: tst-rtld-list-tunables.sh $(objpfx)ld.so
|
|
$(evaluate-test)
|
|
|
|
tst-dst-static-ENV = LD_LIBRARY_PATH='$$ORIGIN'
|
|
+
|
|
+$(objpfx)tst-rtld-help.out: $(objpfx)ld.so
|
|
+ $(test-wrapper) $(rtld-prefix) --help > $@; \
|
|
+ status=$$?; \
|
|
+ echo "info: ld.so exit status: $$status" >> $@; \
|
|
+ if ! grep -q 'Legacy HWCAP subdirectories under library search path directories' $@; then \
|
|
+ echo "error: missing subdirectory pattern" >> $@; \
|
|
+ if test $$status -eq 0; then \
|
|
+ status=1; \
|
|
+ fi; \
|
|
+ fi; \
|
|
+ (exit $$status); \
|
|
+ $(evaluate-test)
|
|
diff --git a/elf/dl-load.c b/elf/dl-load.c
|
|
index 376a2e64d6a33535..2f760503c5f117f8 100644
|
|
--- a/elf/dl-load.c
|
|
+++ b/elf/dl-load.c
|
|
@@ -758,8 +758,14 @@ _dl_init_paths (const char *llp, const char *source,
|
|
max_dirnamelen = SYSTEM_DIRS_MAX_LEN;
|
|
*aelem = NULL;
|
|
|
|
- /* This points to the map of the main object. */
|
|
+ /* This points to the map of the main object. If there is no main
|
|
+ object (e.g., under --help, use the dynamic loader itself as a
|
|
+ stand-in. */
|
|
l = GL(dl_ns)[LM_ID_BASE]._ns_loaded;
|
|
+#ifdef SHARED
|
|
+ if (l == NULL)
|
|
+ l = &GL (dl_rtld_map);
|
|
+#endif
|
|
assert (l->l_type != lt_loaded);
|
|
|
|
if (l->l_info[DT_RUNPATH])
|