5eec3980b9
Resolves: #2167811
128 lines
4.0 KiB
Diff
128 lines
4.0 KiB
Diff
commit 0b962177ee3b45cf775176eb454fcf6aa1b0f6e3
|
|
Author: Andreas Schwab <schwab@suse.de>
|
|
Date: Thu Jan 26 14:25:05 2023 +0100
|
|
|
|
Use 64-bit time_t interfaces in strftime and strptime (bug 30053)
|
|
|
|
Both functions use time_t only internally, so the ABI is not affected.
|
|
|
|
(cherry picked from commit 41349f6f67c83e7bafe49f985b56493d2c4c9c77)
|
|
|
|
diff --git a/time/Makefile b/time/Makefile
|
|
index 38e3a7f4c77ea27f..ef3bb767b825f76a 100644
|
|
--- a/time/Makefile
|
|
+++ b/time/Makefile
|
|
@@ -50,7 +50,7 @@ tests := test_time clocktest tst-posixtz tst-strptime tst_wcsftime \
|
|
tst-clock tst-clock2 tst-clock_nanosleep tst-cpuclock1 \
|
|
tst-adjtime tst-ctime tst-difftime tst-mktime4 tst-clock_settime \
|
|
tst-settimeofday tst-itimer tst-gmtime tst-timegm \
|
|
- tst-timespec_get tst-timespec_getres
|
|
+ tst-timespec_get tst-timespec_getres tst-strftime4
|
|
|
|
tests-time64 := \
|
|
tst-adjtime-time64 \
|
|
@@ -65,6 +65,7 @@ tests-time64 := \
|
|
tst-itimer-time64 \
|
|
tst-mktime4-time64 \
|
|
tst-settimeofday-time64 \
|
|
+ tst-strftime4-time64 \
|
|
tst-timegm-time64 \
|
|
tst-timespec_get-time64 \
|
|
tst-timespec_getres-time64 \
|
|
diff --git a/time/strftime_l.c b/time/strftime_l.c
|
|
index d8cde9c5a3af87c7..57abbaa571694505 100644
|
|
--- a/time/strftime_l.c
|
|
+++ b/time/strftime_l.c
|
|
@@ -159,6 +159,10 @@ extern char *tzname[];
|
|
#ifdef _LIBC
|
|
# define tzname __tzname
|
|
# define tzset __tzset
|
|
+
|
|
+# define time_t __time64_t
|
|
+# define __gmtime_r(t, tp) __gmtime64_r (t, tp)
|
|
+# define mktime(tp) __mktime64 (tp)
|
|
#endif
|
|
|
|
#if !HAVE_TM_GMTOFF
|
|
diff --git a/time/strptime_l.c b/time/strptime_l.c
|
|
index 02c5d63c798f9c13..39d1e59b0871f4b4 100644
|
|
--- a/time/strptime_l.c
|
|
+++ b/time/strptime_l.c
|
|
@@ -30,8 +30,10 @@
|
|
#ifdef _LIBC
|
|
# define HAVE_LOCALTIME_R 0
|
|
# include "../locale/localeinfo.h"
|
|
-#endif
|
|
|
|
+# define time_t __time64_t
|
|
+# define __localtime_r(t, tp) __localtime64_r (t, tp)
|
|
+#endif
|
|
|
|
#if ! HAVE_LOCALTIME_R && ! defined localtime_r
|
|
# ifdef _LIBC
|
|
diff --git a/time/tst-strftime4-time64.c b/time/tst-strftime4-time64.c
|
|
new file mode 100644
|
|
index 0000000000000000..4d47ee7d79f9e648
|
|
--- /dev/null
|
|
+++ b/time/tst-strftime4-time64.c
|
|
@@ -0,0 +1 @@
|
|
+#include "tst-strftime4.c"
|
|
diff --git a/time/tst-strftime4.c b/time/tst-strftime4.c
|
|
new file mode 100644
|
|
index 0000000000000000..659716d0fa4534ae
|
|
--- /dev/null
|
|
+++ b/time/tst-strftime4.c
|
|
@@ -0,0 +1,52 @@
|
|
+/* Test strftime and strptime after 2038-01-19 03:14:07 UTC (bug 30053).
|
|
+ Copyright (C) 2023 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <time.h>
|
|
+#include <stdlib.h>
|
|
+#include <stdio.h>
|
|
+#include <string.h>
|
|
+#include <support/check.h>
|
|
+
|
|
+static int
|
|
+do_test (void)
|
|
+{
|
|
+ TEST_VERIFY_EXIT (setenv ("TZ", "UTC0", 1) == 0);
|
|
+ tzset ();
|
|
+ if (sizeof (time_t) > 4)
|
|
+ {
|
|
+ time_t wrap = (time_t) 2147483648LL;
|
|
+ char buf[80];
|
|
+ struct tm *tm = gmtime (&wrap);
|
|
+ TEST_VERIFY_EXIT (tm != NULL);
|
|
+ TEST_VERIFY_EXIT (strftime (buf, sizeof buf, "%s", tm) > 0);
|
|
+ puts (buf);
|
|
+ TEST_VERIFY (strcmp (buf, "2147483648") == 0);
|
|
+
|
|
+ struct tm tm2;
|
|
+ char *p = strptime (buf, "%s", &tm2);
|
|
+ TEST_VERIFY_EXIT (p != NULL && *p == '\0');
|
|
+ time_t t = mktime (&tm2);
|
|
+ printf ("%lld\n", (long long) t);
|
|
+ TEST_VERIFY (t == wrap);
|
|
+ }
|
|
+ else
|
|
+ FAIL_UNSUPPORTED ("32-bit time_t");
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+#include <support/test-driver.c>
|