39 lines
1.3 KiB
Diff
39 lines
1.3 KiB
Diff
commit 15aebdbada54098787715448c94701f17033fc92
|
|
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
Date: Tue Mar 12 13:21:18 2024 -0300
|
|
|
|
Ignore undefined symbols for -mtls-dialect=gnu2
|
|
|
|
So it does not fail for arm config that defaults to -mtp=soft (which
|
|
issues a call to __aeabi_read_tp).
|
|
Reviewed-by: H.J. Lu <hjl.tools@gmail.com>
|
|
|
|
(cherry picked from commit 968b0ca9440040a2b31248a572891f0e55c1ab10)
|
|
|
|
diff --git a/configure b/configure
|
|
index 59ff1e415dda4fbf..117b48a421792eda 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -7020,7 +7020,7 @@ void foo (void)
|
|
}
|
|
EOF
|
|
if { ac_try='${CC-cc} $CFLAGS $CPPFLAGS -fPIC -mtls-dialect=gnu2 -nostdlib -nostartfiles
|
|
- conftest.c -o conftest 1>&5'
|
|
+ -shared conftest.c -o conftest 1>&5'
|
|
{ { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_try\""; } >&5
|
|
(eval $ac_try) 2>&5
|
|
ac_status=$?
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 65799e56852a5356..19b88a47a52508a1 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1297,7 +1297,7 @@ void foo (void)
|
|
}
|
|
EOF
|
|
if AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS -fPIC -mtls-dialect=gnu2 -nostdlib -nostartfiles
|
|
- conftest.c -o conftest 1>&AS_MESSAGE_LOG_FD])
|
|
+ -shared conftest.c -o conftest 1>&AS_MESSAGE_LOG_FD])
|
|
then
|
|
libc_cv_mtls_dialect_gnu2=yes
|
|
else
|